Port forwarding not working on archer C6

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Port forwarding not working on archer C6

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Port forwarding not working on archer C6
Port forwarding not working on archer C6
2021-07-05 19:51:42 - last edited 2021-07-07 13:31:17
Model: Archer C6  
Hardware Version:
Firmware Version:

Hello, as per the subject, I can't open the ports on my Archer C6. I need this for soulseek, and I'm using soulseek's tool to check wheter the ports are open - they are not. I followed the guides (advanced/NAT forwarding/Virtual servers). I entered the ports that SLSK needs, and my computer's IPv4 address.

I was able to open the ports with the previous router, which was also TP Link, but older.

I'm on win 10, but it's clearly a problem with the new router.

Anyone can help?

Thank you.

 

  0      
  0      
#1
Options
2 Accepted Solutions
Re:Port forwarding not working on archer C6-Solution
2021-07-07 11:37:40 - last edited 2021-07-07 13:31:20

@Onavi 

 

1. You can configure DMZ on C6 to isolate the port-forwarding problem:

 

 

In this example 192.168.1.100 the IP address of your Soulseek PC, make a test if it works correctly.

2. You can disable Windows 10 firewall to isolate the Windows firewall problem - make a test if it works correctly.

If this was helpful click on an arrow pointing upward. If this solves your issue, click the star to mark it as a "Recommended Solution".
Recommended Solution
  0  
  0  
#7
Options
Re:Port forwarding not working on archer C6-Solution
2021-07-07 13:30:36 - last edited 2021-07-07 13:31:17

@terziyski thank you! Fixed.

 

The DMZ doesn't work, but disabling the firewall does open the ports! It was indeed a problem with the firewall (the following for anyone who might have the same problem) I had to allow Soulseek through the firewall, but for some reason the app is listed twice in the firewall settings. I had to check "allow" on both listings.

It's going now, thank you again for your time.

Recommended Solution
  0  
  0  
#8
Options
7 Reply
Re:Port forwarding not working on archer C6
2021-07-05 22:58:58 - last edited 2021-07-06 12:27:52

@Onavi 

 

If you haven't changed anything on your PC, where the Soulseek is installed, then just replicating NAT-forwarding rules from your old router to the C6 should suffice.

Just make sure the C6 UPnP is enabled and it's Internet IP address is public.

Here some guides for Soulseek NAT-forwardig settings:

https://www.wikihow.com/Optimize-Soulseek-for-Downloading-Music

https://www.theloadguru.com/soulseek-configuration/

Otherwise you just may have problems with Windows firewall on the PC - make sure the network location type is set as Private - here's a reference.

If this was helpful click on an arrow pointing upward. If this solves your issue, click the star to mark it as a "Recommended Solution".
  0  
  0  
#2
Options
Re:Port forwarding not working on archer C6
2021-07-06 06:12:30

@terziyski 
I was wrong, the previous router was not TPLink, but linksys. Anyway it was very easy to open the ports (as it apparently is here too).

How do I check whether the IP is public?
Yes, the UPnP is enabled, and is does show me the two ports that SLSK is using, and the correct internal IP address. But still my ports are closed (as I can also tell by how few people are downloading my files).

Slsk is allowed through the firewall, as it was with the previous router - as I said, I haven't changed anything but the router.

  0  
  0  
#3
Options
Re:Port forwarding not working on archer C6
2021-07-06 12:50:39 - last edited 2021-07-07 02:57:36

@Onavi 

 

Here you can check your Internet port IP address:

 

 

If it is not in the following ranges then it's public:

Have you checked your network location type ? It should be "Private network" to be sure that Windows 10 firewall not blocking these ports.

Open Network and Internet settings in Windows 10 and check the status:

If this was helpful click on an arrow pointing upward. If this solves your issue, click the star to mark it as a "Recommended Solution".
  0  
  0  
#4
Options
Re:Port forwarding not working on archer C6
2021-07-06 16:16:53 - last edited 2021-07-06 16:23:03

@terziyski 

Thank you for the answers. I changed the network to "private", but the ports are still closed.

 

I tried one trick: since torrent clients can "force" the ports open, I launched two of them and told each one to open the ports that slsk uses (56051 for one and 56050 for the other). Then I checked again and they are indeed open. It's not a very practical solution though, but it might give a hint as to what the issue is.

  0  
  0  
#5
Options
Re:Port forwarding not working on archer C6
2021-07-07 06:16:10

Any ideas?

  0  
  0  
#6
Options
Re:Port forwarding not working on archer C6-Solution
2021-07-07 11:37:40 - last edited 2021-07-07 13:31:20

@Onavi 

 

1. You can configure DMZ on C6 to isolate the port-forwarding problem:

 

 

In this example 192.168.1.100 the IP address of your Soulseek PC, make a test if it works correctly.

2. You can disable Windows 10 firewall to isolate the Windows firewall problem - make a test if it works correctly.

If this was helpful click on an arrow pointing upward. If this solves your issue, click the star to mark it as a "Recommended Solution".
Recommended Solution
  0  
  0  
#7
Options
Re:Port forwarding not working on archer C6-Solution
2021-07-07 13:30:36 - last edited 2021-07-07 13:31:17

@terziyski thank you! Fixed.

 

The DMZ doesn't work, but disabling the firewall does open the ports! It was indeed a problem with the firewall (the following for anyone who might have the same problem) I had to allow Soulseek through the firewall, but for some reason the app is listed twice in the firewall settings. I had to check "allow" on both listings.

It's going now, thank you again for your time.

Recommended Solution
  0  
  0  
#8
Options

Information

Helpful: 0

Views: 1055

Replies: 7

Related Articles