Archer C80 not connecting to Internet (BT)

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
12
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer C80 not connecting to Internet (BT)
Archer C80 not connecting to Internet (BT)
2021-08-02 21:55:09 - last edited 2021-08-04 05:57:26
Model: Archer C80  
Hardware Version: V1
Firmware Version: 1.5.3 Build 210128 Rel.64503n(4555)

I recently purchased an Archer C80 to replace my BT Home Hub 4.

 

I've set everything up but the Archer refuses to give me an internet connection. The internet LED is red. I am using an ADSL broadband (not fibre) connection, which is connected to a separate TP-Link (TD-W9970) which is set to bridge mode. The TD-W9970 is connected to my Archer via WAN. My TD-W9970 has an internet connection and I have confirmed when connecting it to my PC, I have access to the internet. It doesn't do this in bridge mode (which I will assume is intentional; a bridge mode router is not designed to operate directly into a computer, correct?).

 

Carrying on, my TD-W9970 is connected to my Archer via the WAN port. The Archer works fine and all the settings appear functional but I have no internet connection. I have contacted BT and they confirmed there is no configuration error or the sort on the line which should prevent my router from working (such as it having a MAC address registered, which I explicitly asked about). I have tried the following too to get my connection to work, but to no avail:

 

  • Setting the Archer to Dynamic IP yields no result.
  • Setting the Archer to PPPoE does not work. I have ensured the login (bthomehub@btbroadband.com and the password BT) is correct.
  • Setting the VLAN ID to 101, as many users on the BT forums advised. This has not helped. The two VLAN ids other than Internet (IPTV and VoIP) were set to random values since I assume they do not matter.
  • I've tried switching off NAT to see if it resolved any issues, but it did not.
  • Factory resetting both routers and redoing the process
  • Power cycling both routers (the bridge only router first, then the Archer)

 

A small query, I'm told I should be using PPPoA, but this router only has PPPoE available. Does this matter? As long as I'm routing the ADSL through my TD-W9970, PPPoE should work, correct?

 

I'm incredibly stuck at this point and have no idea why the Archer refuses to acknowledge my bridge connection. I've been at this all evening to no avail. Does anybody have a solution or some advice?

  0      
  0      
#1
Options
1 Accepted Solution
Re:Archer C80 not connecting to Internet (BT)-Solution
2021-08-03 15:47:46 - last edited 2021-08-04 05:57:26

@terziyski I've got it working with Dynamic IP - thank you so much! I feel like a dumb for not realising the difference between PPPoA and PPPoE was so significant... thanks for the help!

Recommended Solution
  0  
  0  
#13
Options
12 Reply
Re:Archer C80 not connecting to Internet (BT)
2021-08-02 23:13:17 - last edited 2021-08-03 01:27:00

@Gerbil 

 

Check this story - it's about pretty much the same configuration as yours.

From BT can confirm if you have to use PPPoE or PPPoA - I would bet on PPPoE.

You may test your BT credentials and TD-W9970 like so:

TD-W9970 configured in bridge mode. Connect it to the PC with a LAN cable.

Then setup PPPoE connection on your PC.

Here's how to add a VLAN ID on a Intel network adapter using PowerShell if you need to.

Upon successful connection your credentials are OK and the TD-W9970 works fine in bridge mode.

If this was helpful click on an arrow pointing upward. If this solves your issue, click the star to mark it as a "Recommended Solution".
  3  
  3  
#2
Options
Re:Archer C80 not connecting to Internet (BT)
2021-08-03 08:49:52

@terziyski Thank you! I didn't know I could set up a PPPoE directly on the computer to test bridge mode - I'll do that right away and update on how things go. I'll also check the other thread, in case there's any assistance there I've missed.

  0  
  0  
#3
Options
Re:Archer C80 not connecting to Internet (BT)
2021-08-03 09:24:52

I've tried setting up a PPPoE connection on my PC whilst connected to the modem in bridge mode.

I put in the login bthomehub@btbroadband.com and the password bt (as they were on my Home Hub).

I get the error code 651 and no connection is established.

 

Does this mean my TD-W9970 is configured incorrectly in bridge mode? I've been doing the following process to activate bridge mode:

 

Quick Setup

Input timezone and region as normal

Select 'Other' as ISP

Select 'Bridge' as connection type, with VPI 0 and VCI 38, and VLAN ID 101.

Disable wireless.

Hit done.

 

This doesn't seem to push a PPPoE connection to my PC (although I did not try setting the VLAN via PowerShell, though I'm not sure how I would do that if it isn't allowing me to set up the connection in the first place due to the error code) or my router. Any ideas?

  0  
  0  
#4
Options
Re:Archer C80 not connecting to Internet (BT)
2021-08-03 11:01:43

@Gerbil 

 

Follow this guide to troubleshoot the error.

Don't use the PowerShell script for VLAN ID, you're doing it right so far.

If this was helpful click on an arrow pointing upward. If this solves your issue, click the star to mark it as a "Recommended Solution".
  0  
  0  
#5
Options
Re:Archer C80 not connecting to Internet (BT)
2021-08-03 12:44:04

@terziyski I've followed the troubleshooting guide. Just a quick query: do I need the TD-W9970 in bridge mode while I'm testing it's PPPoE connection to my PC? My family have been using the internet via it while I figure out the issue and I've been trying to keep disconnects to a minimum, so I have tested the following with bridge mode off so that they can use the internet. (My attempts in my previous post were done with bridge mode on). If I need to test these with bridge mode on, please let me know.

 

I've tried from the guide:

  • I can confirm that both in and out of bridge mode, the DSL light is solid green on the TD-W9970.
  • I've tried remaking the connection in Control Panel, didn't help.
  • I ran an 'sfc /scannow' on my PC to check if raspppoe.sys or a similar file was damaged. It did find damaged files and repair them but the issue still persists, so they were likely not network files.
  • Disabling my antivirus did not help.
  • I've rebooted my PC and both routers.
  • I've disabled IPv6 on the connection. (I don't have an option to set Link Speed & Duplex?)

 

Just to clarify, I'm using Windows 10.

I still receive error code 651 after trying those steps.

  0  
  0  
#6
Options
Re:Archer C80 not connecting to Internet (BT)
2021-08-03 13:01:44

@Gerbil 

 

Yes, to be able to connect the PPPoE session from your PC you have to be in bridge mode on the modem.

If Internet access is mandatory at the moment, just do these tests while noone uses it (at the evening maybe).

And yes, the guide is for Windows 7, but I believe it's apllicable for Windows 10 too.

If you still can't resolve this error try these instructions.

If nothing helps then proceed with configuring PPPoE session in C80 while connected to the bridged modem and test.

If this was helpful click on an arrow pointing upward. If this solves your issue, click the star to mark it as a "Recommended Solution".
  0  
  0  
#7
Options
Re:Archer C80 not connecting to Internet (BT)
2021-08-03 13:16:10

@terziyski Alright, I'll test everything in bridge mode in a few hours when everybody is no longer using the internet and I can arrange to turn it off for a bit

  0  
  0  
#8
Options
Re:Archer C80 not connecting to Internet (BT)
2021-08-03 13:42:35 - last edited 2021-08-03 14:05:44

@terziyski Ok, fortunately there was a convenient window in which nobody was using the internet too much, so I've been able to run the tests quickly now.

 

I tried the same things mentioned in my previous post with the modem in bridge mode, but I am still receiving error code 651.

 

I also tried updating the Ethernet drivers as shown in the instructions you provided, along with ensuring other network drivers were up to date for good measure. However I'm still receiving the error code.

 

I've loaded up my C80 and my computer is now detecting it as an actual network instead of "Unidentified network", which is a good sign, but I still have no connection.

 

Just to avoid any confusion, I should have the Ethernet cable connecting the two routers plugged into the WAN port of both routers, correct? So from the TD-W9970's LAN4/WAN port to the C80's WAN port?

Edit: Just thought it was also worth mentioning that the C80's IP Address shows as 0.0.0.0, like it is not being assigned an IP address over the bridge, if that info helps. Also, the TD-W9970 is using PPPoA for it's working connection; would that be an issue as the other tests and the C80 are attempting to use PPPoE? The C80 doesn't seem to have an option for PPPoA; would that matter?

  0  
  0  
#9
Options
Re:Archer C80 not connecting to Internet (BT)
2021-08-03 15:00:12

@Gerbil 

 

Oops, we should've clarified this from the very beginning - I was going to ask if you have confirmed it with BT (my first post).

If TD-W9970 is using PPPoA for its working connection, then it won't work for sure - C80 doesn't support PPPoA.

The error is probably caused by that when you're trying to connect with PPPoE (from PC or C80).

As long as TD-W9970 is in DSL Modem Router Mode connecting it to LAN4/WAN is fine.

Well, there are two more options left:

1. C80 in router mode connected to its WAN port to TD-W9970 (Wi-Fi disabled) - this way you'll have a double NAT in your network, but all C80 features will be active.

2. C80 in AP mode (Case 1) connected to its WAN port to TD-W9970 - no double NAT, but with limited features, extending wireless coverage in your home.

 

If this was helpful click on an arrow pointing upward. If this solves your issue, click the star to mark it as a "Recommended Solution".
  0  
  0  
#10
Options
Re:Archer C80 not connecting to Internet (BT)
2021-08-03 15:02:27 - last edited 2021-08-03 15:03:03

@terziyski How can I get option 1 working? I'd like to take advantage of the C80's features. Also, if I disable NAT on the TD-W9970, would that prevent double NAT issues?

 

How do I connect the C80 to the TD-W9970 in this way? Is it done in the same way (WAN-port to WAN-port) but with different settings, such as a different connection type?

 

Also, I got in touch with BT and I have discovered that PPPoA is the required connection method. Sorry I didn't clarify that.

  0  
  0  
#11
Options

Information

Helpful: 0

Views: 1181

Replies: 12

Related Articles