TP Link TL-WN781ND wireless adapter - problems

TP Link TL-WN781ND wireless adapter - problems
TP Link TL-WN781ND wireless adapter - problems
2013-03-25 02:31:36
Region : UnitedKingdom

Model : TL-WN781ND

Hardware Version : Not Clear

Firmware Version :

ISP : EE


Hello forum,

I bought a new PC recently and installed one of the above wireless adapters, for home use. Running Windows 7 Ultimate x64.

The adapter came with a "resource CD", from which I was able to install the driver software. This was successful.

However, the adapter is proving to be a little temperamental with my home router - an Orange/EE "Brightbox". The signal strength is good (typically 4 out of 5 bars showing in my taskbar) but attempts to connect often fail. I'm repeatedly asked for the password too. I'm online now, but it took about 10 failed attempts before it worked.

Once connected, the connections are stable (so far) but getting the initial connection is proving to be a real headache. Other devices in my home connect with no trouble at all.

Can anyone suggest what the problem might be please?

Grateful for any advice/suggestions,
Alan.
0
0
#1
Options
2 Replies
Re:TP Link TL-WN781ND wireless adapter - problems
2013-03-26 19:06:02
Hmm, a little strange. maybe you can try to change the wireless channel of your router to 6 or 11 to avoid channel conflict...
0
0
#2
Options
Re:TP Link TL-WN781ND wireless adapter - problems
2013-03-27 00:23:22
Many thanks. A friend made the same suggestion actually.

I checked the router settings. Router was broadcasting on two channels at the same time (?) - 6 and 11.

Switched the dual broadcast thing off and it defaulted to channel 6. PC not happy - still reluctant to connect.

Neighbours' networks all on 1, 6 or 11 so I swapped mine to 12. It worked. Connected first time, hasn't dropped off yet. Fingers crossed.

Many thanks!
0
0
#3
Options