extremly slow speed with wds

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

extremly slow speed with wds

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
extremly slow speed with wds
extremly slow speed with wds
2013-04-26 06:30:51
Region : Others

Model : TL-WR841ND

Hardware Version : V8

Firmware Version : wr841nv8_en_3_13_27_up_boot(121101)

ISP :


Hi all,
I followed TP-Link's guide to set up a WDS connection between my two brand new WR841ND router. It theoreticaly "works", but the network is extremly slow.
Copying a ~100 Mb sized file to another computer on the other side takes more than 10 minutes or more, I don't know exactly, because I shut down the process after 10 min.
I pinged the "slave" router with 200 packets, and I realized that every third, fourth and fifth packet has more than 500 ms time. The minimum is 4 ms, the longest was 566 ms.

Router A (Master)
Connects to the internet/ADSL
DHCP enabled
IP: 192.168.2.1
SSID: something
mode: 11n only
chanel: 5
WDS: not ticked
WIFI security: WPA2-PSK/AES
password: blabla

Router B (Slave)
DHCP: disabled
IP: static 192.168.2.2
SSID: something-1 (slightly different than above
mode: 11n only
chanel: 5
WDS: ticked
SSID to bridge: something
BSSID: MAC address of Router A
WIFI security: WPA2-PSK/AES
password: blabla (same as above)

I bought the two router from the same dealer, at the same time. Both have the same firmware.
I checked all the chanels, and 5 is the only free one, but the situation is the same on every chanel.

What can couse this very slow transfer speed? Did I something wrong?
  0      
  0      
#1
Options
5 Reply
Re:extremly slow speed with wds
2013-04-26 19:17:42
What is the distance between the 2 TL-WR841ND now ? Maybe you can move the second one more closer to the first one. Is there any improvement ?
  0  
  0  
#2
Options
Re:extremly slow speed with wds
2013-04-26 21:08:27
I wouldn't set a static channel to 5 as this prevent the WIFI router from selecting the best channel with the least radio interference.

Moreover, try narrowing your bandwidth from 40Mhz to 20 Mhz, especially if you have a few WIFI routers in your neighborhood. 40 Mhz is more sensitive to interference than 20 Mhz. Your speed may increase even if you think that the maximum speed is limited to 130 mbps (instead of 300 mbps... but this is only theoretical)

Finally the location of your router could also be an issue. If possible, put your router is in a central position of your house and not too near to a wall (this is again to improve the WIFI radio signal and avoid interference )
  0  
  0  
#3
Options
Re:extremly slow speed with wds
2013-04-27 04:19:52
Very important is signal level on second router from main router in WDS configuration. Especially when you made setting 11n only.
  0  
  0  
#4
Options
Re:extremly slow speed with wds
2013-05-01 10:51:00
Hello there,

How is your test setup? you have a PC wired to the first router and a second wired to the other? or both are wireless? a mix? Also remember that the wifi speeds are theorical but your speed is so slow that there is an issue. I have a setup similar as yours (WD841 to WD 741) so I might be helping as mine works (90% of the times)

I would first try without the 11n restriction. Try 11bgn and check what happens. Also beware of DECT wireless phones in the vecinity of routers, they tend to scramble the signal, but if you have high signal strength (>40 or 50db) you should be fine. I also have a fixed channel so I can't tell if this is bad. Also try to make the 2 router closer to see it the speed improves.

thx
AV
  0  
  0  
#5
Options
Re:extremly slow speed with wds
2013-05-04 06:48:20
Hi everybody,

Sorry for not replying until now, but I didn't had time to work on this network in the past few days (this is not mine, but one of my friend's).
I read your answers and I will try them, but at this moment I ran into another issue with these two routers.
In the begining I was focusing on WDS connection, and I didn't take care of ADSL connection, which is also not working (can't connect to the ISP). So I made a hard reser on them, and setup just the PPPoE connection, and checked everything hundred times, but none of them connects to the ISP. The arey always at "Connecting..." phase.
Strange.
I know that at this point I seem like stupid, but I made such networks many times. This network "layout" already worked here for 5 years already, we just wanted to renew the devices, maybe we coud gain better network speed.

Here are a few answer to your questions:
The distance bewteen the to TP-Link devices is about 20 m. They are installed next to the windows, not behind thick walls.
Unfortunately I can't move them closer at the end, but when I was setting them for the first time, they were siting next to each other, and the ping gave almost the same bad result.
Before the hard reset, I ran the Lan SpeedTest with 20 Mb of data, and on the old network (which I'm using now again) had 13 Mbps up and down speed, and the speed of the two TR-841ND was 16Mbps up and 4 Mbps down.
Unfortunately there are at least 5 wifi networks in the neighborhood.
I was thinking on fixing the chanel as every router of mine was trying to use chanel 11 all the time, even if it was completly full, and the other chanels were completly free. I used to check the chanels with wifianalyzer on my mobile, to find out which chanels are free.


The network will look like the following at the end (and it works like this at the moment but with very old devices).
1 computer connects wired to the WR841_slave.
3 computers and 1 printserver connects to the WR841_master router.
Master must connect to the internet trough the ADSL modem also.
No device must connect wirelessly to this network.
  0  
  0  
#6
Options

Information

Helpful: 0

Views: 8024

Replies: 5

Related Articles