Can't access the internet in client mode

Can't access the internet in client mode
Can't access the internet in client mode
2013-05-08 04:12:29
Region : UnitedKingdom

Model : TL-WR702N

Hardware Version : V1

Firmware Version : 4.18.114 Build 130314 Rel.39604n

ISP :


Hi there,

I've setup my nano router in client mode and successfully connected it to my existing wireless network by manually setting it's IP address to 192.168.1.2. The existing router has the IP address 192.168.1.1.

I know this has worked as I'm able to access the web management page from any computer in the house by visiting the IP address 192.168.1.2. So far so good.

However, my problem is that the nano router cannot speak to the internet. If I login to the web management page and go to diagnostics, I can ping every other device on the network fine, but I can't ping anything outside the network (e.g. 8.8.8.8 or http://www.google.co.uk).

I've tried in vain to get this setup correctly, all I can assume is that the nano router isn't correctly determining that the existing router (192.168.1.1) is where it should be routing all external requests and they're just getting lost, but there's no configuration for that on the web management pages.

Thanks for any help!
Nick

------------------------------------------------------------------------------

Solution:
It turns out the solution, at least for me anyway, was to change the 'WDS mode' on the TL-WR702N to use ' 3 Addr' mode rather than ' Auto'.
Hope this helps!
0
0
#1
Options
21 Replies
Re:Can't access the internet in client mode
2013-05-08 16:38:00
On the computer connected to the client, are you able to ping 8.8.8.8 and google.com?
0
0
#2
Options
Re:Can't access the internet in client mode
2013-05-08 19:14:31

Matthew cook wrote

On the computer connected to the client, are you able to ping 8.8.8.8 and google.com?

Nope.
0
0
#3
Options
Re:Can't access the internet in client mode
2013-05-13 15:14:43
with the computer connected to the TL-WR702N Client by LAN cable, you may check if the computer is able to automatically obtain an appropriate IP address assigned by the main router's DHCP through the client. Then try to ping the main router on this computer.
0
0
#4
Options
Re:Can't access the internet in client mode
2013-05-13 15:28:15

Matthew cook wrote

with the computer connected to the TL-WR702N Client by LAN cable, you may check if the computer is able to automatically obtain an appropriate IP address assigned by the main router's DHCP through the client. Then try to ping the main router on this computer.

I've checked this. The only way I can get the computer to connect is to either enable DHCP on the TL-WR702N (which obviously I don't want to do) or to manually configure the computer.
0
0
#5
Options
Re:Can't access the internet in client mode
2013-05-13 15:42:42
Yes. You are right. DHCP should be disabled on TL-WR702N. I am not sure what's going on with your configuration.
Now that in repeater mode, it can extend the original wifi and meanwhile the LAN port is applicable to the other device, like a desktop. At this point, you may give a try on repeater mode.
0
0
#6
Options
Re:Can't access the internet in client mode
2013-05-13 15:47:13

Matthew cook wrote

Yes. You are right. DHCP should be disabled on TL-WR702N. I am not sure what's going on with your configuration.
Now that in repeater mode, it can extend the original wifi and meanwhile the LAN port is applicable to the other device, like a desktop. At this point, you may give a try on repeater mode.

I've already tried on repeater mode as well and I had the same problems, but obviously in repeater mode it also impacted on anyone connecting to the TL-WR702N via WiFi as well as LAN.
0
0
#7
Options
Re:Can't access the internet in client mode
2013-05-15 15:22:46
The DHCP should be disabled on the repeater/client.
Please answer this question:
with the computer connected to the TL-WR702N Client by LAN cable, is the computer able to automatically obtain an appropriate IP address assigned by the main router's DHCP through the client? ( under the condition that the computer is set to "obtain an IP address automatically" and disable DHCP on the WR702N).
If you can not obtain an appropriate IP address through the client, you may try to manually configure a proper static IP address and DNS as 8.8.8.8 on the computer and then see if you can access internet through the client.
0
0
#8
Options
Re:Can't access the internet in client mode
2013-05-15 15:24:50
By the way, are you able to access internet on another computer connected to the WR702N client via LAN cable?
0
0
#9
Options
Re:Can't access the internet in client mode
2013-05-15 15:32:03

Matthew cook wrote

with the computer connected to the TL-WR702N Client by LAN cable, is the computer able to automatically obtain an appropriate IP address assigned by the main router's DHCP through the client?

Nope.

manually configure a proper static IP address and DNS as 8.8.8.8 on the computer and then see if you can access internet through the client.

Nope.

are you able to access internet on another computer connected to the WR702N client via LAN cable?

The original reason I bought this was so I could connect my YouView box to the WiFi. The YouView box behaves just like my computer.
0
0
#10
Options
Re:Can't access the internet in client mode
2013-05-15 16:12:15
Please give a try as the following:
On WR702N's web page, go to DHCP, enter the LAN IP address of your wireless router into "default gateway" on the DHCP server page.
Don't forget to reboot the WR702N.
Then see if the computer able to automatically obtain an IP address.
Does this make any difference?
0
0
#11
Options