Slow speed when using Archer C80 as a repeater

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Slow speed when using Archer C80 as a repeater

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Slow speed when using Archer C80 as a repeater
Slow speed when using Archer C80 as a repeater
2022-04-13 16:41:10
Model: Archer C80  
Hardware Version:
Firmware Version:

Hello!

 

I have 2 routers: Archer C64 as WAN input and Archer C80 as a wi-fi repeater. The routers are connected using long 50m ethernet cable. When I connect a PC to far end of the cable directly without C80, I can get 300mbit/s speed (the limit is set by provider). But if I connect far end to C80 and then with a short cable to PC, I get 90mbit only.

The phone, connected to C64 shows 300mbit through the wi-fi, but same phone, connected to C80, shows 90 mbit only.

Looks like C80 in repeater mode drops the speed to 100mbit range.

 

300mbit:  WAN->C64->>>>><50m cable>>>>>>PC

90mbit:    WAN->C64->>>>><50m cable>>>>>>C80->PC

 

Is this expected?

  0      
  0      
#1
Options
1 Reply
Re:Slow speed when using Archer C80 as a repeater
2022-04-13 19:21:05 - last edited 2022-04-13 19:29:29

  @Mikhaill 

 

In your C80 check the WAN port negotiated speed - it's probably only 100mbps instead 1000mbps:

 

 

For some reason C80 doesn't like the cable and negotiates a lower speed.

Try with the shorter cable closer to C64 and check if that makes any difference.

If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
  4  
  4  
#2
Options

Information

Helpful: 0

Views: 716

Replies: 1

Related Articles