Archer C2300: Devices do not see each other when both on 5GHz wifi

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Archer C2300: Devices do not see each other when both on 5GHz wifi

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer C2300: Devices do not see each other when both on 5GHz wifi
Archer C2300: Devices do not see each other when both on 5GHz wifi
2022-06-13 06:53:18 - last edited 2022-06-13 08:59:08
Model: Archer C2300  
Hardware Version: V1
Firmware Version: 2.0.5 Build 20220114 Rel. 55007(4555/4445)

Hi,

 

I recently realized when I connect 2 devices to the 5GHz network, they don't see each other.

 

(Note that I'm NOT using the Guest WIFI which has the feature to prevent the clients from seeing each other)

 

I set up http server on port 80 on my mac and try to connect to the default "It works!" Apache page from an iPhone and an ethernet connected linux server.

 

It works when:

1. iPhone 2.4GHz -> mac 5GHz

2. linux server -> mac 5GHz

3. iPhone 5GHz -> mac 2.4GHz

4. linux server -> mac 2.4GHz

 

I'm also able to (both directions)

5. iPhone 2.4GHz <-> linux server

6. iPhone 5GHz <-> linux server

7. mac 2.4GHz <-> linux server

8. mac 5GHz <-> linux server

 

It doesn't work only and only when (I realize now I didn't try the opposite direction):

1. iPhone 5GHz -> mac 5GHz

 

I tried to shuffle all the following configurations:

1. enable / disable Guest wifi for both 2.5GHz and/or 5GHz to prevent interference

2. reboot Archer (multiple times)

3. install newest firmware

4. try all possible security configurations (AES, TKIP, WEP, WEP2)

5. try all channels

6. try all channel widths

7. toggle different other features like MIMO, IPTV, Firewall

 

Regardless of what try, the 2.4 GHz network work just fine.

With the 5GHz wifi, the router acts as if the IP Forwarding was simply disabled.

 

I also checked and both the iPhone and the mac have the same client wifi configuration for both the 2.4 and 5 GHz networks. But even if it wasn't, the fact that I'm able to reach the mac on 5GHz from a local ethernet connected linux server imho implies the problem lies in the router.

  0      
  0      
#1
Options

Information

Helpful: 0

Views: 134

Replies: 0