Open VPN - no Internet when connected at new firmware

Open VPN - no Internet when connected at new firmware

Open VPN - no Internet when connected at new firmware
Open VPN - no Internet when connected at new firmware
2022-11-16 21:30:08
Model: ER7206 (TL-ER7206)  
Hardware Version: V1
Firmware Version: 1.2.3

Hello,

Just found a sime kind of bug after the 1.2.1 -> 1.2.3 Build 20221104 update.

Have 2 Open VPN servers (for 2 WAN's, normal and backup-link - both of them 24/7 active) - set up for remote connections + RDP office workers.
Until update all worked fine.
At 11.11.2022 updated OC200 to 5.6.4 and ER7206 from 1.2.1 to 1.2.3.
After that at both VPNs - connection to internet seems like cut down after OpenVPN Client connect to Omada Server.
The thing is that RDP, programs that use LAN connection (accounting, sql etc. progs) works well as before, but we cannot access any website, send e-mail etc. from workstation.

Check "cmd ping yahoo dot com" - cannot find.
BUT when I type for example "ping 8.8.8.8" - it is working. Seems like problem with DNS/Gateway.
Tried to set up DNS at new OpenVPN options in Omada system - no result, still the same. Tried 8.8.8.8, 8.8.4.4, DNS from our ISP, still the same situation.

To let coworkers do their job - I roll back to 1.2.1 firmware at ER 7206. Reboot Router & OC200 and it worked as before.

Could anyone check what is cousing the problem? Some software bug?

  0      
  0      
#1
Options
6 Reply
Re:Open VPN - no Internet when connected at new firmware
2022-11-18 06:10:47

  @Dyspozytor 

 

Everything is working fine with my own OpenVPN, and I just tested it locally and found no problems.

Suggest you can check the openvpn client software, is there an option to set proxy internet access on the client?

Suggest you can grab the packet to see if the DNS is not replying?

  0  
  0  
#2
Options
Re:Open VPN - no Internet when connected at new firmware
2022-11-22 18:44:12

  @Virgo 

Hello, thank You for the answer.

You suggest to set the proxy at what adress? Default gateway of OpenVPN server (tunnel all packets?)?

At OpenVPN Connect Client there is a such proxy option.

 

But why with lower/older firmware all is working fine?

 

  0  
  0  
#3
Options
Re:Open VPN - no Internet when connected at new firmware
2022-11-24 03:41:48

  @Dyspozytor 

 

I'm not quite sure what the exact interface of the Client you're using looks like.
If you could provide a screenshot showing the question you are currently asking, maybe I'd understand.

 

In addition, if the OpenVPN server is set up on the current gateway, it does not support proxy internet access.

  0  
  0  
#4
Options
Re:Open VPN - no Internet when connected at new firmware
2022-11-24 11:34:26

Hello,

 

  @Virgo 

You asked "is there an option to set proxy internet access on the client?"



What should I fulfill at this?

  0  
  0  
#5
Options
Re:Open VPN - no Internet when connected at new firmware
2022-11-25 06:05:52

  @Dyspozytor 

 

In my opinion, no need to add Proxy.

I can connect directly to my OpenVPN server and do not need to set up a proxy.

  0  
  0  
#6
Options
Re:Open VPN - no Internet when connected at new firmware
2022-11-25 10:47:34

  @Virgo 

"I can connect directly to my OpenVPN server and do not need to set up a proxy."

And me too.

The thing is that only at older firmware I can use normaly internet when connected to OpenVPN.
At newer firmware I only can access local adresses (by IP), could not use any dns adress (like any yahoo dot com, google dot com etc. - same story with using e-mail by smtp/imap)

  0  
  0  
#7
Options

Information

Helpful: 0

Views: 147

Replies: 6

Related Articles