Archer GX90 - MU-MIMO and Beamforming

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Archer GX90 - MU-MIMO and Beamforming

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer GX90 - MU-MIMO and Beamforming
Archer GX90 - MU-MIMO and Beamforming
2024-01-15 10:21:33 - last edited 2024-01-15 16:33:19
Tags: #Beamforming
Model: Archer GX90  
Hardware Version: V1
Firmware Version: 1.1.4 Build 20231117 rel.54217(5553)

Hello.

 

I would like to know if the MU-MIMO and Beamforming are enabled by default in the GX90 because I didn´t find it into the router settings.

Thanks a lot !

  0      
  0      
#1
Options
1 Accepted Solution
Re:Archer GX90 - MU-MIMO and Beamforming-Solution
2024-01-15 16:33:07 - last edited 2024-01-15 16:33:19

  @terziyski  Thanks a lot, it worked !

Recommended Solution
  0  
  0  
#3
Options
2 Reply
Re:Archer GX90 - MU-MIMO and Beamforming
2024-01-15 16:31:25

  @JPromano 

 

Initially MU-MIMO setting was here:

 

 

In subsequent FW releases it may have been removed and enabled by default - this was the case with some other router models.

Same goes for the Beamforming.

If you use the Smart Connect feature try turning it off and check if you have the MU-MIMO feature at the bottom (like in the screenshot above).

If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
  1  
  1  
#2
Options
Re:Archer GX90 - MU-MIMO and Beamforming-Solution
2024-01-15 16:33:07 - last edited 2024-01-15 16:33:19

  @terziyski  Thanks a lot, it worked !

Recommended Solution
  0  
  0  
#3
Options

Information

Helpful: 0

Views: 308

Replies: 2

Tags

Beamforming
Related Articles