RE315 Extender does not work with my iPhone 15 Pro

RE315 Extender does not work with my iPhone 15 Pro

RE315 Extender does not work with my iPhone 15 Pro
RE315 Extender does not work with my iPhone 15 Pro
2024-06-05 11:09:37
Model: RE315  
Hardware Version: V1
Firmware Version: 1.0.30 Build 230919 Rel.52342n

Hello,

 

recently i started having very weird problems connecting my iPhone 15 Pro to a Wi-Fi extender TP-Link RE315.

 

Extender is set as access point and has been for the past few months, during which it worked fine. The ethernet cable goes to the RE315 directly from a switch.

 

The iPhone in question will connect to the Wi-Fi (both 2,4GHt and 5GHz), however internet does not work and also a "no internet connection" message is shown (see screenshots.

 

The iPhone works with all other wifi networks in and outside of the company.

 

But now the weird things will start.

 

1.) In the TP-LINK app on the iPhone, i can't even see the RE315 and i can't connect to it.

2.) In the app is shown some weird router TD-W9960 which is not used anywhere in the company. I confirmed with IT dpt.

3.) Different phones can see the RE315 without issues and they do not see the above mentioned TD-W9960 in the app

4.) Sometimes the iPhone is shown as connected to the 5GHz network on other phone but shows different IP address and is recognized as computer for some reason

5.) The iPhone is working with the extender fine when it is used as Wi-Fi extender, however when connected to ethernet as access point, it suddenly stops seeing it and working with it. To go back to the point 3, the weird router is not visible when iPhone is connected to the wifi when extender mode is selected, only when access point mode is selected.

 

From troubleshooting we tried following, however nothing solved the issue:

 

1.) Restart of the RE315

2.) Reset of the RE315

3.) Factory settings reset of the RE315

4.) Tried different connection settings on the iPhone

 

  0      
  0      
#1
Options
1 Reply
Re:RE315 Extender does not work with my iPhone 15 Pro
2024-06-13 03:27:25

  @Luke315 

Hi, 

 

Please keep your iPhone connected to the RE315 and also enable the location permission for the Tether APP, and then refresh the RE315 and check if you can see the device in APP.

 

So is the RE315 now set up as RE mode or AP mode? Please also check if there is any special characters in the SSID. Will only this iPhone cannot see its SSID? Have you tested with other Apple devices?

If you found the post or response helpful, please click Helpful. If an answer solves your problem, click "Recommended Solution" so that others can benefit from it.
  0  
  0  
#2
Options

Information

Helpful: 0

Views: 122

Replies: 1

Related Articles