Crashes with TL-WN822N when using SoftAP

Crashes with TL-WN822N when using SoftAP
Crashes with TL-WN822N when using SoftAP
2014-06-13 05:38:44
Region : Others

Model : TL-WN822N

Hardware Version : V3

Firmware Version :

ISP :


I have a rather weird problem with the TP-Link TL-WN822N v3 wireless adapter.

My problem is as follows:
I bought this wireless USB adapter so I can use it as a software access point (SoftAP, as you call it). I don't really need to get wireless internet on my desktop, as it is directly connected to a cable modem. However, I also have a notebook computer, and it would be a good idea to connect it to the internet. Because my desktop PC is practically always turned on, I don't really need to buy a wireless router, and I learned that TP-Link has a nice SoftAC utility, so I bought only the above wireless USB adapter. I've installed both the official driver (TL-WN822N_V3_130702, published on 7/2/2013) and the utility (TL-WN822N_V3_Utility published on 7/2/2013) from the TP-Link website (the v3 version of the adapter of course). I even managed to get the softAP thing to work nicely through the utility program. However, my desktop PC now hangs (freezes) rather randomly. I don't really use anything else on the adapter besides SoftAP, but when I use it, my desktop PC will crash sooner or later. When the adapter only idles (the LED blinks green), it never freezes, but when I start the SoftAP, that is, when I actually use the adapter, the desktop will crash. The crash it very hard, it's not a BSOD, rather the monitor just shows a static image, the mouse and keyboard doesn't respond, and the funny thing is, when I press e.g. the numlock or capslock keys on the keyboard, the corresponding LEDs on the keyboard won't even turn off/on. So, as I said, its a very "hardcore" crash. I must hard reset the system.

I've tried many things, but none worked. I've tried to turn off some power management stuff, don't really remember what, but it didn't work. Next, I've tried to plug the adapter to another USB port (USB 2.0, USB 3.0, etc.), no effect. Then I've uninstalled the official TP-Link utility, and installed a third-party softAC program, namely, mHotspot. The crash was still there. Then I've started to suspect in the driver, so I've uninstalled the official TP-Link driver, and let Windows to find the adapter by itself. It did, and recognised it as a "Realtek RTL8192CU Wireless LAN" adapter. However, today my desktop crashed again in mHotspot. And now, I'm out of ideas.

I'm playing this game for months, and I don't really know what to do. Is the hardware (the adapter itself) faulty, or is it something else? For a desktop PC that is normally stable as a rock to get hard locks with a wireless adapter is unacceptable.

If you ask, when the crash occurs, it's rather interesting, and I think I narrowed it down to this: the desktop PC crashes a few seconds after I turn off my notebook, that is, when the notebook disconnects itself from the softAP network. I don't know that this will help or not.

At the end, my configuration:
MB: Gigabyte GA-Z87X-D3H (with newest BIOS)
CPU: Intel i7-4770
RAM: 8GB DDR3
GPU: Nvidia GeForce 560 Ti
Audio: Creative SoundBlaster X-Fi on PCI slot
HDDs: 1 Kingston SSD and two HDDs (Hitachi)
OS: Windows 7 64-bit with SP1


I already wrote an e-mail two days ago to the official TP-Link support, but the response was just too generic and not helpful, so I've decided to try here, too.

Thanks!
0
0
#1
Options
4 Replies
What version of windows are you using?
2014-07-09 00:06:07
I'm looking for a driver for windows 8.1 for the tl-wn822N. I just bought it and then upgraded to Windows 8.1. Now the whole system reboots over and over when the adapter is pugged in. Therefor the product is useless until a new driver comes out, or someone can help me a different way.
0
0
#2
Options
TL-WN822N Causing Hard Crashing
2014-07-26 16:00:31
Papsi, I've been experiencing the same problems as you in terms of the hard crashing. Only in the last month or two but it's been persistent and can generally be reproduced by playing a game. It sometimes happens randomly during internet browsing or even if the computer is idle but far more reliably during gaming.

In addition to this it recently got worse. After I powered on my computer, it powered itself off within about 3 seconds. It then powered itself on, and a message appeared saying 'Overclocking Failed', making me go into the BIOS settings to continue. I haven't overclocked so I know this isn't the problem. After a few loops of this, I'm generally able to login to Windows but then the random crashing persists.

All of this led me to believe that it was an issue with either the graphics card (stress tested without issues), memory (ran Memtest86+ without issues), CPU (stress tested without issues).

However for other reasons, I recently removed the TL-WN822N while the computer was switched on and instantly it caused a hard crash in the machine. Ever since, I've been networking using my phone tethered by USB and experienced no issues whatsoever. No hard crashes, and perfect gaming. On the flip side, I'm now using the TL-WN822N in a Debian/Linux machine without issues.

The only similarity in my setup to yours is the Windows 7 64-bit with SP1. So maybe there is a driver issue for this hardware on this version of Windows.

I'll update this thread if I get any crashes in the meantime as this would probably rule out the wireless adapter, but it seems strange that a USB device can cause such hard crashing, and the fact it's happened to both of us over the same kind of time period seems suspicious.
0
0
#3
Options
windows 8.1 crashing
2014-12-22 01:09:45
I'm having the exact same issue with my 8.1 laptop. has anyone resolved this issue yet?
0
0
#4
Options
Re:Crashes with TL-WN822N when using SoftAP
2014-12-22 16:16:16
Yours is TL-WN822N, V3?
It seems that Windows 8.1 is not the supported operating system currently. You tried the driver for Windows 8?
0
0
#5
Options