Archer C9 V1 Beta 4.0.0 firmware - cannot update 'Firmware File Error'

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Archer C9 V1 Beta 4.0.0 firmware - cannot update 'Firmware File Error'

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer C9 V1 Beta 4.0.0 firmware - cannot update 'Firmware File Error'
Archer C9 V1 Beta 4.0.0 firmware - cannot update 'Firmware File Error'
2015-11-12 19:36:13
Model : Archer C9

Hardware Version : 1
Firmware Version : 4.0.0 Build 20150907 Rel. 49201

ISP : Plusnet

Running 4.0.0 Build 20150907 Rel. 49201 (Beta) and just tried to update to c9v1_un-up-ver4-0-0-P18[20150916-rel37772] all I get now is a 'Firmware File Error'. I tried the last two firmwares listed on the support page, but these come up with the same error..

Any help would be much appreciated.
  0      
  0      
#1
Options
2 Reply
Re:Archer C9 V1 Beta 4.0.0 firmware - cannot update 'Firmware File Error'
2015-11-13 00:25:39
Have you tried rebooting the router and the client you are trying to upgrade the firmware from? Also - are you attached via cable attached directly to the router? Just checking.
  0  
  0  
#2
Options
Re:Archer C9 V1 Beta 4.0.0 firmware - cannot update 'Firmware File Error'
2015-11-14 00:55:35
Very odd, made me think about the possible problem and I tried Edge instead of Internet Explorer and there were no errors.... can only assume it was a TPL list or something causing the problem, though I've never had issues with IE before.
  0  
  0  
#3
Options

Information

Helpful: 0

Views: 1254

Replies: 2