Archer C9 - no domain setting in DHCP - cannot acces LAN hosts by hostname.

Archer C9 - no domain setting in DHCP - cannot acces LAN hosts by hostname.
Archer C9 - no domain setting in DHCP - cannot acces LAN hosts by hostname.
2015-11-18 10:54:33
Model : Archer C9

Hardware Version : Not Clear

Firmware Version : 4.0.0 build 20150916 Rel 37772

ISP : internode.on.net

The Archer C9 apparently issues a default local domain name of "lan" to dhcp clients but, while you can ping a local host in the diagnostics menu by adding ".lan" to the hostname. e.g. it can ping ps4.lan,
1. you cannot enter a hostname without a fqdn into the diagnostics ping field; e.g. if you just enter "ps4" it says "invalid format"
2. you cannot access hosts from other hosts using just the hostname [SUP]fn1[/SUP], e.g. [CODE]ping ps4[/CODE] fails,
3. you cannot access hosts using the supposed local fqdn, e.g. [CODE]ping ps4.lan[/CODE] fails.

To make this workable the firmware needs to
1. allow you to set your own local domain name in DHCP settings which should then
2. allow you to resolve local hosts using either their hostname or fully qualified domain name from any other host on the LAN, including the router's own diagnostics page.


(fn1: unless they are Windows hosts, which use another method to resolve other Windows host names on the LAN)
regards Rob

PS static routes still don't work either.
0
0
#1
Options
1 Reply
Re:Archer C9 - no domain setting in DHCP - cannot acces LAN hosts by hostname.
2019-04-21 11:47:51

still no fix on this? Having the same issue...

 

Is there any way or any default local domain name for the TPLINK Archer C9 AC1900. In my case it is ArcherC9 v5.0 firmware 1.2.4 Build 20190403 rel.63869(4555)

0
0
#2
Options