C50 - AC1200 router 5GHz is disabled, how to enable

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

C50 - AC1200 router 5GHz is disabled, how to enable

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
C50 - AC1200 router 5GHz is disabled, how to enable
C50 - AC1200 router 5GHz is disabled, how to enable
2015-11-21 23:14:31
Model :

Hardware Version : Not Clear

Firmware Version :

ISP :

I set up my new dual band router C50. On status page it shows 5GHz is disabled. I played around a lot but I am unable to enable it through tplink admin webpage.

please check photo and guide me.



  0      
  0      
#1
Options
10 Reply
Re:C50 - AC1200 router 5GHz is disabled, how to enable
2015-11-23 03:13:01
Can you see Wireless 5GHz tab?
  0  
  0  
#2
Options
Re:C50 - AC1200 router 5GHz is disabled, how to enable
2015-11-23 15:33:12
Yes I can see tab and it is enabled there.
  0  
  0  
#3
Options
Re:C50 - AC1200 router 5GHz is disabled, how to enable
2015-11-24 00:56:59
Are you sure?
  0  
  0  
#4
Options
Re:C50 - AC1200 router 5GHz is disabled, how to enable
2015-11-28 07:35:35
Please check the photo. I am 100 % sure everything is right in set up.











  0  
  0  
#5
Options
Re:C50 - AC1200 router 5GHz is disabled, how to enable
2015-11-28 07:39:03
I am adding here remaining screens under 5GHz option on setting page.















  0  
  0  
#6
Options
Re:C50 - AC1200 router 5GHz is disabled, how to enable
2015-11-30 21:07:25
The SSID and Region appear to be blank in the screenshot you posted.
  0  
  0  
#7
Options
Re:C50 - AC1200 router 5GHz is disabled, how to enable
2015-12-01 07:14:39
The SSID and Region fields are blank.
  0  
  0  
#8
Options
Re:C50 - AC1200 router 5GHz is disabled, how to enable
2015-12-01 11:36:37
try reset your C50 first, and upgrade the frimware
  0  
  0  
#9
Options
Re:C50 - AC1200 router 5GHz is disabled, how to enable
2015-12-10 20:54:45
Did you ever get this resolved, and if so what did you do to fix it? Others may want to know if it happens to them. Thanks.
  0  
  0  
#10
Options
Re:C50 - AC1200 router 5GHz is disabled, how to enable
2015-12-11 03:16:13
If the 2.4GHz is working then it can't a wireless button fault.

The 5GHz wireless chip may be faulty so the driver isn't correctly initialising thus, driver isn't started and region isn't displayed.
  0  
  0  
#11
Options

Information

Helpful: 0

Views: 2562

Replies: 10