[SOLVED] Random Packet Loss AC750

[SOLVED] Random Packet Loss AC750
[SOLVED] Random Packet Loss AC750
2016-12-16 08:14:00
Model :

Hardware Version :

Firmware Version :

ISP :

Hey! I bought an Archer C2 AC750 recently. I have a very big problem, and have no idea how to solve it.

I have 3 computers connected, 2 via wired. I experienced this problem on every computer connected via wired, didn't test via wireless (I'm doing it right now, but it needs days possibly to get this problem). OS: Windows 10 and 8 on all 3 computers.

When I play a game, or just use TeamSpeak or do anything that require a steady internet connection, after a while (it comes randomly) the program has packet loss. As I've seen (I may be wrong tho) only individual programs are affected.


I didn't find any settings that may have been connected to this issue, or it was already turned off. I hope someone knows what causes this, and that I can fix it. As for teamspeak, I've tried opening ports, and it still happens, port forwarding did not solve the problem.



EDIT: I solved the issue by disabling hardware NAT functions. I got to this conclusion after someone saying that the problem is with the router itself, this can't be software issue. And he was right. How NAT works, the only reason this might happen is that the router isn't doing a great job at identifying packets. Hardware NAT doesn't seem to be working great for me, don't know if the problem was with my router, or the whole series, or even possibly how TP-Link handles his hardware.
0
0
#1
Options
2 Replies
Re:[SOLVED] Random Packet Loss AC750
2016-12-16 21:37:11
I forgot to mention firmware and hardware:
Hardware: Archer C2 v1 00000002
Firmware:
0.9.1 4.2 v0032.0 Build 160706 Rel.37961n

I can't find this Firmware version on the officiat tp-link page, and I can't upgrade to an older firmware. It just doesn't change the firmware.
0
0
#2
Options
Re:[SOLVED] Random Packet Loss AC750
2016-12-22 09:15:13
I have disabled the "hardware NAT feature", which seems to have solved my issue. Someone said the problem is with the router itself, and that I can't do anything against it. He may have been right about it being a problem with the router itself, but it seems I can turn it off.
0
0
#3
Options