Fail to use OpenVPN on TP-LINK router? Read this!

Used Products:

To let my friends on the internet to access my local network resources via my local TP-LINK router, I tried to set OpenVPN on TP-LINK Archer C4000. I have met some complex problems and struggled a lot. Happily, I found a useful instruction on TP-LINK website and finally made it. Hope my experience would help you avoid detours.

First I set up OpenVPN server on my C4000 and export the configuration file. Here is the screenshot of my OpenVPN settings.


Then, I downloaded and installed OpenVPN Software on my client computer.


Then, I pasted the configuration file I had exported to the config folder of OpenVPN Software on my computer.


After importing the configuration file properly, two small icons for OpenVPN popped out on the bottom corner of my computer. So I thought I had installed OpenVPN Software successfully and the only thing I would need to do was to right-click the small OpenVPN GUI icon (the left one on the following screenshot) to connect to my OpenVPN server.

However, I failed and it displayed this error info: Connecting to OpenVPN-Config has failed.

I had no idea about this error info. Someone online suggested me to check the administrative authority of my computer when I installed the OpenVPN Software. That really helped. I realized that I have installed that application under GUEST Account.

So, I tried to install OpenVPN Software again under ADMINISTRATOR Account. At this time, I found that there was another VIRTUAL LOCAL CONNECTION for OpenVPN enabled but showing cable unplugged on my computer. Previously, it was disabled.

One more try, failed again, but this time it displayed a very complicated error info.

SIGUSR1[soft, connection-reset] received, process restarting

SIGINT[hard,init_instance] received,process exiting


Guess how I solved this problem? By changing the time settings of my TP-LINK router! This solution was provided by TP-LINK Technical Support. They checked some details and found out that different time settings on my computer and my TP-LINK router caused my issue.

How twisted my story was! But hope it would help you if you meet the same problem.