Internet disconnection with Verizon Fios G1100

Used Products:

Hello community members,

I would like to share how I fixed the internet disconnection issue on Deco with Verizon Fios.

First, Thank you very much to one of their senior engineers. Without his help, I could never figure out what happened.

Verizon gave the Fios G1100 when I subscribed to their internet service and At the beginning of this year, I decided to update to Deco M5 which worked fine till recently.

The main unit stayed solid red and No IP address when I checked on the Deco APP. Somehow I unplugged Deco and replaced it with my computer on the same port, it worked instantly.

It was a disaster for working at home now and I called their support. After multiple tests and plenty of questions, the support asked me to connect both my computer and Deco M5 to the Fios G1100, so now my network layout was like:


After a while, Deco went red again but this time, my computer did not either. the engineer logged into the Fios G1100 and soon he saved the following screenshot for me:

Somehow, all the Ethernet connections from Fios G1100 were disconnected but I did not touch any cables!

Later I got another email that he suggested I should change my computer properties to "100 Mbps Half Duplex". I didn't know why but It's worth a shot.  To my surprise, the Deco turned green at once and my computer started working as well.

I asked why and he explained to me that Fios G1100 might have some issues when all the LAN devices are 1000 Full-duplex, and sent me a forum link from Verizon community (I am not allowed to post it here and search "FIOS G110 Router Ethernet connection cycling on and off" if you want). The post is quite old but I did get my issue fixed.


Hope it helps you if you ever had the same experience as I did.

Thank you!