Finally I make my Archer C7 work well with CenturyLink Fiber service !

Used Products:
× 1
Archer C7

I bought this TP-Link router – Archer C7 for a few months and it worked perfect. Since I changed to CenturyLink Fiber internet service last week, the Archer C7 stops working.

Absolutely, I understand that I need connect them correctly and reconfigure the Archer C7 with my new credentials given by CenturyLink.

Below is what I have done:

I wired-connected the ONT to the WAN port of the Archer C7, and log in to the web UI to set it up. When I finished quick setup, the internet LED is still orange, there is still no internet access.

Firstly I thought there may have something wrong about the credentials, like username or password, so I reached out to the ISP, they said it has nothing with their ONT or configuration parameters, I need check my router instead.

I just hard reset the Archer C7 by holding the reset hole and start the configuration from scratch but still no avail. My families started complaining due to the lack of internet, I know it is an emergency, I need figure it out ASAP.

I called the TP-Link tech support and they gathered some basic information and troubleshooting method I have done. Then they suggested to enable IPTV/VLAN function under Advanced-Network-IPTV/VLAN page and enter Internet VLAN ID as 201 and tick 802.1Q Tag. Seconds later, I noticed that the internet LED turns blue, and confirmed that I can access internet.  

 

Long story but short, if you cannot access internet from your TP-Link router with CenturyLink fiber internet service, please enable VLAN ID 201 to give it a shot. It is worth a try. Below is the instruction to set it up. 

https://www.tp-link.com/support/faq/1585/

Thank you TP-Link. It is very appreciated to get such a great support from you guys. Therefore, I would have no hesitation in making a purchase from TP-Link in the future and will recommend family or friend also.

 

0 Subscribe Bookmark