✶Update 09/2020✶ Omada Controller 3.2.10 for Debian, Raspbian and other Linux systems

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Re:✶Update 07/2020✶ Omada Controller 3.2.10 for Debian, Raspbian and other Linux systems
2020-07-24 10:38:20 - last edited 2020-07-24 10:44:52

@R1D2 

hello, is there a way to have the compatibilty with SDN 4.1.5 and an EAP 245 V1 ?

In my case I have 2 EAP, one V1 and one V3, is it planed a firmware upgrade for the V1 ?

 

Thank you in advance for your reply.

1
1
#179
Options
Re:✶Update 07/2020✶ Omada Controller 3.2.10 for Debian, Raspbian and other Linux systems
2020-07-24 11:55:57

 

TheYort73 wrote

hello, is there a way to have the compatibilty with SDN 4.1.5 and an EAP 245 V1 ?

 

Unfortunately no. Please see the SDN Controller FAQ, questions #5 and #6.

༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
0
0
#180
Options
Re:✶Update 07/2020✶ Omada Controller 3.2.10 for Debian, Raspbian and other Linux systems
2020-07-24 21:11:22 - last edited 2020-07-24 21:12:44

I just finished installing on Ubuntu 18.04 with their default mongodb-server pkg.  My plan is to upgrade to the SDN software but wanted to migrate from a tar ball based install I had been using to deb packages.
 

/opt/tplink/OmadaController/bin# ./mongod --version
db version v3.6.3
git version: 9586e557d54ef70f9ca4b43c26892cd55257e1a5
OpenSSL version: OpenSSL 1.1.1  11 Sep 2018
allocator: tcmalloc
modules: none
build environment:
    distarch: x86_64
    target_arch: x86_64

 

 

 

Some notes:

1) you need to remove --nohttpinterfaces from mongodb.properties or it can't start

2) You need to install Java 8, 11 is the default.  I went with headless pkg. 

3) You need to set the JAVA_HOME in /etc/defaults/omada to JAVA_HOME=/usr/lib/jvm/java-8-openjdk-amd64

4) You need to disable mongodb from startup by the system.  systemctl disable mongodb, otherwise it seems to kill the instance (I could be wrong here)

 

0
0
#181
Options
Re:✶Update 07/2020✶ Omada Controller 3.2.10 for Debian, Raspbian and other Linux systems
2020-07-24 22:07:23 - last edited 2020-07-24 22:25:25

Hi zinner,

 

zinner wrote

1) you need to remove --nohttpinterfaces from mongodb.properties or it can't start

2) You need to install Java 8, 11 is the default.  I went with headless pkg. 

3) You need to set the JAVA_HOME in /etc/defaults/omada to JAVA_HOME=/usr/lib/jvm/java-8-openjdk-amd64

4) You need to disable mongodb from startup by the system.  systemctl disable mongodb, otherwise it seems to kill the instance (I could be wrong here)

 

1) Yes, applies to all system which use mongodb > v2.4.

 

2) As I wrote. JRE8 is needed.

 

3) If you manually install a symlink for the java executable in /usr/bin/java or (even better) use update-alternatives to install such a symlink, omadactl computes the value of JAVA_HOME automatically from the real pathname, no need to set it, but doesn't harm either:

 

$ update-alternatives --list java      # Debian, manually installed
/opt/jvm/jre1.8.0_251/bin/java
$

 

$ update-alternatives --list java      # Raspbian, package-provided
/usr/lib/jvm/jdk-8-oracle-arm32-vfp-hflt/jre/bin/java
$

 

Note that /etc/default/omadad has been merged with /opt/tplink/OmadaController-3.2.10/CONFIG for package version omada-controller_3.2.10-2 (that's package release 2) and it's not used anymore. Reason is that it prevented to install Omada SDN Controller 4.1.5 package at the same time w/o removing the 3.2.10 Omada Controller package. So it had to go into Omada Controller's home.

 

4) Correct for systems running systemd. That's unfortunately caused by the way Omada Controller starts an own mongod instance instead just connecting to the running one (a typical Windows-ism).

༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
0
0
#182
Options
Re:✶Update 07/2020✶ Omada Controller 3.2.10 for Debian, Raspbian and other Linux systems
2020-07-25 00:00:27 - last edited 2020-07-25 00:01:00

@R1D2 

 

I just was reading your response and realized something.  I forgot you to thank you for your work creating this package and all the surrounding support.

0
0
#183
Options
Re:✶Update 07/2020✶ Omada Controller 3.2.10 for Debian, Raspbian and other Linux systems
2020-07-25 08:00:33

Hi zinner, you're welcome. Thanks for your nice words!

༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
0
0
#184
Options
Re:✶Update 07/2020✶ Omada Controller 3.2.10 for Debian, Raspbian and other Linux systems
2020-08-01 18:34:16

@R1D2 

 

Linux noob here...  

 

Is there a way to autostart omadactl upon a Rpi reboot?  I'm using Rpi OS (aka Rasbian).  I might have missed it in the 16 pages of comments.  Thanks in advance!

 

And thanks for heading up this project.  

 

Salud!  

0
0
#185
Options
Re:✶Update 07/2020✶ Omada Controller 3.2.10 for Debian, Raspbian and other Linux systems
2020-08-02 13:22:32

@Stonewall77   Depends on level os, but with

older os:

 

update-rc.d omadad defaults

 

or with the newer systemd:

 

systemctl enable omadad

 

That should be enough

0
0
#186
Options
Re:✶Update 07/2020✶ Omada Controller 3.2.10 for Debian, Raspbian and other Linux systems
2020-08-02 17:33:01

@Ronald1965 

 

I'm running the systemctl enable command and it keeps throwing off

 

omadad.service is not a native service, redirecting to systemd-sysv-install

Executing: /lib/systemd/systemd-sysv-install enable

 

Any hints? I am running the latest rasbian OS. 

0
0
#187
Options
Re:✶Update 07/2020✶ Omada Controller 3.2.10 for Debian, Raspbian and other Linux systems
2020-08-02 19:35:38 - last edited 2020-08-02 19:40:48

Hi @Stonewall77,

 

just use: update-rc.d omadad enable. This is, btw, executed by the dpkg installer by default when installing the omada-controller package.

 

Stonewall77 wrote

I'm running the systemctl enable command and it keeps throwing off

 

omadad.service is not a native service, redirecting to systemd-sysv-install

Executing: /lib/systemd/systemd-sysv-install enable

 

This is typical verbose garbagge by systemctl informing you that the omada-controller package does not have a native systemd-conforming service file. It therefore will execute a compatibility hook which installs the traditional start/stop script included in the package using the command update-rc.d omadad enable. You can save yourself time and confusion by just running the latter command manually.

 

When rebooting the RasPi, the Omada Controller will be started automatically, but it needs an eternity or two on a RasPi until it completes the startup. You can check the current status of the controller with the command omadactl status.

 

If the automatic start at reboot fails, check whether the manual start of the controller also fails. Use omadactl -W 240 start or omadactl -v start to start it manually and omadactl status to find out what happens at start. Please see the manpage of omadactl(8) for details and for tips what to do if the start of the controller needs too much time on a RasPi.

 

And run sudo -i to switch to the root account permanently before issuing any of the above commands, so you don't have to type sudo before every command.

 

Hope this helps!

༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
0
0
#188
Options