Email Server on Omada Software controller not working

Email Server on Omada Software controller not working
Email Server on Omada Software controller not working
2021-06-16 17:43:39 - last edited 2021-06-18 09:55:01
Hardware Version:
Firmware Version: 4.3.x / 4.2.x

Hi all,

I've been looking at making the jump to upgrade to the SDN controller.

 

I currently run version 3.2.10 and this works fine with the current Email settings. However all the testing I've done on version 4.3.x / 4.2, I am unable to get the Email server to work.

 

When trying to connect out, i get the following error:

2021-06-12 15:48:27 [email-task-0] [INFO]-[SourceFile:101] - Send mail exception Could not connect to SMTP host: smtp.gmail.com, port: 465

 

However the server can connect and resolve the FQDN correctly:

root@test:/opt/tplink/EAPController/logs# nc -v smtp.gmail.com 465
Connection to smtp.gmail.com 465 port [tcp/submissions] succeeded!

 

I am using the exact same email settings as previously enabled on the older version. (this is the same app password, i even did a fresh install of version 3.2.10 on a new server to ensure it wasn't an issue with host identifier etc). The version 4.x is a fresh install as well, so no config has been imported over.

 

I've disabled the firewall on the server in the hope that maybe some traffic was being denied, but no. It still doesn't work. I've tried it on the following OS versions:

Ubuntu 18:04 / Ubuntu 20:04 - MongoDB version 3.6.3

 

Can anyone help point me in the direction on how i may go about getting this operational?

 

I rely on the Email Server for log updates etc.

 

Many thanks

0
0
#1
Options
1 Accepted Solution
Re:Email Server on Omada Software controller not working-Solution
2021-06-18 09:54:49 - last edited 2021-06-18 09:55:01

Dear @AaronN,

 

AaronN wrote

However all the testing I've done on version 4.3.x / 4.2, I am unable to get the Email server to work.

When trying to connect out, i get the following error:

2021-06-12 15:48:27 [email-task-0] [INFO]-[SourceFile:101] - Send mail exception Could not connect to SMTP host: smtp.gmail.com, port: 465

 

However the server can connect and resolve the FQDN correctly:

root@test:/opt/tplink/EAPController/logs# nc -v smtp.gmail.com 465
Connection to smtp.gmail.com 465 port [tcp/submissions] succeeded!

 

The issue has been reported to the R&D team and here is the update:

 

This is an incompatible issue with JDK. The new Java 8 Update 291 (8u291) disables TLS 1.0 and 1.1 by default, which is used for SMTP service by the Omada Controller. Reference: https://bugs.java.com/bugdatabase/view_bug.do?bug_id=JDK-8202343

 

The R&D team will fix the issue in the subsequent updates later.

 

At present, you could try to manually modify the file "jre\lib\security\java.security" as the temporary solution:

  1. Find "jdk.tls.disabledAlgorithms" as shown in the picture below, delete "TLSv1, TLSv1.1," and save;
  2. then restart the Controller.

 

Best Regards!
Recommended Solution
0
0
#2
Options
1 Reply
Re:Email Server on Omada Software controller not working-Solution
2021-06-18 09:54:49 - last edited 2021-06-18 09:55:01

Dear @AaronN,

 

AaronN wrote

However all the testing I've done on version 4.3.x / 4.2, I am unable to get the Email server to work.

When trying to connect out, i get the following error:

2021-06-12 15:48:27 [email-task-0] [INFO]-[SourceFile:101] - Send mail exception Could not connect to SMTP host: smtp.gmail.com, port: 465

 

However the server can connect and resolve the FQDN correctly:

root@test:/opt/tplink/EAPController/logs# nc -v smtp.gmail.com 465
Connection to smtp.gmail.com 465 port [tcp/submissions] succeeded!

 

The issue has been reported to the R&D team and here is the update:

 

This is an incompatible issue with JDK. The new Java 8 Update 291 (8u291) disables TLS 1.0 and 1.1 by default, which is used for SMTP service by the Omada Controller. Reference: https://bugs.java.com/bugdatabase/view_bug.do?bug_id=JDK-8202343

 

The R&D team will fix the issue in the subsequent updates later.

 

At present, you could try to manually modify the file "jre\lib\security\java.security" as the temporary solution:

  1. Find "jdk.tls.disabledAlgorithms" as shown in the picture below, delete "TLSv1, TLSv1.1," and save;
  2. then restart the Controller.

 

Best Regards!
Recommended Solution
0
0
#2
Options