Deco M5 - Packet Loss, Gaming Lag

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Deco M5 - Packet Loss, Gaming Lag

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Deco M5 - Packet Loss, Gaming Lag
Deco M5 - Packet Loss, Gaming Lag
2021-06-20 18:55:01 - last edited 2021-07-03 17:13:21
Model: Deco M5  
Hardware Version: V1
Firmware Version: 1.5.3

I've been using the Deco M5 mesh network in router mode with 3 nodes since 2018, with very few issues. In the last few months though, I have gotten some staggering lag playing online games, to the point that I can't play multiplayer at all anymore.

 

My internet provider hasn't changed and speeds seem to be fine/normal. My latency and ping, in general, are quite good. I notice while playing games that my game freezes, ping goes negative and then spikes up like crazy before recovering to normal. Because my latency and speeds seem fine, I'm guessing this is related to packet loss? The PC I'm playing on is hardwired to one of the nodes, which is connected wirelessly to the main unit.

 

I have reset all my networking hardware etc several times, and I downgraded the firmware on my Deco units before installing the new firmware again when that didn't work. I have changed my DNS settings to the recommended Google ones.

 

Please let me know if you have any recommendations for what I can do to solve this, or if there are certain logs I can post that might help narrow down the problem?

  0      
  0      
#1
Options
1 Accepted Solution
Re:Deco M5 - Packet Loss, Gaming Lag-Solution
2021-07-03 17:13:10 - last edited 2021-07-03 17:13:21

Just in case this helps anyone else, I found what the issue was. My ISP ended up sending techs out a couple times, and the second guy noticed that the signal strength was actually too strong.
 

He removed a signal booster that had been installed and everything appears to have cleared up. 

Recommended Solution
  7  
  7  
#4
Options
3 Reply
Re:Deco M5 - Packet Loss, Gaming Lag
2021-06-21 00:40:08

@MingShow 

 

It does sound like latency on the wireless backhaul between the nodes, there are 2 things to try first

1.  Run network optimisation to see if it will move you to another channel.   Link below page 18

2.  Turn on QOS and set your PC as a priority device, this will consider your gaming traffic over all else.   Again link below page 26

 

https://static.tp-link.com/2021/202104/20210429/1910012954_Deco%20M5_UG_V1.pdf

 

I would give those a rattle and see how you get one.    This simply could be that a neighbour or someone close has a new router or AP and its causing that bit extra interference with you.  Seen it before where it worked fine for years then someone changed something and now you are affected as a result, last time I had this with a customer on Eero (similar to deco) we just bought an additional node to act as a middle man between the main node and him, that extra jump point increased the speed for him back to what he had. 

It literally was just the additional interference caused his signal to drop a fraction and it became noticeable.   May be the same for you, you could try something like WiFi analyser if you have an Android phone, it will tell you what is going on around you.  

 

https://play.google.com/store/apps/details?id=com.farproc.wifi.analyzer&hl=en_GB&gl=US

  2  
  2  
#2
Options
Re:Deco M5 - Packet Loss, Gaming Lag
2021-06-21 19:56:41

@Philbert 

 

Thank you for those recommendations. I had my PC set up as one of the priority devices on the QOS, but I have now removed the other 3 devices that were on there so my PC is the only one. I'll see if that can improve things.

 

I had also run the network optimizer a couple of times recently but haven't seen any improvements there, but I'm giving that another shot.

 

I also opened a ticket with my ISP to see if there's any issue on their end that might be causing problems, so hopefully I can get to the bottom of this.

  2  
  2  
#3
Options
Re:Deco M5 - Packet Loss, Gaming Lag-Solution
2021-07-03 17:13:10 - last edited 2021-07-03 17:13:21

Just in case this helps anyone else, I found what the issue was. My ISP ended up sending techs out a couple times, and the second guy noticed that the signal strength was actually too strong.
 

He removed a signal booster that had been installed and everything appears to have cleared up. 

Recommended Solution
  7  
  7  
#4
Options

Information

Helpful: 0

Views: 3324

Replies: 3

Related Articles