DHCP not propagating hostnames for DNS resolution

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
DHCP not propagating hostnames for DNS resolution
DHCP not propagating hostnames for DNS resolution
2022-01-23 23:15:47 - last edited 2022-01-23 23:24:24
Model: ER7206 (TL-ER7206)  
Hardware Version: V1
Firmware Version: 1.1.1 Build 20210723 Rel.64359

Here's the problem;

 

I am using this device to manage subnets of Ubuntu Linux servers and Windows 10 and 11 WS connected to a Genexis P3410B Gigabit Fibre Endpoint. The embedded DHCP server on the P3410B serves hostnames and IP addresses and resolves them on its subnet 192.168.1.0/24 without issue. One of those IP,s is connected to the Port 1/WAN port on the ER7206 and its WAN port is routed to the 192.168.0.0/24 subnet on the ER7206. This is the system Status page

 

The LAN and DHCP is as follows;

 

The problem is this, the ER7206 DHCP service has the full info set BUT is unable to resolve host names to an IP address. When you attempt to ping host you get;

"Temporary failure in name resolution" on the Linux CLI

or

Ping request could not find host r610-1. Please check the name and try again. from a PowerShell CLI

 

These devices can all be accessed via SSH without issue by way of the IP address.

 

How do I fix this?

  0      
  0      
#1
Options
3 Reply
Re:DHCP not propagating hostnames for DNS resolution
2022-01-24 08:04:38

Dear @Tim-Ryan,

 

Tim-Ryan wrote

The problem is this, the ER7206 DHCP service has the full info set BUT is unable to resolve host names to an IP address. When you attempt to ping host you get;

"Temporary failure in name resolution" on the Linux CLI

or

Ping request could not find host r610-1. Please check the name and try again. from a PowerShell CLI

 

Are you trying this across VLANs? Would it work properly in the same subnet network?

Get Started Here: https://community.tp-link.com/en/business/forum/topic/551684 https://community.tp-link.com/en/business/forum/topic/552406
  0  
  0  
#2
Options
Re:DHCP not propagating hostnames for DNS resolution
2022-01-24 17:52:55

@Fae This is within a single subnet. I have one and one only lan on this device,

 

ID 1

Name LAN

Vlan 1

IP address 192.168.0.1

Subnet Mask 255.255.255.0

DHCP Server Enabled

 

All the devices I am working with are in the local subnet and show up on the DHCP Client list with IP adresses that work, just no Host name resolution to IP address.

Alejandro Diaz says there is a missing DHCP Server Tab in the TL-ER7206 GUI on the TL-ER7206 Router V1.0 with Firmware 1.1.1 Build 20210723 Rel.64359 I am using

  0  
  0  
#3
Options
Re:DHCP not propagating hostnames for DNS resolution
2022-01-25 01:56:34

Dear @Tim-Ryan,

 

Tim-Ryan wrote

Alejandro Diaz says there is a missing DHCP Server Tab in the TL-ER7206 GUI on the TL-ER7206 Router V1.0 with Firmware 1.1.1 Build 20210723 Rel.64359 I am using

 

Please navigate to the Network list section under Network -> LAN for DHCP Server setup. Read this post for more details.

Get Started Here: https://community.tp-link.com/en/business/forum/topic/551684 https://community.tp-link.com/en/business/forum/topic/552406
  0  
  0  
#4
Options