First time setup, few issues, very happy ending

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

First time setup, few issues, very happy ending

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
First time setup, few issues, very happy ending
First time setup, few issues, very happy ending
2022-01-26 06:59:04
Model: EAP225-Outdoor  
Hardware Version: V1
Firmware Version: 5.0.7 Build 20211026 Rel. 33125

As first post I want to say hello to everybody.

 

Like the title says, everything works perfectly. I've read some misleading posts about eap, maybe they are not misleading but my interpretation was wrong. I jumped into eap quite suddenly and did not have any experience with eap devices, only with cpe210 which still does the job quite well on locations where used.

 

I bought two eap225-outdoor, two eap235-wall and two eap245 which were intended to be used in two flats in house, distance between the balcony is a little bit less than 50 meters and first I was not sure if eap225 will work properly as well as 50 meters is not where I would use cpe series. First I bought only one, there was no omada controller and it was configured straightforward after connecting then checked the signal strengh on balcony of other flat,  -52db - -48db, my phone had full signal and full speed, great, ordered then other devices.

 

In begin I did not plan to use omada but openwrt with which I am very familiar and it wandered into stable releases. Client mode is different than mesh where most devices in both flats are wired. This is where I think I was mislead, as far as I understood was that one can not use eap225-outdoor in client mode and I did no want to build up mesh network.

 

I actually only wanted to use one eap225-outdoor in client mode, as all other devices would be wired access points. Everything went well, original firmware backed up, flashed openwrt, set up wlan interface client as wan. So far everything worked well, however, there were some issues which I was not really happy about, on other side, I read on this forum one requires omada controller for advanced features like roaming, mesh etc... I took simply one rock pi4 laying around and installed omada cloudcontroller. Installation process was not without issues, v3 launched, but v4 and v5 simply did not launch pointing to java home and then java vm. I wasted over an hour on looking for solution resulting in actually completly uninstalling openjdk 11 and 8 and the reinstalling. After that v5 had no issues to start.

 

After playing around with cloud controller, I really do like, there is a lot room for improvement, however, this is outstanding that you offer ability to install it on SoC boards.

 

I liked it so much, that after less than a day of running openwrt in client mode, I flashed back original, connected it to the network over lan, add it to controller, then moved back to another flat and it already built up connection to the root ap. Very nice, that was my first though. Both outdoor eap's have actually free air view, however, they are still not mounted to the wall (will do after finding best location on wall):

 

root ap shows in downlinks:

eap225-outdoor2

-55 dBm

 

on eap225-outdoor2 it shows everything properly too and everything works as great. Other devices were then added simply over cloud controller, it is quite nice to have cloud management, but I still find that it is maybe not the most secure way. 

 

I had few issues which I want to mention and which might help other users:

 

1. Installation of omada cloud controller on ubuntu 20.04 (aarc64): I had to remove and reinstall openjdk

2. I am still not aware of how long does the controller wait before applying changes (as example wireless) which results in devices using wireless as uplink to actually reconfigure itself and disconnect for a moment as well as become isolated. The issue which I faced was that I was not aware of how it works and I did mada changes to wireless networks by deleting few and changing encryption method which resulted that one eap235 actually could not connect and device had to be manually reseted before it worked, as I am 200km away it was quite costly to spare on reading huge ton of documentation :), however, I was lucky that somebody could reset it for me.

3. I probably have to read the manual, but each time when I enabled wan for testing on cloud controller, all my devices were disconnected, only wired reconnected after disabling wan but all wireless connected had to be factory restored (reseted).

4. Even on amazon, one of first comments which I saw is that somebody likes omada cloud controller but cant figure out how to use ssh and if it works. I must agree, user interface could be improved, but enabling SSH in service was for quick try something that let me think that it is option to enable ssh acces to controller which raised in me question what kind of ssh is used, I have sshd running already on that SoC. Same question then goes for dnsmasq and odhcp. However, it took me few minutes to just assume that with SSH is meant SSH on devices as I wondered myself already what it means more features with controller but then ssh is gone. Enabling it and trying to connect raised the question about credentials, which took me to documentation link saying that there is on bottom username and password. On that point, I actually do not need ssh enabled on those devices permanently but I would still preffer to use authorized_keys because I dislike managing ton of credentials.

5. dhcp server does not work with omada cloud controller, I need to dig out first what the requirements are or why it does not work, if dnsmasq and odhcp are used, then great, but like I said, user has to read it up somewhere which costs some time and it is not directly visible in installation description for required/optional packages. I use archer c7 v4 as dhcp server on openwrt and so far I see all hostnames correctly, in openwrt I added to dhcp options omada controller but am not sure if anything would be different if I would not have done it (have to test it first)

6. CPE series includes iperf, thats very nice, sadly eap does not. I did not try to modify the firmware but believe one could it if trying hard. It would be really great to have iperf available including ability to run it in omada cloud controller, that is one of my wishes for future, it is especially usefull for testing, enabling speedtest in omada cloud delivers sadly no results if wan is not enabled, where I anyway still have no clue why wan has to be enabled if gateway is known.

7. Last is the biggest, please add wireguard to cloud controller, my SoC board which runs omada cloud runs already wireguard and I have no issues, everything runs fine. IPSec is cool and nice, but it is not wireguard :)

 

There is much more on my mind as well as I simply skipped detailed description of every step I did, my first post is already now too long, sorry for that.

I hope all those points above can contribute in helping you improve already amazing product/s, tp-link never disappointed me since you brought out first devices, with each year tp-link was growing and today you are top, thanks for great products over years.

  0      
  0      
#1
Options

Information

Helpful: 0

Views: 499

Replies: 0

Related Articles