Linux controller and Mongo compatibility issue

Linux controller and Mongo compatibility issue
Linux controller and Mongo compatibility issue
2022-03-28 07:45:27 - last edited 2022-03-29 03:51:27

Apologies in advance for this being brief and vague, but the forum kept complaining that my message contained "illegal external links", so I tried trimming it down to the minimum.

 

Basically, I've been running the Linux controller 5.0.30 on Debian 11 with MongoDB 4.4 for a while. When upgrading the controller to 5.1.7, however, I got error messages about unmet dependencies, specifically MongoDB.

 

Examining the 5.0.30 and 5.1.7 DEB files downloaded from the TP-Link website confirms that 5.1.7 no longer lists MongoDB 4 as a dependency, only MongoDB 3. Is there a reason for this change?

1
1
#1
Options
1 Accepted Solution
Re:Linux controller and Mongo compatibility issue-Solution
2022-03-29 03:51:20 - last edited 2022-03-29 03:51:27

Dear @OTL99,

 

OTL99 wrote

  @Indrek I have this exact same error while using Ubuntu, for now I went back to 5.0.30, I wish we could get an answer from mods

 

Thank you for your valuable feedback!

 

For Controller 5.1.7, please install it with the following command.

sudo dpkg --ignore-depends=jsvc,mongodb-server –i Omada_SDN_Controller_v5.x.x_Linux_x64.deb

 

The support team just updated the guide below.

How to install Omada SDN controller on Linux system (above Controller 5.0.29)

Get Started Here: https://community.tp-link.com/en/business/forum/topic/551684 https://community.tp-link.com/en/business/forum/topic/552406
Recommended Solution
2
2
#5
Options
10 Reply
Re:Linux controller and Mongo compatibility issue
2022-03-28 07:46:27

This is the error I currently get when trying to "apt install" or "apt update" anything:



The following packages have unmet dependencies:
 omadac : Depends: mongodb-server (< 1:4.0.0) but it is not installable or
                   mongodb-10gen (< 4.0.0) but it is not installable or
                   mongodb-org-server (< 4.0.0) but 4.4.13 is installed
1
1
#2
Options
Re:Linux controller and Mongo compatibility issue
2022-03-28 07:47:17

Here's the output from examining the DEB files downloaded from the TP-Link website:



$ dpkg-deb --info Omada_SDN_Controller_v5.0.30_linux_x64.deb | grep mongo
  mongodb-server (>= 3.0.0) | mongodb-10gen (>= 3.0.0) | mongodb-org-server (>= 3.0.0),
  mongodb-server (<< 1:4.5.0) | mongodb-10gen (<< 4.5.0) |  mongodb-org-server (<< 4.5.0),

$ dpkg-deb --info Omada_SDN_Controller_v5.1.7_Linux_x64.deb | grep mongo
  mongodb-server (>= 3.0.0) | mongodb-10gen (>= 3.0.0) | mongodb-org-server (>= 3.0.0),
  mongodb-server (<< 1:4.0.0) | mongodb-10gen (<< 4.0.0) |  mongodb-org-server (<< 4.0.0),
0
0
#3
Options
Re:Linux controller and Mongo compatibility issue
2022-03-28 22:35:22

  @Indrek I have this exact same error while using Ubuntu, for now I went back to 5.0.30, I wish we could get an answer from mods

0
0
#4
Options
Re:Linux controller and Mongo compatibility issue-Solution
2022-03-29 03:51:20 - last edited 2022-03-29 03:51:27

Dear @OTL99,

 

OTL99 wrote

  @Indrek I have this exact same error while using Ubuntu, for now I went back to 5.0.30, I wish we could get an answer from mods

 

Thank you for your valuable feedback!

 

For Controller 5.1.7, please install it with the following command.

sudo dpkg --ignore-depends=jsvc,mongodb-server –i Omada_SDN_Controller_v5.x.x_Linux_x64.deb

 

The support team just updated the guide below.

How to install Omada SDN controller on Linux system (above Controller 5.0.29)

Get Started Here: https://community.tp-link.com/en/business/forum/topic/551684 https://community.tp-link.com/en/business/forum/topic/552406
Recommended Solution
2
2
#5
Options
Re:Linux controller and Mongo compatibility issue
2022-03-29 04:23:55
Thank you! everything is working fine now
0
0
#6
Options
Re:Linux controller and Mongo compatibility issue
2022-03-29 05:27:31

  @Fae Thank you for the response!

 

Personally I managed to fix it by unpacking the DEB file, editing the dependencies inside and re-packing it, then installing the modified DEB. I won't go into details here since the solution you posted is much more straightforward, but for the curious, there are instructions on the internet how to do this. Might come in handy if someone is deploying the installer using an automated process like Ansible.

5
5
#7
Options
Re:Linux controller and Mongo compatibility issue
2022-04-01 15:12:28

Is this only temporary solution and new version will have fixed dependencies?

I was able to install omadac, but not able to upgrade system (without uninstalling omadac).

I haven't found any solution for this so far...

 

# apt upgrade

...
The following packages have unmet dependencies:
 omadac : Depends: mongodb-server (< 1:4.0.0) but it is not installable or
                   mongodb-10gen (< 4.0.0) but it is not installable or
                   mongodb-org-server (< 4.0.0) but 4.4.13 is installed

0
0
#8
Options
Re:Linux controller and Mongo compatibility issue
2022-04-02 21:49:45

  @jrypacek I did what Indrek said, unpacked the DEB file, edited the dependencies inside and re-packed, Fae solution was fine but just for installing

0
0
#9
Options
Re:Linux controller and Mongo compatibility issue
2022-04-03 13:59:25

Funny, I posted about this (albeit in the wrong section of the forum) and got hassled by some other user....

 

https://community.tp-link.com/en/business/forum/topic/541466

 

I'm hopeful that TP-Link will fix the dependency issue in the package as installing with ignore dependencies will mess up future system upgrades (as noted by another user in this thread).

0
0
#10
Options
Re:Linux controller and Mongo compatibility issue
2022-04-04 12:48:37 - last edited 2022-04-04 12:52:38

@jrypacek @iamperson347 Beta of v5.2.4 of the controller software has been posted, fixing this dependency issue is listed in the changelog.

 

https://community.tp-link.com/en/business/forum/topic/542418

 

Edit: confirmed by examining the DEB package:


$ dpkg-deb --info Omada_SDN_Controller_v5.2.4_Linux_x64.deb | grep mongo
  mongodb-server (>= 3.0.0) | mongodb-10gen (>= 3.0.0) | mongodb-org-server (>= 3.0.0),
  mongodb-server (<< 1:4.5.0) | mongodb-10gen (<< 4.5.0) |  mongodb-org-server (<< 4.5.0),

 

0
0
#11
Options