Upgrade from 3.1.x/3.2.x - Do you have to upgrade to 4.1.5 or can you use a newer version?

Upgrade from 3.1.x/3.2.x - Do you have to upgrade to 4.1.5 or can you use a newer version?

Upgrade from 3.1.x/3.2.x - Do you have to upgrade to 4.1.5 or can you use a newer version?
Upgrade from 3.1.x/3.2.x - Do you have to upgrade to 4.1.5 or can you use a newer version?
2022-08-12 13:46:39 - last edited 2022-08-22 11:10:14
Tags: #Controller Installation #Controller Upgrade

I maintain the `mbentley/omada-controller` Docker images and I would like to discontinue support for older versions that TP-Link has stopped supporting as well but I was hoping to get clarification on the upgrade process of moving from 3.2 to 4.x.  According to the upgrade documentation (https://www.tp-link.com/us/omada-sdn/controller-upgrade/#content-1), it mentions going from 3.1.4 or above to 4.1.5.

 

Two main questions:

 

  • Do you have to migrate to the exact version 4.1.5 or could you restore the backed up configuration from 3.1.4 or above to any of the 4.x versions (4.1.x, 4.2.x, 4.3.x, or 4.4)?
  • If the controller supports it, could you also migrate from 3.1.4 or above to any of the 5.x releases (5.0, 5.1, 5.3 or 5.4)?

 

If 4.1.5 isn't explicitly required, it would allow me to archived the 4.1, 4.2, 4.3 versions and just maintain versions for 3.2, 4.4, and the 5.x series.

  0      
  0      
#1
Options
1 Accepted Solution
Re:Upgrade from 3.1.x/3.2.x - Do you have to upgrade to 4.1.5 or can you use a newer version?-Solution
2022-08-22 05:39:16 - last edited 2022-08-22 11:10:14

Dear @mbentley

 

Controller v4.1.5 is the initial version of the Omada SDN Controller, which had some data compatible processing with old controller v3. The subsequent SDN Controller versions are developed based on v4.1.5, whether the data is compatible with the controller v3 is not considered. On the Controller v5.x, only the configuration file from 4.1.5 or above can be restored.

 

So if you upgrade from 3.x, it's highly recommended to upgrade 3.x to v4.1.5 first, then v4.1.5 to the latest 5.x.

For your Docker images, you may just maintain versions for 3.2, 4.1.5 and the 5.x series.

Happy New Year! Meet Us at CES 2023 | Featuring Wi-Fi 7, Omada Business Networking, VIGI Video Surveillance
Recommended Solution
  1  
  1  
#2
Options
3 Reply
Re:Upgrade from 3.1.x/3.2.x - Do you have to upgrade to 4.1.5 or can you use a newer version?-Solution
2022-08-22 05:39:16 - last edited 2022-08-22 11:10:14

Dear @mbentley

 

Controller v4.1.5 is the initial version of the Omada SDN Controller, which had some data compatible processing with old controller v3. The subsequent SDN Controller versions are developed based on v4.1.5, whether the data is compatible with the controller v3 is not considered. On the Controller v5.x, only the configuration file from 4.1.5 or above can be restored.

 

So if you upgrade from 3.x, it's highly recommended to upgrade 3.x to v4.1.5 first, then v4.1.5 to the latest 5.x.

For your Docker images, you may just maintain versions for 3.2, 4.1.5 and the 5.x series.

Happy New Year! Meet Us at CES 2023 | Featuring Wi-Fi 7, Omada Business Networking, VIGI Video Surveillance
Recommended Solution
  1  
  1  
#2
Options
Re:Upgrade from 3.1.x/3.2.x - Do you have to upgrade to 4.1.5 or can you use a newer version?
2022-08-22 11:10:11

  @Fae - awesome, thanks for the guidance!

  0  
  0  
#3
Options
Re:Upgrade from 3.1.x/3.2.x - Do you have to upgrade to 4.1.5 or can you use a newer version?
2022-08-22 11:34:02

Dear @mbentley 

 

mbentley wrote

  @Fae - awesome, thanks for the guidance!

 

You're welcome.

Happy New Year! Meet Us at CES 2023 | Featuring Wi-Fi 7, Omada Business Networking, VIGI Video Surveillance
  0  
  0  
#4
Options