DHCP Reservation Doesn't Stick

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

DHCP Reservation Doesn't Stick

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
DHCP Reservation Doesn't Stick
DHCP Reservation Doesn't Stick
2023-03-03 00:45:33 - last edited 2023-03-23 02:52:21
Model: ER605 (TL-R605)  
Hardware Version: V2
Firmware Version: 2.1.2

Hi,

 

I have an inconvenient issue which I believe has started since the last update. So I have the following set-up:

 

Gateway: ER605 v2.0 (Firmware 2.1.2)

Controller: OC200 v5.7.6 (Firmware 2.7.7)

Switch: TL-SG3428 v2.0 (Firmware 2.0.10)

AP's: 14x EAP615-WALL v1.0 (Firmware 1.1.3).

 

I have 3 VLAN's set-up, the controller acts as DHCP server and I have a couple of Static IP's set-up. Also I have some Switch ACL rules in place which works with IP Groups.

 

The problem is that one of the static IP's doesn't stick and changes from time to time. Obviously the MAC address is not changed. So as soon as this happens, some services stops working since the IP has changed and since I have the Switch ACL in place it can't communicate with the rest of the devices and therefore doesn't work. 


The funny part is that: when you click on the device, you see that it has a new IP but if you look under Device -> Config you'll still can see the "use Fixed IP Address" is checked + the IP address is the one as per DHCP Reservation. Also the history tab is empty when this happens, so it seems that somehow the controller has forgotten everything about this device?

 

Since I don't have an option to set-up a static IP on the device itself, I've done this on the controller under Services -> DHCP Reservation. This set-up was proven to work for months however, now is giving me some issues. The way I deal with this, is to change the IP address to the new one under Services -> DHCP Reservation, change the IP in teh IP Group profile, Switch ACL off /on and reload the services to get it working back again which is kind of annoying. 

 

So the question what I have is:
- Is there a way to override the new IP address provided by the controller and to solve this issue for good?

- Or is this perhaps caused by an bug? If so, when will this be fixed?

 

Anyone an idea? 

 

Many thanks! 

 

Best Regards.

 

 

  0      
  0      
#1
Options
1 Accepted Solution
Re:DHCP Reservation Doesn't Stick-Solution
2023-03-22 12:11:10 - last edited 2023-03-23 02:52:21

Hi @Virgo,

 

I've been in contact with a TP-Link technical support and as of today this is what I can share:
 

Both ER605 & TL-SG3428 offer the option to server as DHCP server.
 
In my case I have set the DHCP option using my OC200 controller under:
- Wired Networks -> LAN = Technical Support confirms that this is configured on the ER605.
- Services -> DHCP reservation = Technical Support confirms that this is configured on the ER605.
 
But as it seems, the DHCP option on the VLAN interface of TL-SG3428 was also ON! which caused for the DHCP conflict. I've now disabled this on the TL-SG3428 and this should fix my issue. (Obviously I wasn't aware that I had the DHCP option enabled on the L2 switch as well... )
 
 
Recommended Solution
  0  
  0  
#7
Options
6 Reply
Re:DHCP Reservation Doesn't Stick
2023-03-03 11:17:35

Hello @Unnamed.m3

 

May I know if the issue occurs after an upgraded firmware?

How many clients have this issue? What exact model number are they?

Does the problem only occur during the router or controller is rebooting?

Best Regards! >> Omada EAP Firmware Trial Available Here << >> Get the Latest Omada SDN Controller Releases Here << *Try filtering posts on each forum by Label of [Early Access]*
  0  
  0  
#2
Options
Re:DHCP Reservation Doesn't Stick
2023-03-03 12:13:56

  @Hank21

 

Hi Henk,

 

Sure.

 

Yes, I believe so but I'm not quite sure if this makes sense. (Specially after reading that version 2.1.2 20230210) shouldn't have this issue. Refering to this post).

So far this issue occors on 1 IoT device which sends data from it's own VLAN to a specific IP in another VLAN. This problem doesn't occur during the reboots but happens random at different times while everything seems to be working fine. I've rebooted the router and controller in different sequence to see if it makes any difference but it didn't.

 

I guess I could try to downgrade to an older version but then I guess I would need to go back to V2_2.0.1 Build 20220223 since the release of V2_2.1.1 Build 20230115 had this issue already?

 

 

 

  0  
  0  
#3
Options
Re:DHCP Reservation Doesn't Stick
2023-03-04 08:44:13

Hi  @Unnamed.m3 


To better assist you, I've created a support ticket via your registered email address, and escalated it to our support engineer to look into the issue. The ticket ID is TKID230306436, please check your email box and ensure the support email is well received. Thanks!

Best Regards! >> Omada EAP Firmware Trial Available Here << >> Get the Latest Omada SDN Controller Releases Here << *Try filtering posts on each forum by Label of [Early Access]*
  0  
  0  
#4
Options
Re:DHCP Reservation Doesn't Stick
2023-03-04 09:35:23

Hi  @Hank21 ,

 

Great, thanks.

And yes indeed, I've received the support email with the ticket  ID.

  0  
  0  
#5
Options
Re:DHCP Reservation Doesn't Stick
2023-03-22 09:54:25

  @Unnamed.m3 

 

Have you already fixed the issue?

Do you have a solution can share?

Just striving to develop myself while helping others.
  0  
  0  
#6
Options
Re:DHCP Reservation Doesn't Stick-Solution
2023-03-22 12:11:10 - last edited 2023-03-23 02:52:21

Hi @Virgo,

 

I've been in contact with a TP-Link technical support and as of today this is what I can share:
 

Both ER605 & TL-SG3428 offer the option to server as DHCP server.
 
In my case I have set the DHCP option using my OC200 controller under:
- Wired Networks -> LAN = Technical Support confirms that this is configured on the ER605.
- Services -> DHCP reservation = Technical Support confirms that this is configured on the ER605.
 
But as it seems, the DHCP option on the VLAN interface of TL-SG3428 was also ON! which caused for the DHCP conflict. I've now disabled this on the TL-SG3428 and this should fix my issue. (Obviously I wasn't aware that I had the DHCP option enabled on the L2 switch as well... )
 
 
Recommended Solution
  0  
  0  
#7
Options

Information

Helpful: 0

Views: 358

Replies: 6