Slow Upload Speed

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Slow Upload Speed

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Slow Upload Speed
Slow Upload Speed
2023-08-16 22:45:24 - last edited 2023-08-30 21:46:43
Tags: #WAN Setup #Slow Upload
Model: ER8411  
Hardware Version: V1
Firmware Version: 1.1.0 Build 20230705 Rel.64091

I pay for 2.5Gbps symmetric fiber through AT&T.

When testing my speed directly from the AT&T BGW320-505 I (mostly)get the speed I pay for.

Heres a speedtest directly from the modem.

 

I use IP Passthrough so the WAN IP goes directly to the ER8411

 

While connected to the ER8411, I get download speed bursts up to 8Gbps sometimes.

As of writing this I had a burst to 3.1Gbps download BUT ONLY 620Mbps upload

I know.. I know.. some people don't get the opportunity or have the infrastructure and this can come off as inconsiderate to the people who don't get city/metro fiber in their area, but I do and the upload speed is abysmal.

 

Here's a test from Fast(dot)com showing my download at 3.1Gbps and upload of 620Mbps.

This is the same at Speedtest as well and any other speed test that isn't tied to Fast(Verizon) or Speedtest(Ookla)

I've also tried M-Lab, Testmy(dot)net, and Speedof(dot)me and they all conclude the same thing from the ER8411

If I connect my PC to the Modem directly, and run these speed tests, they give consistent download/upload, it is strictly the ER8411 that is limiting the upload.

 

 

 

Now the problem, the upload; Why is the upload not even hitting 1Gbps?

I have a 10Gbps SFP+ module installed(10Gtek ASF-10G-T), and it's obviously getting download speeds fine.

I've seen other posts(on Reddit) about this as well but opposite, where there upload is perfectly fine, but their download is not up to par with what is being paid for.

Is there a particular SFP+ module that is supported?

I've tried speed tests on multiple devices that have different ethernet cards ranging from 2.5Gb, 5Gb, and 10Gbps endpoint ethernet and all of them are between 300-600Mbps upload. What's the deal?

I've tinkered with settings thinking that maybe something being turned off or on was the problem, but nothing has solved this yet.

 

Someone, anyone, can I get help or an explanation? Do I need to buy a TP-Link module, such as the TL-SM5310-T?

  0      
  0      
#1
Options
1 Accepted Solution
Re:Slow Upload Speed-Solution
2023-08-24 08:29:03 - last edited 2023-08-30 21:46:43

Hi @ibphantom 

Thanks for posting in our business forum.

ibphantom wrote

@Clive_A 

I'm sad to say that upgrading the network cable to CAT 8 from the modem to the ER8411 hasn't fixed the upload speed.

I noticed the SFP+ plugin was hot to touch when making the swap.

I also attempted to link my 10G nic from my PC directly to the 10Gb LAN SFP+ port and it came back with the same results, download was on par, but upload at most would max at 700Mbps.

 

Are there any details I can provide further to troubleshoot and get the upload symmetric as I pay for?

 

I checked with the senior engineer about this. From their information, it is said that the 10Gtek has a compatibility issue with us. Suggest you try TL-SM5310-T.

 

Best Regards! If you are new to the forum, please read: Howto - A Guide to Use Forum Effectively. Read Before You Post. Look for a model? Search your model NOW Official and Beta firmware. NEW features! Subscribe for the latest update!Download Beta Here☚ ☛ ★ Configuration Guide ★ ☚ ☛ ★ Knowledge Base ★ ☚ ☛ ★ Troubleshooting Manual ★ ☚ (Disclaimer: Short links are used above solely for guidance to TP-Link subdomains and are safe and tracker-free. Exercise caution with short links from non-official members on forums. We are not liable for external content or damage from non-official members' link use.)
Recommended Solution
  2  
  2  
#8
Options
9 Reply
Re:Slow Upload Speed
2023-08-17 06:29:50

Hi @ibphantom 

Thanks for posting in our business forum.

Can you please try to enable flow control in WAN settings?

Under the WAN settings tab, is everything on default?

Do you use the 2.5Gbps Eth on your modem to ER8411 10G Ethernet port?

Best Regards! If you are new to the forum, please read: Howto - A Guide to Use Forum Effectively. Read Before You Post. Look for a model? Search your model NOW Official and Beta firmware. NEW features! Subscribe for the latest update!Download Beta Here☚ ☛ ★ Configuration Guide ★ ☚ ☛ ★ Knowledge Base ★ ☚ ☛ ★ Troubleshooting Manual ★ ☚ (Disclaimer: Short links are used above solely for guidance to TP-Link subdomains and are safe and tracker-free. Exercise caution with short links from non-official members on forums. We are not liable for external content or damage from non-official members' link use.)
  0  
  0  
#2
Options
Re:Slow Upload Speed
2023-08-17 07:22:00 - last edited 2023-08-17 07:56:30

  @Clive_A 

Hey Clive, with this ER8411 being tied to an Omada Controller, I don't have flow control, I've gone through every page to be sure.

The closest thing I found was bandwidth control which is set to the max

The Modem(BGW320-505) is linked to the 10Gtek ASF-10G-T SFP+ on the ER8411

The Modem is a BGW320-505 and has a 5Gbps 'Blue' port showing 5000Mbps FullDuplex in the management page of the modem.

The ER8411 shows 10 Gbps FullDuplex
 

  0  
  0  
#3
Options
Re:Slow Upload Speed
2023-08-17 08:02:51

@Clive_A @MR.S 
Lets put this on hold until Monday Aug 21st. I just ordered a CAT8 cable. Every cable I have is CAT6 UTP(I tried to find an STP or CAT6A), and moving the cable around a little has put me up to 800Mbps upload.

I'm thinking that although Cat6 UTP at only 2ft *Should* be able to handle up to 10Gbps, with all the other Cat6 UTP around, it's causing interference.

I'll update if the new CAT8 Cable solves the slower upload.

  0  
  0  
#4
Options
Re:Slow Upload Speed
2023-08-17 08:09:45

Hi @ibphantom 

Thanks for posting in our business forum.

Gotta ask you for some details about the firmware. ER8411 enabled Flow Control by default by V1.1.0. Can you check your firmware for me?

What's your controller version?

 

Best Regards! If you are new to the forum, please read: Howto - A Guide to Use Forum Effectively. Read Before You Post. Look for a model? Search your model NOW Official and Beta firmware. NEW features! Subscribe for the latest update!Download Beta Here☚ ☛ ★ Configuration Guide ★ ☚ ☛ ★ Knowledge Base ★ ☚ ☛ ★ Troubleshooting Manual ★ ☚ (Disclaimer: Short links are used above solely for guidance to TP-Link subdomains and are safe and tracker-free. Exercise caution with short links from non-official members on forums. We are not liable for external content or damage from non-official members' link use.)
  0  
  0  
#5
Options
Re:Slow Upload Speed
2023-08-17 08:26:05 - last edited 2023-08-17 08:26:22

  @Clive_A 

Omada controller is Version : 5.9.31
 
  0  
  0  
#6
Options
Re:Slow Upload Speed
2023-08-24 03:49:19

@Clive_A 

I'm sad to say that upgrading the network cable to CAT 8 from the modem to the ER8411 hasn't fixed the upload speed.

I noticed the SFP+ plugin was hot to touch when making the swap.

I also attempted to link my 10G nic from my PC directly to the 10Gb LAN SFP+ port and it came back with the same results, download was on par, but upload at most would max at 700Mbps.

 

Are there any details I can provide further to troubleshoot and get the upload symmetric as I pay for?

  0  
  0  
#7
Options
Re:Slow Upload Speed-Solution
2023-08-24 08:29:03 - last edited 2023-08-30 21:46:43

Hi @ibphantom 

Thanks for posting in our business forum.

ibphantom wrote

@Clive_A 

I'm sad to say that upgrading the network cable to CAT 8 from the modem to the ER8411 hasn't fixed the upload speed.

I noticed the SFP+ plugin was hot to touch when making the swap.

I also attempted to link my 10G nic from my PC directly to the 10Gb LAN SFP+ port and it came back with the same results, download was on par, but upload at most would max at 700Mbps.

 

Are there any details I can provide further to troubleshoot and get the upload symmetric as I pay for?

 

I checked with the senior engineer about this. From their information, it is said that the 10Gtek has a compatibility issue with us. Suggest you try TL-SM5310-T.

 

Best Regards! If you are new to the forum, please read: Howto - A Guide to Use Forum Effectively. Read Before You Post. Look for a model? Search your model NOW Official and Beta firmware. NEW features! Subscribe for the latest update!Download Beta Here☚ ☛ ★ Configuration Guide ★ ☚ ☛ ★ Knowledge Base ★ ☚ ☛ ★ Troubleshooting Manual ★ ☚ (Disclaimer: Short links are used above solely for guidance to TP-Link subdomains and are safe and tracker-free. Exercise caution with short links from non-official members on forums. We are not liable for external content or damage from non-official members' link use.)
Recommended Solution
  2  
  2  
#8
Options
Re:Slow Upload Speed
2023-08-30 21:49:40

  @Clive_A 

Thank you VERY much Clive! I received the new SFP+ transceiver you and your team recommended today and speeds are now up to par!

Could I make a recommendation that we have notes added to equipment specs pages of TP-Link Products for supported equipment?

 

 

Thank you again,

 

ibphantom(AKA - Zach)

  0  
  0  
#9
Options
Re:Slow Upload Speed
2023-08-31 01:05:56

Hi @ibphantom Zach

Thanks for posting in our business forum.

ibphantom wrote

  @Clive_A 

Thank you VERY much Clive! I received the new SFP+ transceiver you and your team recommended today and speeds are now up to par!

Could I make a recommendation that we have notes added to equipment specs pages of TP-Link Products for supported equipment?

 

 

Thank you again,

 

ibphantom(AKA - Zach)

Actually, we do. In the datasheet instead of on the specs page. Datasheet has more detailed information.

But we don't test other brands' SFP modules. So the knowledge would be the SFP module from us is pretty certainly compatible with our products.

Only when people report this, our test team get one and run a test and analysis on it. We cannot test all modules on the market due to cost and time.

 

ER8411(UN)1.0_Datasheet.pdf

Best Regards! If you are new to the forum, please read: Howto - A Guide to Use Forum Effectively. Read Before You Post. Look for a model? Search your model NOW Official and Beta firmware. NEW features! Subscribe for the latest update!Download Beta Here☚ ☛ ★ Configuration Guide ★ ☚ ☛ ★ Knowledge Base ★ ☚ ☛ ★ Troubleshooting Manual ★ ☚ (Disclaimer: Short links are used above solely for guidance to TP-Link subdomains and are safe and tracker-free. Exercise caution with short links from non-official members on forums. We are not liable for external content or damage from non-official members' link use.)
  2  
  2  
#10
Options

Information

Helpful: 0

Views: 846

Replies: 9

Tags

WAN Setup
Slow Upload
Related Articles