ER605 reports Local IP to DDNS instead of WAN IP

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

ER605 reports Local IP to DDNS instead of WAN IP

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
ER605 reports Local IP to DDNS instead of WAN IP
ER605 reports Local IP to DDNS instead of WAN IP
2024-01-10 08:38:32 - last edited 2024-01-12 14:01:12
Model: ER605 (TL-R605)  
Hardware Version: V2
Firmware Version: 2.2.3

Hi,

 

I have 2 DDNS service providers configured and one of those is correctly sending the WAN IP (NO-IP) while the other one (DuckDNS) sends the Local IP.
I am pretty sure this has been working correctly until a few weeks ago before I replaced the ER605 V1 with the ER605 V2.

 

Could you please help with this?
 

Thank you

  0      
  0      
#1
Options
1 Accepted Solution
Re:ER605 reports Local IP to DDNS instead of WAN IP-Solution
2024-01-12 14:01:05 - last edited 2024-01-12 14:01:12

 Hi @MisterW @Clive_A  ,

 

Thank you for your help.
I totally agree with your comments but I could not understand why it has been working before.
 

I have just realized that I re-inserted the Custom URL and accidentally introduced one new parameter ip=[IP].
This is not needed and it is why it was taking the wrong address.

 

Recommended Solution
  0  
  0  
#8
Options
7 Reply
Re:ER605 reports Local IP to DDNS instead of WAN IP
2024-01-11 01:38:09

Hi @Birillo 

Thanks for posting in our business forum.

Screenshots?

Best Regards! If you are new to the forum, please read: Howto - A Guide to Use Forum Effectively. Read Before You Post. Look for a model? Search your model NOW Official and Beta firmware. NEW features! Subscribe for the latest update!Download Beta Here☚ ☛ ★ Configuration Guide ★ ☚ ☛ ★ Knowledge Base ★ ☚ ☛ ★ Troubleshooting Manual ★ ☚ (Disclaimer: Short links are used above solely for guidance to TP-Link subdomains and are safe and tracker-free. Exercise caution with short links from non-official members on forums. We are not liable for external content or damage from non-official members' link use.)
  0  
  0  
#2
Options
Re:ER605 reports Local IP to DDNS instead of WAN IP
2024-01-12 09:19:22

Hi @Clive_A ,

I attached the screenshots.
Note that the Public IP starts with 151.x.x.x in the router while I see the provider router IP in the services status (provider router --> ER605).
In any case NO-IP get the WAN IP while DuckDNS receives the router local IP.
This was working correctly before switching the ER605 from v1 to v2.


  0  
  0  
#3
Options
Re:ER605 reports Local IP to DDNS instead of WAN IP
2024-01-12 09:27:11

Hi @Birillo 

Thanks for posting in our business forum.

Birillo wrote

Hi @Clive_A ,

I attached the screenshots.
Note that the Public IP starts with 151.x.x.x in the router while I see the provider router IP in the services status (provider router --> ER605).
In any case NO-IP get the WAN IP while DuckDNS receives the router local IP.
This was working correctly before switching the ER605 from v1 to v2.


Because your WAN IP is not public. DDNS can report private IPs to the DDNS server.

Can you check your WAN interface IP address from the device info? Click it and on the popup page to your right.

Best Regards! If you are new to the forum, please read: Howto - A Guide to Use Forum Effectively. Read Before You Post. Look for a model? Search your model NOW Official and Beta firmware. NEW features! Subscribe for the latest update!Download Beta Here☚ ☛ ★ Configuration Guide ★ ☚ ☛ ★ Knowledge Base ★ ☚ ☛ ★ Troubleshooting Manual ★ ☚ (Disclaimer: Short links are used above solely for guidance to TP-Link subdomains and are safe and tracker-free. Exercise caution with short links from non-official members on forums. We are not liable for external content or damage from non-official members' link use.)
  0  
  0  
#4
Options
Re:ER605 reports Local IP to DDNS instead of WAN IP
2024-01-12 09:33:57 - last edited 2024-01-12 09:34:51

Hi  @Clive_A 

 

 

 

  0  
  0  
#5
Options
Re:ER605 reports Local IP to DDNS instead of WAN IP
2024-01-12 09:40:18

Hi @Birillo 

Thanks for posting in our business forum.

Birillo wrote

Hi  @Clive_A 

 

 

 

It is still the issue with the double-NAT. Remove the NAT or set it to bridge would fix this.

Best Regards! If you are new to the forum, please read: Howto - A Guide to Use Forum Effectively. Read Before You Post. Look for a model? Search your model NOW Official and Beta firmware. NEW features! Subscribe for the latest update!Download Beta Here☚ ☛ ★ Configuration Guide ★ ☚ ☛ ★ Knowledge Base ★ ☚ ☛ ★ Troubleshooting Manual ★ ☚ (Disclaimer: Short links are used above solely for guidance to TP-Link subdomains and are safe and tracker-free. Exercise caution with short links from non-official members on forums. We are not liable for external content or damage from non-official members' link use.)
  0  
  0  
#6
Options
Re:ER605 reports Local IP to DDNS instead of WAN IP
2024-01-12 13:11:25

  @Birillo 

 

DuckDNS is updated via a URL and is passed the WAN IP address in the URL. As Clive says, the ER605 WAN has a private IP because its behind another NAT router.

 

I believe NO-IP uses the RFC 2136 compliant DDNS update method which sends a UDP update packet. This does not contain the actual IP, rather the update uses the source IP (from which the update is received) as the IP address to set the DDNS. Since this packet will be NAT'ed via your primary router, it will by implication always be sent from your true public IP

 

  0  
  0  
#7
Options
Re:ER605 reports Local IP to DDNS instead of WAN IP-Solution
2024-01-12 14:01:05 - last edited 2024-01-12 14:01:12

 Hi @MisterW @Clive_A  ,

 

Thank you for your help.
I totally agree with your comments but I could not understand why it has been working before.
 

I have just realized that I re-inserted the Custom URL and accidentally introduced one new parameter ip=[IP].
This is not needed and it is why it was taking the wrong address.

 

Recommended Solution
  0  
  0  
#8
Options

Information

Helpful: 0

Views: 463

Replies: 7

Related Articles