Setup dual WAN, how to force devices on specific VLANs touse use a specific gateway/WAN

Setup dual WAN, how to force devices on specific VLANs touse use a specific gateway/WAN

Setup dual WAN, how to force devices on specific VLANs touse use a specific gateway/WAN
Setup dual WAN, how to force devices on specific VLANs touse use a specific gateway/WAN
2024-03-02 02:15:43 - last edited 2024-03-06 02:11:46
Model: ER707-M2  
Hardware Version: V1
Firmware Version: 1.2.1 Build 20240109 Rel.72478

I'm just setting up a new ER707-M2 router. I'm not using an Omada controller for it yet, but maybe later.

 

I currently have it setup with two separate WAN connections, each with their own public IP address, of course. I do not want to use the dual WAN config for fail over, but I do want to force VLANs to use a specific WAN.

 

As I have it setup now, load balancing is disabled, each VLAN has a different /24 subnet, and I've configured the VLAN/LANs to use separate gateway IP's.

 

However, it seems that traffic from both VLANs is randomly connecting thru either of the WAN IP's.

 

As an example, I'm trying to force all devices on vlan10 to only use WAN interface 1, and force all devices on vlan20 to only use WAN interface 2.

 

How can I force devices on specific VLANs to only move traffic thru specific WAN interfaces?

 

Thanks!

  0      
  0      
#1
Options
2 Accepted Solutions
Re:Setup dual WAN, how to force devices on specific VLANs touse use a specific gateway/WAN-Solution
2024-03-04 02:16:16 - last edited 2024-03-06 02:11:46

Hi @Blazemonkey 

Thanks for posting in our business forum.

Kindly refer to this guide.

Best Regards! If you are new to the forum, please read: Howto - A Guide to Use Forum Effectively. Read Before You Post. Look for a model? Search your model NOW Official and Beta firmware. NEW features! Subscribe for the latest update!Download Beta Here☚ ☛ ★ Configuration Guide ★ ☚ ☛ ★ Knowledge Base ★ ☚ ☛ ★ Troubleshooting Manual ★ ☚ (Disclaimer: Short links are used above solely for guidance to TP-Link subdomains and are safe and tracker-free. Exercise caution with short links from non-official members on forums. We are not liable for external content or damage from non-official members' link use.)
Recommended Solution
  2  
  2  
#2
Options
Re:Setup dual WAN, how to force devices on specific VLANs touse use a specific gateway/WAN-Solution
2024-03-06 01:37:14 - last edited 2024-03-06 02:15:48

  @Clive_A 

 

Thanks for the help Clive, setting up Policy Routing did the trick!

 

I found the Policy Routing settings, created a rule for each WAN interface, set the Mode to Only, and configured the necessary IP Groups and IP Address Lists to use for the Source IP field. Everything now works as intended.

 

Just leaving this here for anyone else that might need some extra info.  smiley

 

Cheers!

Recommended Solution
  1  
  1  
#3
Options
2 Reply
Re:Setup dual WAN, how to force devices on specific VLANs touse use a specific gateway/WAN-Solution
2024-03-04 02:16:16 - last edited 2024-03-06 02:11:46

Hi @Blazemonkey 

Thanks for posting in our business forum.

Kindly refer to this guide.

Best Regards! If you are new to the forum, please read: Howto - A Guide to Use Forum Effectively. Read Before You Post. Look for a model? Search your model NOW Official and Beta firmware. NEW features! Subscribe for the latest update!Download Beta Here☚ ☛ ★ Configuration Guide ★ ☚ ☛ ★ Knowledge Base ★ ☚ ☛ ★ Troubleshooting Manual ★ ☚ (Disclaimer: Short links are used above solely for guidance to TP-Link subdomains and are safe and tracker-free. Exercise caution with short links from non-official members on forums. We are not liable for external content or damage from non-official members' link use.)
Recommended Solution
  2  
  2  
#2
Options
Re:Setup dual WAN, how to force devices on specific VLANs touse use a specific gateway/WAN-Solution
2024-03-06 01:37:14 - last edited 2024-03-06 02:15:48

  @Clive_A 

 

Thanks for the help Clive, setting up Policy Routing did the trick!

 

I found the Policy Routing settings, created a rule for each WAN interface, set the Mode to Only, and configured the necessary IP Groups and IP Address Lists to use for the Source IP field. Everything now works as intended.

 

Just leaving this here for anyone else that might need some extra info.  smiley

 

Cheers!

Recommended Solution
  1  
  1  
#3
Options

Information

Helpful: 0

Views: 312

Replies: 2

Related Articles