L2TP VPN Connection issue

L2TP VPN Connection issue

L2TP VPN Connection issue
L2TP VPN Connection issue
3 weeks ago - last edited a week ago
Tags: #VPN
Model: ER7206 (TL-ER7206)  
Hardware Version: V1
Firmware Version: 1.2.3 Build 20221104 Rel.41500

Hi,

 

I have a TP-Link router (TL-ER7206) with L2TP VPN enabled behind my WAN internet router.

 

I would like to connect to my VPN from outside my LAN and to do this I have enabled port forwarding in my WAN router as per below (192.168.0.121 is the TP-Link router):

 

 

When I connect to the VPN from inside my LAN everything works correctly, but when I try to connect from outside, the connectivity gets stuck here:

 

 

Am I missing any other port in the list of the ports I need to forward?

 

Please let me know if you need more info.

 

Thanks

  0      
  0      
#1
Options
1 Accepted Solution
Re:L2TP VPN Connection issue-Solution
2 weeks ago - last edited a week ago

This problem could be related to NAT-T in Windows. Check Google: NAT-T Windows 10/11

 

1) Open the registry editor in Windows. Select Start -> All Programs -> Accessories -> Run, then type 'regedit'.

2) Browser to registry subkey below. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PolicyAgent

3) Create a new DWORD (32-bit) registry value with the string below. AssumeUDPEncapsulationContextOnSendRule

4) Enable NAT-T for both devices located behind NAT. In the Value Data field, type '2'.

5) Restart Windows

 

Note. Meaning of value for the Value Data field.

0 - When both Omad and Client are not behind a NAT device.

1 - When Omada is behind a NAT device, but Client is not.

2 - When both Omada and Client are behind a NAT device.

Recommended Solution
  0  
  0  
#3
Options
2 Reply
Re:L2TP VPN Connection issue
3 weeks ago

Hi @User52671 

Thanks for posting in our business forum.

You can check this guide out.

Virtual Services(Port Forwarding) on the Router Doesn't Take Effect

It is not targeting your model but can give you some ideas in troubleshooting your modem router.

The ports are forwarded correctly. Nothing wrong with them.

However, you should check if your WAN is actually a public IP address.

Best Regards! If you are new to the forum, please read: Howto - A Guide to Use Forum Effectively. Read Before You Post. Look for a model? Search your model NOW Official and Beta firmware. NEW features! Subscribe for the latest update!Download Beta Here☚ ☛ ★ Configuration Guide ★ ☚ ☛ ★ Knowledge Base ★ ☚ ☛ ★ Troubleshooting Manual ★ ☚ (Disclaimer: Short links are used above solely for guidance to TP-Link subdomains and are safe and tracker-free. Exercise caution with short links from non-official members on forums. We are not liable for external content or damage from non-official members' link use.)
  1  
  1  
#2
Options
Re:L2TP VPN Connection issue-Solution
2 weeks ago - last edited a week ago

This problem could be related to NAT-T in Windows. Check Google: NAT-T Windows 10/11

 

1) Open the registry editor in Windows. Select Start -> All Programs -> Accessories -> Run, then type 'regedit'.

2) Browser to registry subkey below. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PolicyAgent

3) Create a new DWORD (32-bit) registry value with the string below. AssumeUDPEncapsulationContextOnSendRule

4) Enable NAT-T for both devices located behind NAT. In the Value Data field, type '2'.

5) Restart Windows

 

Note. Meaning of value for the Value Data field.

0 - When both Omad and Client are not behind a NAT device.

1 - When Omada is behind a NAT device, but Client is not.

2 - When both Omada and Client are behind a NAT device.

Recommended Solution
  0  
  0  
#3
Options

Information

Helpful: 0

Views: 130

Replies: 2

Tags

Related Articles