RE450 - Turn off TKIP protocol

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

RE450 - Turn off TKIP protocol

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
RE450 - Turn off TKIP protocol
RE450 - Turn off TKIP protocol
2018-11-02 06:42:55
Model :

Hardware Version :

Firmware Version :

ISP :

Hi guys,I've just got an RE450 to connect up to my Archer D9 for better downstairs coverage. In terms of speed and coverage it's working great, however when it comes to roaming and offering the same level of security, I've come across a hitch.The D9 is set to WPA2-PSK AES. That's all that's allowed with WPA2-PSK only, TKIP and AUTO are blanked out. And to be honest that's all I would like to use as all our devices are modern, and this is the most secure setup.The RE450 however, although supposed to be mirroring the D9's setup, is also allowing TKIP connections. Not only is this less secure, but because it's a different security system to the D9, going up and downstairs means devices cling on to the first connected AP.It definitely appears to affect the handover, as after switching the D9 to offer TKIP, devices swap over instantly upon moving around the house. Even worse with this solution though, is that in order for me to enable TKIP on the D9, I also have to switch security to mixed mode, meaning WPA is offered too, a big problem for security and speed.So does anyone have any idea on how I can disable TKIP on the RE450? I can't see anything in either the admin/IP page, nor on the Tether app to change this. It does seem a rather big setting to not include if this is the case.I've attached a screenshot from WiFiAnalyzer for you to see what I mean.Thanks!
File:
Screenshot_20181101-222255.jpgDownload
  1      
  1      
#1
Options
5 Reply
Re:RE450 - Turn off TKIP protocol
2020-10-05 13:07:59

@trinitron321 I just bought the RE450 yesterday and I'm having the exact same issue.  It signs onto my router using AES but any device that signs onto the TP-Link RE450 is using TKIP.  Apple devices complain stating that it's not a very secure wireless protocol.  There are no options to turn this off.  It's definitely something that needs to be done in the firmware.  I don't understand why TP-Link would create extender with this flaw!  I also don't understand why no one responded to your question in over two years.  That's really bad.  
 

The other issue I have is with the firmware.  The RE450 I have is hardware version 2 even though I bought it yesterday and these are now on hardware version 4.  The firmware version is 1.0.4. It came with this firmware dated from 2017.  There is new firmware and I've tried installing it 7 times.  It tells me it's installing and then after a few seconds it reboots.  When it comes back to the firmware is still version 1.0.4 from 2017-12-20.  That's not working either.  
 

Very disappointed in this product.  I'll see if I can get the firmware upgraded today by trying some more, but I have a feeling I'll be returning this tomorrow.  

  0  
  0  
#2
Options
Re:RE450 - Turn off TKIP protocol
2020-10-11 13:44:08

@trinitron321 

several users are in the same situation, the company is providing inconsistent answers (that the extender will follow the main router security and encryption settings - this is not the case) and no resolution timeline, that can be achieved only through an updated firmware.

  1  
  1  
#3
Options
Re:RE450 - Turn off TKIP protocol
2020-10-11 13:51:55 - last edited 2020-10-11 14:04:42

 

@Solla-topee 

This thread (to which you replied) confirms that regardless of the latest answers that were provided the extenders still broadcast in TKIP mode:

https://community.tp-link.com/en/home/forum/topic/192784

 

An update from your side is needed by yesterday

 

KR

  1  
  1  
#4
Options
Re:RE450 - Turn off TKIP protocol
2021-01-12 10:59:11

Hi all,

it seems that finally we have new official firmware release (thanks TP-Link support!).

For RE450v3 here is the link:

https://www.tp-link.com/en/support/download/re450/v3/#Firmware

 

I tested it and it solves the issue for TKIP.

In order to be sure to get rid of TKIP, just take care to re-scan and re-associate with your main wifi source and you've done.

Hope it helps.

  0  
  0  
#5
Options
Re:RE450 - Turn off TKIP protocol
2021-04-24 05:31:28

@EnzoA 

That doesn't help if you have v2 hardware. I bought two RE450 from Amazon and both devices are v2, not v3.

  0  
  0  
#6
Options

Information

Helpful: 1

Views: 3102

Replies: 5