Disable WPA + TKIP

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Disable WPA + TKIP

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Disable WPA + TKIP
Disable WPA + TKIP
2020-02-09 18:54:04 - last edited 2020-12-01 08:19:48
Model: RE650  
Hardware Version: V1
Firmware Version: 1.0.7 Build 20190521 Rel. 52591

Hi my re650 is connected to my host network via WPA2-PSK
However the range extender is broadcasting with WPA + TKIP which i need turned off but I cannot find it in the settings 

my extender is the top one and host network is the third one

  0      
  0      
#1
Options
1 Accepted Solution
Re:Disable WPA + TKIP -Solution
2020-12-01 08:17:20 - last edited 2020-12-01 08:19:48

@Celticmist 

Good day,

There has been an official firmware which would fix the weak security issue for RE650 v1 and have you updated to this firmware already:

RE650(EU)_V1_200922

https://static.tp-link.com/2020/202011/20201116/RE650_v1_200922.zip

 

Thank you very much.

 

@Pro4TLZZ 

We are really sorry for the inconvenience.

Later If you need further assistance, please feel free to send me a private message and we would be glad to provide any help.

Thank you very much for your understanding and support.

Recommended Solution
  1  
  1  
#8
Options
7 Reply
Re:Disable WPA + TKIP
2020-02-12 07:54:45

@Pro4TLZZ 

 

Hello, thanks for your information.

 

May I know does it affect the actual performance of the extender? Like the clients cannot connect to the extender's wifi with the correct password.

 

Have you ever tried to hard reset and reconfigure the extender?

 

Please ensure that the firmware is up to date.

 

May it help.

  0  
  0  
#2
Options
Re:Disable WPA + TKIP
2020-02-12 08:05:34

@Kevin_Z hi it does affect me as the different security breaks the roaming. I haven't tried a reset as its brand new and there is no control over what security it can broadcast so firmware needs to be added for that

  0  
  0  
#3
Options
Re:Disable WPA + TKIP
2020-09-03 17:28:21
I 100% agree with you and this is freaking me out. On iOS it’s showing me as warning when I connect to the extender because it knows it’s vulnerable to security and easily hackable
  0  
  0  
#4
Options
Re:Disable WPA + TKIP
2020-09-14 11:15:06

@Pro4TLZZ @OynSat 

Good day.

Sorry for the delay.

Thank you very much for your time and patience.

We would like to forward your case to our senior engineers and please check your email box.

What is the model number of your home router?

Are the CH100+CH1 SSIDs of 5ghz and 2.4ghz of RE650? CH11, the SSID of home router?

Thank you very much.

  0  
  0  
#5
Options
Re:Disable WPA + TKIP
2020-11-23 18:32:32
@Solla-topee I have the same problem, what did the engineer recommend?
  0  
  0  
#6
Options
Re:Disable WPA + TKIP
2020-11-23 18:34:54
when i wrote the issue the support was not able to help, so i just returned the product. I want to get a TP router soon but this is putting me off
  0  
  0  
#7
Options
Re:Disable WPA + TKIP -Solution
2020-12-01 08:17:20 - last edited 2020-12-01 08:19:48

@Celticmist 

Good day,

There has been an official firmware which would fix the weak security issue for RE650 v1 and have you updated to this firmware already:

RE650(EU)_V1_200922

https://static.tp-link.com/2020/202011/20201116/RE650_v1_200922.zip

 

Thank you very much.

 

@Pro4TLZZ 

We are really sorry for the inconvenience.

Later If you need further assistance, please feel free to send me a private message and we would be glad to provide any help.

Thank you very much for your understanding and support.

Recommended Solution
  1  
  1  
#8
Options

Information

Helpful: 0

Views: 4657

Replies: 7

Related Articles