MR3220 not working after firmware upgrade.

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
12
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
MR3220 not working after firmware upgrade.
MR3220 not working after firmware upgrade.
2012-11-04 17:11:36
Region : India

Model : TL-MR3220

Hardware Version : Not Clear

Firmware Version : 3.14.2 Build 120822 Rel.57775n

ISP : BSNL EVDO


Hello Support,

I have one BSNL EVDO data card which was working fine before firmware upgrade to latest 3.14.2 Build 120822 Rel.57775n. Now it is keep on saying device unplugged after identifying the device. The device is working fine while connected on my laptop.

Please provide me the solution asap.


Regards,
Vikas Varma
0
0
#1
Options
16 Reply
Re:MR3220 not working after firmware upgrade.
2012-11-04 17:28:02
Below are my modem details which I use with this device, in case if some one can share modem bin files.


Reliance Netconnect+ , ZTE AC2736
BSNL EVDO, ZTE AC8700

Regards,
Vikas
0
0
#2
Options
Re:MR3220 not working after firmware upgrade.
2012-11-04 19:20:42
How to check the hardware version: http://www.tp-link.com/en/Article/?id=46 Is it v2?
There may be some compatible problem, you may downgrade to the previous firmware.
0
0
#3
Options
Re:MR3220 not working after firmware upgrade.
2012-11-04 19:41:13
Yes it is V2. I tried the previous version of firmware too. but it is giving the same error. Below logs reports the error.
I thin I need to push modem bin file into the device.

####################################################################
# TL-MR3220 System Log
# Time = 1970-01-01 0:03:21 202s
# H-Ver = MR3220 v2 00000000 : S-Ver = 3.14.2 Build 120822 Rel.57775n
# L = 192.168.0.1 : M = 255.255.255.0
# 3G : 3G = 0.0.0.0 : M = 0.0.0.0 : G = 0.0.0.0
####################################################################

1st day 00:00:08 OTHER INFO System started
1st day 00:00:19 DHCP NOTICE DHCP server started
1st day 00:00:19 SECURITY INFO PPTP Passthrough enabled
1st day 00:00:19 SECURITY INFO L2TP Passthrough enabled
1st day 00:00:19 SECURITY INFO IPSEC Passthrough enabled
1st day 00:00:19 SECURITY INFO FTP ALG enabled
1st day 00:00:19 SECURITY INFO TFTP ALG enabled
1st day 00:00:19 SECURITY INFO H323 ALG enabled
1st day 00:00:19 SECURITY INFO RTSP ALG enabled
1st day 00:00:30 DHCP NOTICE DHCPS:Recv REQUEST from 00:24:D7:3E:63:2C
1st day 00:00:31 DHCP NOTICE DHCPS:Send ACK to 192.168.0.101
1st day 00:00:33 3G/4G NOTICE handle_card start
1st day 00:00:33 3G/4G INFO LTE MODEM = 0, status = 1, targetVendorID = 0x0, targetProductID = 0x0
1st day 00:00:36 DHCP NOTICE DHCPS:Recv REQUEST from 00:1D:FE:DD:4E:DE
1st day 00:00:37 DHCP NOTICE DHCPS:Send ACK to 192.168.0.100
1st day 00:00:38 3G/4G INFO Before Mode switch VendorID = 0x19d2, ProductID = 0xfffe
1st day 00:01:30 3G/4G INFO Main interface_index[0] = 0
1st day 00:01:31 3G/4G NOTICE after switch modem vid is 0x19d2 pid is 0xfffe
1st day 00:01:34 3G/4G INFO getModemPinStatus 257 Can not get modem PIN status
1st day 00:01:34 3G/4G INFO LTE MODEM = 0, status = 2, targetVendorID = 0x19d2, targetProductID = 0xfffe
1st day 00:01:34 3G/4G INFO USB modem is ready
1st day 00:01:44 PPP NOTICE Standard authentication.
1st day 00:01:44 3G/4G NOTICE 3G/4G start connecting...
1st day 00:01:44 3G/4G INFO Run 3G dial cmd: pppd 3g 1 /dev/ttyUSB0 115200 connect "chat -s -v -f /etc/ppp/c
1st day 00:01:44 PPP INFO pppd start
1st day 00:01:52 DHCP NOTICE DHCPS:Recv INFORM from 00:24:D7:3E:63:2C
1st day 00:01:55 3G/4G WARNING 3G Modem connecting error, please check the dial number and APN.
1st day 00:01:55 3G/4G INFO sw3GMobileCmdReq 330 mobileFormatCmd error

1st day 00:02:06 PPP NOTICE Standard authentication.
1st day 00:02:06 3G/4G NOTICE 3G/4G start connecting...
1st day 00:02:06 3G/4G INFO Run 3G dial cmd: pppd 3g 1 /dev/ttyUSB0 115200 connect "chat -s -v -f /etc/ppp/c
1st day 00:02:06 PPP INFO pppd start
1st day 00:02:16 3G/4G NOTICE Reset the 3G modem, please wait.
1st day 00:02:17 3G/4G NOTICE handle_card start
1st day 00:02:17 3G/4G INFO LTE MODEM = 0, status = 1, targetVendorID = 0x0, targetProductID = 0x0
1st day 00:02:17 3G/4G INFO LTE MODEM = 0, status = 0, targetVendorID = 0x0, targetProductID = 0x0
1st day 00:02:17 3G/4G NOTICE delete usb_reset file
1st day 00:02:18 3G/4G INFO sw3GMobileCmdReq 330 mobileFormatCmd error

1st day 00:02:20 3G/4G INFO 3G Modem is plugged out.
1st day 00:02:25 3G/4G NOTICE handle_card start
1st day 00:02:25 3G/4G INFO LTE MODEM = 0, status = 1, targetVendorID = 0x0, targetProductID = 0x0
1st day 00:02:30 3G/4G INFO Before Mode switch VendorID = 0x19d2, ProductID = 0xfffe
1st day 00:03:21 3G/4G INFO Main interface_index[0] = 0
1st day 00:03:22 3G/4G NOTICE after switch modem vid is 0x19d2 pid is 0xfffe
0
0
#4
Options
Re:MR3220 not working after firmware upgrade.
2012-11-05 13:02:24
Wow, from the very long log, dail number and APN information may be incorrent.
Just confirm it with your ISP and may put in manually for a try.
To get technical support from tplink directly is a more effecient solution for you.
0
0
#5
Options
Re:MR3220 not working after firmware upgrade.
2012-11-05 20:30:07
reset and reconfigure the router; put the dial no. and APN manually - that may help.
0
0
#6
Options
Re:MR3220 not working after firmware upgrade.
2012-11-06 20:32:09
I have already done reset many times and the same user/password working fine on my laptop.

I have reset the modem & run quick setup many times and when it start dialing. it automatic unplug the deice and status says device unplugged.

This is something which is corrupted at code level.

I would still say if you have the BIN file for these modems please provide me that.
0
0
#7
Options
Re:MR3220 not working after firmware upgrade.
2012-11-06 21:15:58
I have a tp-link 3G router before. You may try to set it up on Network-3G, NOT from quick setup. If your problem still remains, you'd better contact the tplink guy for help.
0
0
#8
Options
Re:MR3220 not working after firmware upgrade.
2012-11-21 22:13:13
MR3220 not working after firmware upgrade with my ZTE modem of 3G EVO.
0
0
#9
Options
Re:MR3220 not working after firmware upgrade.
2012-11-22 18:18:13
Hi,

I am facing the same problem. MR3220 isnt working after firmwire upgrade. Can any one tell me the solution please.
0
0
#10
Options
Re:MR3220 not working after firmware upgrade.
2012-12-11 03:13:15
Hello to all..

I had the same problem with my TL-MR3420 v.1 and with TL-MR3420 v.2

solved only for TL-MR3420 v.1:
download from TP-LINK site and downgrade the firmware to mr3420v1_en_3_12_8_up(110418).bin

Explanation:
what happens is that the new/latest firmware has a bug and only 4G modems get to work. The old 3G or 3.75G don't connect. It will show you the signal strength
100% and the modem works on any laptop/PC wit windows or Linux, but not with the TL-MR3420 v.1 that has the bin later than 110418 or any bin on TL-MR3420 v.2

So, for the new TL-MR3420 v.2 there is no bin file that can fix this. I have even tried to use the same mr3420v1_en_3_12_8_up(110418).bin, but of course no luck :-)

Actually I registered just to request TP-LINK to provide the solution for this problem BECAUSE I HAVE A BRAND NEW ROUTER that is not compatible with my modem that works
on a older router. I understand that an upgrade of a router should fix problems, not create new!
My MODEM is ZTE AC2746 3/3,75G CDMA2000

Best regards

Victor Riquelme
+258 84 3373 160
0
0
#11
Options