My new Range Extender does not connect to the router

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
My new Range Extender does not connect to the router
My new Range Extender does not connect to the router
2019-02-24 15:50:22
Model: TL-WA850RE
Hardware Version: V6
Firmware Version:

I have bought a new tp-link TL-WA850RE range extender and have tried installing it and connecting it to my router. I could not connect it through pressing the WPS button on the router so tried the second method of installing through my PC. I have followed all instructions, named the SSID with a different name than my home network, kept the same password and continued with the wireless setting process until getting a congratulations notification teling me I can now connect to the extended network. Hoever, the RE light in the RE device did not light up and I could not connect through the RE network to the internet. I have tried resetting the RE device several times but without any change in the result. Would appreciate advice on how to resolve this before goign back to the store to replace the product... Thanks

 

 

0
0
#1
Options
3 Reply
Re:My new Range Extender does not connect to the router
2019-02-26 06:25:16

Before you set up the extender, please make sure there is no special settings such as MAC filtering and access control on your router, they may block the extender.

 

Then please confirm your router's wifi password, make sure it is correct, you can try to forget the home network on the phone then try to reconnect it back, if you are not able to reconnect it back with the password, that means the password is incorrect, that's why you failed to install the extender.

 

After that please refer to this manual to check the extender's firwmare version(start from step 2), https://www.tp-link.com/en/faq-1416.html, if the firmware version is not the latest, update it and reinstall it.

 

By the way, what's the model number of your router?

0
0
#2
Options
בעיה באבטחהRe:My new Range Extender does not connect to the router
2020-04-28 18:42:00

בעיה באבטחה 

@zivo 

0
0
#3
Options
Re:My new Range Extender does not connect to the router
2020-06-05 19:29:06

@zivo 

Hi i have bouth a new tplink extender TL-WA850RE but the RE LED is never solid so i cannot connected. 

My router is a Mitrastar model GPT-2541GNAC

Mac filter is off.

I can see in my mobile and laptop a wifi with the name of my network_EXT but the button never gets solid. i have tried the three methods and nothing.

I am sure about password.

can you please support me?

Thanks.

 

Martin

1
1
#4
Options