Why Deco M5 in router will not adress clients?

Why Deco M5 in router will not adress clients?
Why Deco M5 in router will not adress clients?
2019-04-07 10:27:47 - last edited 2019-04-07 11:59:49
Model: Deco M5
Hardware Version:
Firmware Version:

Hello!

 

Actually in AP mode i had some problems with gateway addressing, so i decided to disable my box DHCP and enable DECO in rooter mode with DHCP.

 

So i don't undertand why DECO will not apply Addresses to clients in LAN connexion? It seems that the DHCP mode will only apply to WLAN clients?

Is there something wrong in my config?

 

To be more precise

 

Add internet to static IP

adress 192.168.2.253

mask 255.255.255.0

Gateway 192.168.2.254

DNS 192.168.2.254

 

192.168.2.254 is my internet box

 

LAN

192.168.1.253

 

DHCP

192.168.1.200 to 250

 

All my WLAN clients are ok and have full access but with LAN clients over the network they will not have any address from DECO?

 

Thanks in advance for replies (and sorry for my poor english)

0
0
#1
Options
15 Replies
Re:Why Deco M5 in router will not adress clients?
2019-04-07 22:17:01 - last edited 2019-04-07 22:17:43

As you have had a router and access point setup previously, as a sanity check I have to ask, are the clients that are not getting the IP addresses from DHCP downstream from the the Deco? - ie: not connected to the router ports or on a switch between the router and the Deco.


Are your LAN clients connected directly to the downstream ports on the Deco, or do they connect to a switch and then to the Deco?  If using a switch, do you get the same result for a client connected directly to the Deco?

0
0
#2
Options
Re:Why Deco M5 in router will not adress clients?
2019-04-09 01:45:12

Hi,

 

With Deco connected to the internet box by wired cable and works as the AP mode, can you access internet from the AP Deco by wireless? 

 

Meanwhile, with device connected to the AP Deco by wired cable, please check its IP address and show us a screenshot. 

Note: How to check IP address: https://www.tp-link.com/en/support/faq/838/

 

Besides, with device connected to the internet box directly, bypass the AP Deco, what is the IP address it obtained and can they access internet? 

 

Thanks in advance. Good day. 

 

 

0
0
#3
Options
Re:Why Deco M5 in router will not adress clients?
2019-04-10 19:45:43 - last edited 2019-04-10 19:47:13

Hello!

 

My internet box is wired to a switch and all my DECO too, all my wired clients are connected to the same switch.

 

Previously i was configured as: box was DHCP server and DECO as AP. All was working fine (except that i can't manage DECO's IP in manual mode...) and all my clients wired or WIFI with good adresses given by box DHCP server.

 

But i changed my internet provider, and recived a new box. On it, the settings are very light (some missing settings, not the top of the router...), and with it, sometimes on WLAN clients i found 2 DNS adresses (1 of my box ands the second was the IP of the master DECO???!!!) and gateway with the adress of DECO master.

By this issues i decided to change all my configuration, make the DECO my DHCP server, to manage all my network, disabling DHCP on my box. The problem is that all the wired clients remains without IP adress, DECO DHCP seems to adress only WLAN clients.

 

Hope i've explained my problem correctly...

 

Thanks

0
0
#4
Options
Re:Re:Why Deco M5 in router will not adress clients?
2019-04-10 22:59:17

So, just to confirm, you have your network set up like this?:

 

Router -----> Switch -------> Deco (Main)
                     +------> Deco (Other)
                     +------> Deco (Other)       
                     +------> Other Client
                      

    

If so this won't work in Router mode.  The Deco DHCP server will only issue addresses to devices on the inside (ie: attached to the second wired interface on the master unit, or to one of the slave units.)  If it issued addresses out the outside interface they would be in the wrong address range, and for most people, not even on their network!  Also, in this configuration the non-main Decos are probably using wireless rather than wired connections to form their mesh as they are on the wrong side of the main Deco.

 

If you want to take advantage of all the Deco router features your network must be setup like this:

 

Router -----> Deco (Main) -------> Switch -------> Deco (Other)                                       
                                          +------> Deco (Other)
                                          +------> Other Client

 

That way the Main deco can issue IP addresses to all clients, both wired to the switch and on the wireless, as they are all on the inside (downstream) of the Deco system.

 

Hope that helps.

0
0
#5
Options
Re:Re:Re:Why Deco M5 in router will not adress clients?
2019-04-11 19:26:22

Hello!

 

Yes i confirm that my network is build like this, it's a shame that DECO won't apply same rules on both ports....

 

In my case it's impossible without many work to be as the second solution. My internet bos in LTE 4G is just bottom the roof of my house, and in the same place i have a WRT54G in AP mode to link another house in WIFI. The main switch is lacated in a technical room near garage, and in this place i don't need a DECO, so i'm condemned to DHCP with my internet box.

 

I've tried to DHCP with my WRT54G and with my 100MB internet connection, i've noticed some slow-down by having this as gateway (think the WRT54G is aged now for fast internet....)

 

Thanks for your replies, and pity that don't work.

0
0
#6
Options
Re:Re:Re:Re:Why Deco M5 in router will not adress clients?
2019-04-12 06:00:37

>nobru26 wrote

>Yes i confirm that my network is build like this, it's a shame that DECO won't apply same rules on both ports....

 

It's not really a shame - and it's not specific to Deco - when it's configured as a router it has to act as one.  And issuing IP addresses onto the ISP side of the network (which is the other side for most peoples' setups) would be a very unsafe thing to do.  Access Point mode is the one designed to run like that.

 

 

> In my case it's impossible without many work to be as the second solution. My internet bos in LTE 4G is just bottom the roof of my house, and in the same place i have a >WRT54G in AP mode to link another house in WIFI. The main switch is lacated in a technical room near garage, and in this place i don't need a DECO, so i'm condemned to 

> DHCP with my internet box.

 

Anywhere between the router and the switch would do - that could include wherever your LTE box and other access point are located.  Otherwise you can always get extra deco nodes, even if you don't really need wifi near your garage, one could sit there in a router role.

 

In general however it looks like you would prefer your setup to be in Access Point mode anyway.  What problems drove you to change to Router mode?  It may be better to address those problems directly.  I had thought from other posts here that it was possible to turn on DHCP on Deco even in AP mode - is that not the case?  I can't check on mine without breaking the current config as I'm running Deco as a Router.  If not do you have anything else fixed on the network that can server DHCP - NAS, Rasberry Pi, server, etc?

 

 

0
0
#7
Options
Re:Re:Re:Re:Re:Why Deco M5 in router will not adress clients?
2019-04-12 11:08:02

Hello!

 

Issue today, first problem again.

 

I restated my internet box who's the router, all DECO still active (no power cutting).

 

After i found my laptop (wifi) with an adress outside my router reserved adressing and with 2 dns adress?!

i foung it at 192.168.1.12 255.255.255 DNS 192.168.1.254 and 192.168.1.208 

 

I don't understand why in AP mode it seems that the DECO will sometims apply adress to wifi clients....

 

After this i've restarted all my network, BOX and DECO and now DECO is RED fixed...

 

It's very strange, just after insdtalltion i've never noticed this problem, is there an issue in new firmware?

 

Thanks for you help...

0
0
#8
Options
Re:Re:Re:Re:Re:Re:Why Deco M5 in router will not adress clients?
2019-04-12 20:05:42

Re,

 

Made 1.2.8 update = same issue.

 

Tested again.

 

Start in AP mode with internet connexion in automatic, all fine with clients adressed as 192.168.1.2xx, 255.55.255.0, 192.168.1.254, DNS 192.168.1.254.

I tried to restart my DHCP router (my box) my clients chage adress to 192.168.1.12, 255.255.255.0, 192.168.1.208, DNS 192.168.1.208 and 192.168.1.254!!!!!

 

Resulting with no internet connexion, bad IP adress, why DECO in AP mode send adress to clients???? Normally they would loose their adress and wait DHCP come on again?

 

I'm disapointed by this material! Is their someone who can test on his network?

 

Second question, how is the setting if i would try to set internet connexion as manual on dECO side? (my box is 192.168.1.254)

0
0
#9
Options
Re:Re:Re:Re:Re:Re:Re:Why Deco M5 in router will not adress clients?
2019-04-12 20:13:39
To have more information again, I've just restarted the DECO unit and = RED light Clients on DECO WIFI have address: 192.168.68.101 255.255.255.0 192.168.1.1 192.168.1.1. It's really a shame on DECO, what is comming with this products?
0
0
#10
Options
Re:Re:Re:Re:Re:Re:Re:Re:Why Deco M5 in router will not adress clients?
2019-04-15 09:35:15

Hi, 

Thanks for your reply.

 

Do you have internet access from Deco in AP mode when LED light red now?

 

If it is, could you please check if you enabled DHCP function on your switch that feeds the Deco M5? If so, the IP address on wireless device is possible from there. 

 

To help locate the problem, could you please connect a windows PC to the Deco network and ping 192.168.1.1, screenshot;

Then type in arp a, the actual MAC address of the device that provides IP address for your wireless devices will be found. Please send us the screenshot as well on that page.

 

Thanks in advance, good day!

0
0
#11
Options