Having trouble setting up an OpenVPN server on the Archer C7 v5

Having trouble setting up an OpenVPN server on the Archer C7 v5
Having trouble setting up an OpenVPN server on the Archer C7 v5
2019-04-26 18:20:07 - last edited 2020-09-10 10:30:29
Model: Archer C7
Hardware Version:
Firmware Version: Version 5

Hi there,

 

I purchased an Archer C7 yesterday and have succesfully intergrated it into my home network. There is only one area I am struggling with and that is the OpenVPN server.

 

I followed the instructions and exported a .opvn file, however it doesn't seem to work when loaded into my OpenVPN client on my Windows 10 laptop. Is there a trick to getting this to work?

 

Also can I use the same file on more than one device?

 

Cheers

0
0
#1
Options
1 Accepted Solution
Re:Re:Re:Re:Re:Re:Re:Re:Having trouble setting up an OpenVPN server on the Archer C7 v5-Solution
2020-09-10 10:30:19 - last edited 2020-09-10 10:30:29

@Dalaracing 

 

Hello, 

 

Is your model number Archer C7? Ensure it is running with the latest firmware first.


Please help verify some details and we will try to figure it out:
1. Kindly check the below VPN setup instructions again to confirm all the settings on the C7 are correct:
How to use OpenVPN to access your home network through the Wi-Fi Routers
BTW, please also provide us your network topology.
2. If the above guide doesn't help, please tell us what is the WAN IP address of the C7 and it is suggested to configure the DDNS:
How to set up TP-LINK DDNS on TP-Link Wireless Router?

3. Please check the VPN Tunnel: login the web interface, and on the VPN Server-> VPN Connections, we can see the status of the VPN Server, confirm if there is a VPN connection enabled. If not, which means the VPN setup is not successful.
4. Check the Firewall and Anti-Virus software on the server: generally, Windows Firewall would block the packages from the VPN Client, disabling the firewall on Windows PC for "public" and "private" network will be helpful. Windows Firewall is located at "Control panel->System and Security->Windows Firewall/Windows Defender Firewall".

 

May it help.

Recommended Solution
0
0
#12
Options
14 Replies
Re:Having trouble setting up an OpenVPN server on the Archer C7 v5
2019-04-27 19:19:10

This is the message I get in the OpenVPN client when I try to run it

 

Sat Apr 27 20:17:17 2019 WARNING: No server certificate verification method has been enabled.  

0
0
#2
Options
Re:Re:Having trouble setting up an OpenVPN server on the Archer C7 v5
2019-04-28 06:36:16

Hi,

 

After you enabled the OpenVPN server on the web UI, please generate the certificate to give it a go.

https://www.tp-link.com/en/support/faq/1239/

 

Any updates, please let me know. 

 

Have a nice day. 

 

 

0
0
#3
Options
Re:Re:Re:Having trouble setting up an OpenVPN server on the Archer C7 v5
2019-04-28 08:36:59

Hey Kevin,

 

This is exactly the method I have been using.

 

Any thoughts on why it might not be working?

 

Cheers

0
0
#4
Options
Re:Re:Re:Re:Having trouble setting up an OpenVPN server on the Archer C7 v5
2019-04-29 01:40:26

Hi,

 

Our engineer will contact you via email then, if you are willing to do further analysis, please notice your inbox. 

 

Have a nice day. 

 

CraftyClown wrote

Hey Kevin,

 

This is exactly the method I have been using.

 

Any thoughts on why it might not be working?

 

Cheers

 

0
0
#5
Options
Re:Re:Re:Re:Re:Having trouble setting up an OpenVPN server on the Archer C7 v5
2019-07-10 09:57:02 - last edited 2019-07-10 09:57:29

Hi,

 

I am having the exact same issue on my router TL-MR6400, Any ideas in how to overcome this issue?

 

 

Best,

 

0
0
#6
Options
Re:Re:Re:Re:Re:Re:Having trouble setting up an OpenVPN server on the Archer C7 v5
2019-07-12 05:42:51

@MohamedC 

 

You can refer to the instruction below to setup the OpenVPN on MR6400.

https://www.tp-link.com/support/faq/2482/

 

Could you please provide more information about the current issue? Is there any error message when you tried to connect to the OpenVPN server on your remote clients. 

 

Please take a screenshot of it and send it to us. 

 

Meanwhile, what is the hardware and firmware version? 

0
0
#7
Options
Re:Re:Re:Re:Re:Re:Re:Having trouble setting up an OpenVPN server on the Archer C7 v5
2019-07-14 06:34:10

Kevin_Z wrote

@MohamedC 

 

You can refer to the instruction below to setup the OpenVPN on MR6400.

https://www.tp-link.com/support/faq/2482/

 

Could you please provide more information about the current issue? Is there any error message when you tried to connect to the OpenVPN server on your remote clients. 

 

Please take a screenshot of it and send it to us. 

 

Meanwhile, what is the hardware and firmware version? 

Hello Kevin,

 

 

I have followed the same exact steps mentioned in the article, but I keep getting this error when establishing the OpenVPN session:

 

Sun Jul 14 09:31:04 2019 WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
 

I am using a version 3 hardware of TL-MR6400 with firmware version of 181022.

 

Best,

MohamadC

0
0
#8
Options
Re:Re:Re:Re:Re:Re:Re:Re:Having trouble setting up an OpenVPN server on the Archer C7 v5
2019-07-16 07:18:31

@MohamedC 

 

Thanks for your reply; to fix this issue, our engineer will email you later, if you are willing to do further troubleshooting, please check your inbox. 

 

Thanks for your cooperation and understanding in advance, and have a nice day. 

 

 

0
0
#9
Options
Re:Re:Re:Re:Re:Re:Re:Re:Re:Having trouble setting up an OpenVPN server on the Archer C7 v5
2019-07-16 07:41:33
@Kevin_Z Thank you for your reply. I will wait for the engineering team message. Have a nice day
0
0
#10
Options
Re:Re:Re:Re:Re:Re:Re:Re:Having trouble setting up an OpenVPN server on the Archer C7 v5
2020-09-10 09:47:06

@Kevin_Z 

Hi Kevin

i have the same issue. Can your enginner contact me? 

 

Have a nice day

// johan 

 

File:
Capture.PNGDownload
0
0
#11
Options