TP-Link Archer C20 V4 (US) - wifi not working after going back to stock

TP-Link Archer C20 V4 (US) - wifi not working after going back to stock
TP-Link Archer C20 V4 (US) - wifi not working after going back to stock
2019-09-14 13:51:22 - last edited 2019-09-19 06:34:01
Model: Archer C20
Hardware Version: V4
Firmware Version:

Hi There

I recovered my Archer C20 from OpenWRT to Stock Firmware but when I go to router settings, both 2.4GHz and 5Ghz seem not working

there are not MAC Address in both bands just FF: FF: FF: FF: FF: FF and MAC Address is empty in WAN
Can Anyone help me or give me an advise?!!

Which blocks should I edit for mac address?!!!!

I appreciate that

0
0
#1
Options
1 Accepted Solution
Re:TP-Link Archer C20 V4 (US) - wifi not working after going back to stock-Solution
2019-09-18 09:39:46 - last edited 2019-09-19 06:34:01

@Kevin_Z 

Hi Again

Finally, I went back to OpenWRT and config Wireless!  cheekywinkit works fine, but I was wondering why there is such a problem like that while going back to stock firmware! it's the secret that I'll figure it out  one dayenlightenedlaugh I just know I must modify Stripped Firmware that I created beforewink

Thank You very much for your reply

Appreciate that

Best Solution
0
0
#5
Options
5 Replies
Re:TP-Link Archer C20 V4 (US) - wifi not working after going back to stock
2019-09-16 05:59:41 - last edited 2019-09-16 07:22:05

@David.1983 

 

This router seems faulty. Anyway, we can do some troubleshooting first, but I have to say, if we cannot fix it, there will be not much we can do; and installing the 3rd party firmware is against the warranty policy, we are not able to offer a replacement. 

 

With the MAC address of the 2.4GHz and 5GHz changed, can you detect the wifi name on the wireless devices? And can you connect to them with the wifi password? 

 

For the WAN MAC, the current WAN IP is absent, and it shows cable is unplugged; you can connect your  modem to the internet port and configure it first with the username and password given by ISP. 

 

May it help and have a good day. 

 

0
0
#2
Options
Re:TP-Link Archer C20 V4 (US) - wifi not working after going back to stock
2019-09-17 05:00:35

@Kevin_Z 

Hi Kevin

Thank You for your reply

No I can't detect both wifi with any device 

when I connect cable to WAN I have Internet but there is no MAC Address while cable is connected

 

When I update my router to OpenWRT I'm able to enable wireless and wireless devices detect it and I don't have those problems on Openwrt 

but in Stock firmware all of them show up again

I believe that I should edit hex in picture number 2  to change MAC but I don't know which blocks I should edit

0
0
#3
Options
Re:TP-Link Archer C20 V4 (US) - wifi not working after going back to stock
2019-09-18 09:09:53

@David.1983 

 

The wifi networks cannot be detected and the MAC address is blank, if you can flash the OpenWRT firmware, you can give it a go.

 

Otherwise, there is not much we can do. 

 

Good day. 

 

0
0
#4
Options
Re:TP-Link Archer C20 V4 (US) - wifi not working after going back to stock-Solution
2019-09-18 09:39:46 - last edited 2019-09-19 06:34:01

@Kevin_Z 

Hi Again

Finally, I went back to OpenWRT and config Wireless!  cheekywinkit works fine, but I was wondering why there is such a problem like that while going back to stock firmware! it's the secret that I'll figure it out  one dayenlightenedlaugh I just know I must modify Stripped Firmware that I created beforewink

Thank You very much for your reply

Appreciate that

Best Solution
0
0
#5
Options
Re:TP-Link Archer C20 V4 (US) - wifi not working after going back to stock
2019-09-19 06:33:18

@David.1983 

 

Thanks for your reply, glad to hear that you figured it out by flashing back to OpenWRT. Congrats.

 

The reason why it stops working when use the stock firmware is still a misery, but it seems that the 3rd party has changed some settings on the router which the stock firmware cannot detect or match. You can sort it out someday. wink

 

Now you can enjoy the internet with the router.

 

Best regards. 

0
0
#6
Options