Archer T4U V3 AC1300: very low and odd speeds

Archer T4U V3 AC1300: very low and odd speeds
Archer T4U V3 AC1300: very low and odd speeds
2019-09-18 11:28:56
Model: Archer T4U
Hardware Version: V3
Firmware Version:

Hi

I've recently switched to a new router and fiber connection (1 gbps) with both 2.4G and 5G gateways, and bought an Archer T4U V3 adapter to use with it.

I've followed all installation instruction properly, plugged it into a USB 3.0 port and connected it with the 5G gateway, however speed tests show an average speed of 7.5 Mbps in download and, oddly enough, 39.5 Mbps in upload. The wireless associated speed is shown to be 585.0 Mbps, and I've made some speed tests with an ethernet cable to check if the router connection was weak but the speed via cable is as it should be (8-900 Mbps give or take). I've tried different USB 3.0 ports but it changed nothing.

 

I've uninstalled and reinstalled the adapter several times already, but the speed remained low. The signal is always shown as good, and the distance between my router and PC is 10 metres (I'll install a signal repeater tomorrow).

 

During most tests I've noticed that the download speed always spikes at the beginning of the test (between 60 and 100 mbps, it's pretty random) then drops after a second or so and stays low.

I've tried making a test using my Galaxy A10 (which doesn't run on 5G) as a hotspot and the results were 51 Mbps in download and 24 Mbps in upload.

My PC runs on Win7.

Can somebody help me with this issue?

 

1
1
#1
Options
1 Reply
Re:Archer T4U V3 AC1300: very low and odd speeds
2019-09-19 09:18:15 - last edited 2019-09-19 09:37:22

@FlerpLeClerk 

 

May I know what is the model number of the main router? 

 

With T4U connected to the 2.4GHz, what is the speed you can get? 

 

Have you ever tried to change the wireless settings of 5GHz on the main router to give it a go? 

 

Meanwhile, from the speed the T4U get from the mobile hotspot, the adapter should be fine. You can try to search the driver online with the chipset of the Archer T4U, which is RTL8812BU.

 

Or you can try to install the driver attached below:

http://support.tp-link.com/f/b28f69d9e4/?dl=1

 

How to install it manually, please refer to https://www.tp-link.com/support/faq/228/

 

Good day. 

0
0
#3
Options