Archer T4U V2 "crashes" when i connect to 5 GHz but works fine with 2 GHz

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Archer T4U V2 "crashes" when i connect to 5 GHz but works fine with 2 GHz

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer T4U V2 "crashes" when i connect to 5 GHz but works fine with 2 GHz
Archer T4U V2 "crashes" when i connect to 5 GHz but works fine with 2 GHz
2019-11-23 21:19:35 - last edited 2019-11-29 09:07:20
Model: Archer T4U V2  
Hardware Version: V2
Firmware Version:

Dear TP-Link community

 

I have recently purchased a TP-Link Archer T4U V2. 

 

Every time I boot my computer (Windows 10 64 bit) I have issues connecting to my 5 GHz network. It is difficult to describe the issue as it feels like the adapter "crashes" when I try to connect. Sometimes it works after 3-4 times but other times I have no success.

 

I have tried to delete the driver which didn't work. Furthermore, I tried to use the CD that came with my T4U but the software didn't fix it either. Lastly, I tried to download the driver from the website but that didn't work either.

 

2Ghz works fine and if I finally succeed connecting to 5 GHz the connection is stable.

 

I have recorded a video that shows the issue: https://streamable.com/u6nzn

 

I hope that you can provide me with some insight on how to fix this issue.

 

Best regards 

Daniel

 

 

  0      
  0      
#1
Options
1 Accepted Solution
Re:Archer T4U V2 "crashes" when i connect to 5 GHz but works fine with 2 GHz-Solution
2019-11-28 08:23:25 - last edited 2019-11-29 09:07:20

@DanielDK 

 

From the video attached, once you booted your computer and try to connect to the 5GHz, it shows connecting but then no wifi network detected, it will appear again in seconds but still failed to connect to 5GHz; while if you connect to the 2.4GHz first and then reconnect to the 5GHz, it seems it is connected but then the it is connected to 2.4GHz again. 

 

And I found that the signal strength of 5GHz is unstable, sometimes it is one bar, sometimes it is 3/4 bars. So we can do some troubleshooting first. 

1. Try to move the computer closer to the router and ensure that it can obtain good signal strength from 5GHz.

2. Try to change the wireless settings of the 5GHz on the main router to improve its performance like wireless channel and channel width. 

3. If it failed to connect to 5GHz, try to remove the profile and reconnect to it. 

4. Try to find the driver from the manufacturer's website with the chipset, which is Realtek RTL8812AU.

 

May it help. 

 

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
Recommended Solution
  1  
  1  
#2
Options
3 Reply
Re:Archer T4U V2 "crashes" when i connect to 5 GHz but works fine with 2 GHz-Solution
2019-11-28 08:23:25 - last edited 2019-11-29 09:07:20

@DanielDK 

 

From the video attached, once you booted your computer and try to connect to the 5GHz, it shows connecting but then no wifi network detected, it will appear again in seconds but still failed to connect to 5GHz; while if you connect to the 2.4GHz first and then reconnect to the 5GHz, it seems it is connected but then the it is connected to 2.4GHz again. 

 

And I found that the signal strength of 5GHz is unstable, sometimes it is one bar, sometimes it is 3/4 bars. So we can do some troubleshooting first. 

1. Try to move the computer closer to the router and ensure that it can obtain good signal strength from 5GHz.

2. Try to change the wireless settings of the 5GHz on the main router to improve its performance like wireless channel and channel width. 

3. If it failed to connect to 5GHz, try to remove the profile and reconnect to it. 

4. Try to find the driver from the manufacturer's website with the chipset, which is Realtek RTL8812AU.

 

May it help. 

 

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
Recommended Solution
  1  
  1  
#2
Options
Re:Archer T4U V2 "crashes" when i connect to 5 GHz but works fine with 2 GHz
2019-11-29 09:07:01

@Kevin_Z 

 

Hi Kevin

 

Thank you very much for your suggestions. I appreciate you taking your time to help me.

 

However, none of your suggestions have helped. I will try to return my adapter and purchase a new one as the same issue happen when I try to use the adapter on my laptop.

 

 Best regards

Daniel

  0  
  0  
#3
Options
Re:Archer T4U V2 "crashes" when i connect to 5 GHz but works fine with 2 GHz
2019-12-02 09:53:53

@DanielDK 

 

I see, sorry for that; you can return it and get a new one first and test its performance. 

 

Any further problem, just be free to let us know.

 

Best regards. 

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#4
Options