TP-Link Wireless MU-MIMO USB Adapter not work in usb3 mode! Need help!

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
TP-Link Wireless MU-MIMO USB Adapter not work in usb3 mode! Need help!
TP-Link Wireless MU-MIMO USB Adapter not work in usb3 mode! Need help!
2020-01-23 10:13:43
Model: Archer T4U
Hardware Version: V3
Firmware Version:

Hello everyone! My Archer connected to usb3 port (Lenovo desktop) but work in usb2! Drivers are old 2018 in website here, was trying them but still i have usb2. Someone can help me to find the right drivers? Thank you.)

0
0
#1
Options
8 Reply
Re:TP-Link Wireless MU-MIMO USB Adapter not work in usb3 mode! Need help!
2020-03-02 09:12:25 - last edited 2020-03-06 00:28:06

 

novahudonosor wrote

Hello everyone! My Archer connected to usb3 port (Lenovo desktop) but work in usb2! Drivers are old 2018 in website here, was trying them but still i have usb2. Someone can help me to find the right drivers? Thank you.)

@novahudonosor 

Hello,

 

Would you please tell us your computer's operating system? How do you know the adapter work in USB2? 

 

Please try to use this adapter in another USB port, if it is possible, you can change another computer to do a comparison test.

 

Have a good day.

0
0
#2
Options
Re:TP-Link Wireless MU-MIMO USB Adapter not work in usb3 mode! Need help!
2020-03-05 07:48:36

I have Windows 10 1809 and i now about usb from AIDA (see screenshot).

 

0
0
#3
Options
Re:TP-Link Wireless MU-MIMO USB Adapter not work in usb3 mode! Need help!
2020-03-11 03:01:48

@novahudonosor 

Hello, thanks for the info.

 

Please change the router's 5G channel width to 80MHz, with your computer connected to the 5G wifi, please check the wireless negotiation speed. Instruction as below:

https://www.tp-link.com/support/faq/2265/

 

Then check AIDA again.

 

0
0
#4
Options
Re:TP-Link Wireless MU-MIMO USB Adapter not work in usb3 mode! Need help!
2020-03-11 16:13:16 - last edited 2020-03-11 16:13:44

@Stella.Q  Please change the router's 5G channel width to 80MHz,

 

where? what 5G? this is not mobile router.)

explane please where and what to change?

 

P.S. now i have 130-144 Mbps.

0
0
#5
Options
Re:TP-Link Wireless MU-MIMO USB Adapter not work in usb3 mode! Need help!
2020-03-12 08:45:34
No, after restart this service this is still usb 2 mode.(
0
0
#7
Options
Re:TP-Link Wireless MU-MIMO USB Adapter not work in usb3 mode! Need help!
2020-03-14 06:42:51

Thank you but here https://weekly-geekly.github.io/articles/420845/index.html i didnt find my usb stick at all (Adapter in the system with a specific device, you can thanks to the information in the DriverDesc key: Adapter in the system with a specific device, you can thanks to the information in the DriverDesc key)!

In all needed registry sections (i have many). Maybe problems exactly here?

0
0
#9
Options
Re:TP-Link Wireless MU-MIMO USB Adapter not work in usb3 mode! Need help!
2020-03-16 07:25:23

@novahudonosor 

Hi, 

According to your current negotiation speed, it looks like you are connecting to the router's 2.4GHz wifi, USB 2.0 port can handle this speed, so the message shows the adapter is connecting to the 2.0 port.

If your router supports 5GHz wifi, it is suggested to connect to the 5GHz, if the negotiation speed is good enough, you will get the message that the adapter is connecting to the 3.0 port.

0
0
#11
Options
Re:TP-Link Wireless MU-MIMO USB Adapter not work in usb3 mode! Need help!
2021-05-18 07:58:48 - last edited 2021-05-18 09:38:04

 

novahudonosor wrote

Hello everyone! My Archer connected to usb3 port (Lenovo desktop) but work in usb2! Drivers are old 2018 in website here, was trying them but still i have usb2. Someone can help me to find the right drivers? Thank you.)

@novahudonosor It certainly seems to be evident that T4U usb 3 port is faulty or no connection is established with the usb 3 connectors of PC in spite of being connected to usb 3.... Its happening to me also... T4U usb 3 port is blocked somehow by tplink.. So port is getting connected by usb 2 mode. You should investigate why it is not getting connected by USB3 mode... The answer is simple... Usb3 connection is blocked in archer T4U. Now the question is whether TPlink will enable it via Dongle firmware update or not? Note this is not the Windows software, it is the firmware of the T4U hardware that needs to be fixed... If the internal connections of T4U's USB3 connectors are cut off during manufacture, then no firmware can correct this fault...

 So if T4U gets truly connected in usb3 mode in future then we all will get at least 100MB to 108MB per sec of transfer speed (equivalent to at least 800Mbps at 5GHz ac mode)... I am not talking about internet speed.. because if yor internet speed is 400Mbps you will get 400Mbps, if your internet speed is 1Gbps you will get 866 Mbps....which is equivalent to at least 100 to 108 MB per sec..

 

Please be informed that it  connects at 867Mbps at USB 2 mode where we will not get true usb 3 speed, instead we are getting usb 2 speed around 250Mbps (equivalent to 32 MB per sec) in spite of having 1Gbps broadband speed (equivalent to 125MB per sec).  

 

TP Link should state that T4U v 3.2 works only in usb2 mode as of now..

 

 

1
1
#12
Options