Deco P9 - Devices randomly go offline

Deco P9 - Devices randomly go offline
Deco P9 - Devices randomly go offline
2020-02-06 10:33:35 - last edited 2020-02-11 13:54:34
Model: Deco P9
Hardware Version: V1
Firmware Version: 1.0.2 BUILD 20190917 Rel. 71168

Hi 

 

Looking for some help please.

 

Ever since purcashing the Deco P9s, I have an issue where devices randomly stop working over wireless.

 

I have up to 20 devices connected to my home wireless solution, and at random times and locations around the house, a device will lose internet connectivity. However, the device does not disconnect from the wireless, and in most cases shows a full bar of wireless signal. During this period, if I try to ping the default gateway of the device, it times out. (I have the Deco in router mode so the Deco is acting as default gateway)

 

I have tried everything I can think to try and get this working, including the below.

 

- Reset Deco back to factory default.

- Removed meshed devices and just ran one Deco main device. 

- Switched from router mode to access, same timeout issue occurs but this time the gateway is my modem sitting behind the Deco.  

- Ran a network analyzer tool -

2.4Ghz running on channel 2, only a handful of other wireless signals on 11 so should be no co channel interference. 

5Ghz running on channel 36 - only one other wifi running on same channel but due to width of 5ghz channels, shouldn't be affected by interference. 

 

When I remove the Deco and put in my old wifi router, no issues at all (apart from signal in far ends of the house, hence me buying the Deco solution)

 

When a device does stop working over wireless, other devices over the wireless work fine. Also, if you leave the device 5-10 minutes, it will start working again. 

 

Has anyone experienced a similar issue, or have any ideas on the above before I end up giving up and buying something else.

 

Thanks

 

 

 

 

 

 

1
1
#1
Options
1 Accepted Solution
Re:Deco P9 - Devices randomly go offline-Solution
2020-02-11 13:35:44 - last edited 2020-02-11 13:54:34

@S13 I had the same issue as well. Randomly my Deco P9 would lose internet connection. So I switched out my modem and now everything is perfect. New modem Arris SBG-6900AC

Best Solution
1
1
#3
Options
7 Replies
Re:Deco P9 - Devices randomly go offline
2020-02-11 03:11:29

@S13 

 

Thanks for your information and time to do the troubleshooting by your side. We would do further analysis to locate this issue and try to fix it.

 

1. What is the current network diagram? How do you connect these devices?

 

2. Is it the specific device which goes offline? Or it is random?

 

3. Have you ever tried to forget the network on the offline devices and reconnect them to the Deco's network? Does it work?

 

4. You can reserve an IP address for the devices or setup the static IP for them to verify whether it works.

 

5. Besides, you can switch a slave Deco to main Deco to test its performance. Click here to get the instruction.

 

May it help.

0
0
#2
Options
Re:Deco P9 - Devices randomly go offline-Solution
2020-02-11 13:35:44 - last edited 2020-02-11 13:54:34

@S13 I had the same issue as well. Randomly my Deco P9 would lose internet connection. So I switched out my modem and now everything is perfect. New modem Arris SBG-6900AC

Best Solution
1
1
#3
Options
Re:Deco P9 - Devices randomly go offline
2020-02-11 13:54:29

@Wire011 Thanks Wire011, that was something I was considering and will try. 

0
0
#4
Options
Re:Deco P9 - Devices randomly go offline
2020-02-11 14:08:26

@S13 No problem. If you happen to go with that one you'll want to turn off the router functionality and have it just operate as a modem.

1
1
#5
Options
Re:Deco P9 - Devices randomly go offline
2020-02-11 15:42:00

@Kevin_Z Hi, please see below.

 

1. What is the current network diagram? How do you connect these devices?

Main Deco (Living Room in front of house connected to modem) >>>>>>>> Slave Deco (back of kitchen, connected via wireless >>>>>> Slave Deco (in garage office, connected via wireless) All located on ground floor. 

 

2. Is it the specific device which goes offline? Or it is random?

It is any random device, can be phone, tablet, CCTV camera, etc.

 

3. Have you ever tried to forget the network on the offline devices and reconnect them to the Deco's network? Does it work?

Yes, also factory reset the Decos and changed SSID name. Still experience the same issue. 

 

4. You can reserve an IP address for the devices or setup the static IP for them to verify whether it works.

Yes, tried on static and DHCP. 

 

5. Besides, you can switch a slave Deco to main Deco to test its performance. Click here to get the instruction.

Have tried both slaves as main, also tried just one main with no slaves. 

0
0
#6
Options
Re:Deco P9 - Devices randomly go offline
2020-02-12 01:36:45

@S13 

 

Thanks for your valued reply.

 

You mentioned that the devices are still connected to the Wi-Fi even though there is no internet access; may I know do they obtain valid IP address and gateway from Deco at that way? And what are they? You can show us a screenshot of it.

 

Besides, as discussed above, you can change another modem to test its performance if possible,

 

Best regards.

0
0
#7
Options
Re:Deco P9 - Devices randomly go offline
2020-08-13 17:17:09

@S13 

 

Same issue here. I use Deco P9 in access point mode. When issue happens it's always the same, there is no more connection between main Deco and the modem. The modem show connected IP for the two secondary Deco P9 but no more for the main, seems that main deco lost its IP. Once all rebooted, the main Deco P9 got back an IP adress and a connection and then it works.

 

I am trying to put static IP adress to the main Deco P9...modem is still in DHCP except for the Mac address of main Deco P9 which has now a static IP...

 

hope it's the solution...time will tell...

0
0
#8
Options