TL-WPA8630 v2.0 : No powerline signal issue / can this be used as “solo extender”

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
TL-WPA8630 v2.0 : No powerline signal issue / can this be used as “solo extender”
TL-WPA8630 v2.0 : No powerline signal issue / can this be used as “solo extender”
2020-05-04 17:06:55 - last edited 2020-05-04 17:08:01
Model: TL-WPA8630 KIT  
Hardware Version: V2
Firmware Version: 2.0.2 build 20171017

Hi guys,

 

Need some help here. I just got this powerline kit, TL-WPA8630 kit comes with;

 i) Powerline Adapter  (PA)

ii) Powerline Extender (PE)

 

 When plugged in both in the same room,

- the PA's powerline led lits up for like a minute, then turns off.

- the PE's powerline led doesn't light at all

Using WPS function, the PE was able to copy the exising ssid from the main router. Still, no internet connection.

...faulty PE?
 

Then, installed the TPplc utility on windows, used a lan cable to connect directly to PA.

TPplc detects the PA, but i cannot add the PE manually (doesn't detect..because no powerline connection i guess). Next, i connect the pc to PE using lan cable, TPplc utility cannot detect the PE.

Do i have a faulty PE here? How many years of warranty do this kit comes with? @TP-link malaysia

 

On a sidenote, can the PE work as a solo extender like the RE305 or TL-WA855RE? ..tips are welcome

  0      
  0      
#1
Options