AX50 AX3000 router "low-security WiFi" on latest iOS 14.0.1

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

AX50 AX3000 router "low-security WiFi" on latest iOS 14.0.1

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
AX50 AX3000 router "low-security WiFi" on latest iOS 14.0.1
AX50 AX3000 router "low-security WiFi" on latest iOS 14.0.1
2020-10-08 02:21:26 - last edited 2020-10-21 12:12:27
Model: Archer AX50  
Hardware Version: V1
Firmware Version: 1.0.9

Hi,

 

I just bought an Archer AX50 router yesterday.  Everything was set and when I connect my iPhone 11 running on IOS 14.0.1 to the router, it shows "low-security wifi".  It happens on my whole family's iPhone.

 

I am unable to find any option in the router setup page to enable or disable anything about the connection security (wpa or wpa2, etc).  Is this normal?  I mean even my old router bought on a couple of years ago was equipped with such an option.   

 

Can I still consider my connection with this Archer AX50 is secured?

 

Any help is highly appreciated.

 

Thanks

Hicks

 

  0      
  0      
#1
Options
2 Accepted Solutions
Re:AX50 AX3000 router "low-security WiFi" on latest iOS 14.0.1-Solution
2020-10-21 12:12:21 - last edited 2020-10-21 12:12:27

@marines 

 

Hi, this is because iOS14 and some new operating systems consider other than the latest WPA3 and WPA2 AES to have security issues. It is suggested to modify and change the wireless security on the AX50 to WPA2-PSK, AES:

If you found a post or response helpful, please click Helpful (arrow pointing upward icon). If you are the author of a topic, remember to mark a helpful reply as the "Recommended Solution" (star icon) so that others can benefit from it.
Recommended Solution
  1  
  1  
#2
Options
Re:AX50 AX3000 router "low-security WiFi" on latest iOS 14.0.1-Solution
2021-02-16 06:06:14 - last edited 2021-02-19 02:48:24
Ah hah! Didn’t realize I had to do that for both! That seems to have resolved it. Thanks!
Recommended Solution
  0  
  0  
#7
Options
7 Reply
Re:AX50 AX3000 router "low-security WiFi" on latest iOS 14.0.1-Solution
2020-10-21 12:12:21 - last edited 2020-10-21 12:12:27

@marines 

 

Hi, this is because iOS14 and some new operating systems consider other than the latest WPA3 and WPA2 AES to have security issues. It is suggested to modify and change the wireless security on the AX50 to WPA2-PSK, AES:

If you found a post or response helpful, please click Helpful (arrow pointing upward icon). If you are the author of a topic, remember to mark a helpful reply as the "Recommended Solution" (star icon) so that others can benefit from it.
Recommended Solution
  1  
  1  
#2
Options
Re:AX50 AX3000 router "low-security WiFi" on latest iOS 14.0.1
2021-02-13 15:22:55

@Kevin_Z :

 

I have completed these setting changes on my AX 3000, but I still get the message. 
 

Any way to resolve this?

  0  
  0  
#3
Options
Re:AX50 AX3000 router "low-security WiFi" on latest iOS 14.0.1
2021-02-13 17:55:18
Have you rebooted the router to force all your wireless devices to reconnect ?
If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
  0  
  0  
#4
Options
Re:AX50 AX3000 router "low-security WiFi" on latest iOS 14.0.1
2021-02-16 02:42:41
Yep, tried that with no luck. Strangely the iPhone sometimes does not show that message, but then it returns.
  0  
  0  
#5
Options
Re:AX50 AX3000 router "low-security WiFi" on latest iOS 14.0.1
2021-02-16 03:25:29
Did you set these security parameters for both 2.4GHz & 5Ghz bands ?
If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
  3  
  3  
#6
Options
Re:AX50 AX3000 router "low-security WiFi" on latest iOS 14.0.1-Solution
2021-02-16 06:06:14 - last edited 2021-02-19 02:48:24
Ah hah! Didn’t realize I had to do that for both! That seems to have resolved it. Thanks!
Recommended Solution
  0  
  0  
#7
Options
Re:AX50 AX3000 router "low-security WiFi" on latest iOS 14.0.1
2021-02-16 12:51:32
From Kevin's screenshot is not clear that both bands have to be modified if you are not using Smart Connect feature.
If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
  0  
  0  
#8
Options

Information

Helpful: 0

Views: 2878

Replies: 7

Related Articles