MR3220 disconnects LTE modem

MR3220 disconnects LTE modem
MR3220 disconnects LTE modem
2013-03-16 17:54:22
Region : UnitedKingdom

Model : TL-MR3220

Hardware Version : V2

Firmware Version : 121126 Rel.70304n (BETA)

ISP : T-mobile


Hello,

there is a bug with MR3220 Router. I have HUAWEI E398 modem. It makes a LTE connections, everything works OK for half an hour, sometimes for a couple of hours, but then it (router)
just unplugs modem after some time.

Here is log:

1st day 00:44:50 DHCP NOTICE DHCPS:Recv DISCOVER from 8C:70:5A:8F:F0:E0
1st day 00:34:47 3G/4G NOTICE modemUnplugedTime >=60s
1st day 00:33:51 3G/4G INFO 3G Modem is plugged out.
1st day 00:33:49 3G/4G NOTICE dhcpcLteModemRelease 1261 sysCmd = ifconfig lte0 0.0.0.0
1st day 00:33:48 DHCP INFO dhcpc_ipc_data_rcv_router 675 : current network type = 1
1st day 00:33:48 DHCP NOTICE DHCPC Entering released state
1st day 00:33:48 DHCP NOTICE DHCPC Unicasting a release of 178.160.9.196 to 178.160.9.193
1st day 00:33:47 3G/4G INFO process_msg 322 : call dhcpcLteModemRelease
1st day 00:33:47 3G/4G INFO LTE MODEM = 0, status = 0, targetVendorID = 0x0, targetProductID = 0x0
1st day 00:33:47 3G/4G INFO LTE MODEM = 0, status = 1, targetVendorID = 0x0, targetProductID = 0x0
1st day 00:33:47 3G/4G NOTICE handle_card start
1st day 00:01:08 DHCP WARNING LTE Network connected.
1st day 00:01:06 DHCP INFO Update DNS1 = 0x57fc9c19, DNS2=0xa30411e
0
0
#1
Options
5 Replies
Re:MR3220 disconnects LTE modem
2013-03-16 20:38:21
Uh, it seems that they are not quite compatible. Why not try the bin file for your modem on tp-link website?
0
0
#2
Options
Re:MR3220 disconnects LTE modem
2013-03-17 05:23:48
Hi,

There is growing evidence that some of the newer LTE modems appear to exceed the TP-Link router USB power source, causing a variety of problems.

This only occurs in weak signal areas when the modem is at maximum transmit power.

Is your signal weak?

Try a USB Y-cable


and connect it to a 2nd source of USB power.
0
0
#3
Options
Re:MR3220 disconnects LTE modem
2013-03-17 05:58:02
It seems to me that problem is when 4G is idle for a longer period, than router disconnects LTE dongle.
I've turned on my PC connected via cable and left web browser with page that has some streaming and now it hasn't disconnected for more than 4 hours.
By the way, signal is very good (around 80%)
0
0
#4
Options
Re:MR3220 disconnects LTE modem
2013-03-17 06:03:46

Miss Lucky wrote

Uh, it seems that they are not quite compatible. Why not try the bin file for your modem on tp-link website?


How can you say that they are incompatible when 4G router made a connection within 20 seconds after boot and then worked fine for 31 minutes?
0
0
#5
Options
Re:MR3220 disconnects LTE modem
2013-03-17 06:44:46

Wahroonga Farm wrote

Hi,

There is growing evidence that some of the newer LTE modems appear to exceed the TP-Link router USB power source, causing a variety of problems.

This only occurs in weak signal areas when the modem is at maximum transmit power.

Is your signal weak?

Try a USB Y-cable


and connect it to a 2nd source of USB power.


It seems that you'rw right.

I've had a 3m USB cable and I've noticed that it disconnected modem when I went to speedtest.net.

Now when I plug modem directly to USB and try speedtest.net, everything works OK, it's just that I get lower speeds because signal is weaker. :-(

This is really a discrase from tp-link.

I've had MR3420 v1 and it didn't had this kind of problem. It only had limited LTE speed to max 12 Mbit/s (I can get 22 Mbit/s where I live).
0
0
#6
Options