TL-MR3420 3G/4G >>> Internet Access MODE CHANGE ISSUE

TL-MR3420 3G/4G >>> Internet Access MODE CHANGE ISSUE
TL-MR3420 3G/4G >>> Internet Access MODE CHANGE ISSUE
2013-04-22 00:59:42
Region : Others

Model : TL-MR3220

Hardware Version : V2

Firmware Version : 3.13.24 Build 120703 Rel.55807n

ISP :


Hello Support Community,

I purchased TL-MR3420 3G/4G Router yesterday.

I am facing a following issue:

I have attached 3G device and WAN with router using WAN Preferred Mode but it is not working properly. WAN should be given priority but It shows 0.0.0.0 most of time and always connected to 3G.

Are there any specific conditions on which this quick switch from 3G to WAN and WAN to 3G is done?

For example, WAN responds late to Router...
Even if WAN responds late, once router gain access to WAN, it should be switched to WAN.

Please guide me or I have to claim WARRANTY.

Please respond me as soon as possible.
0
0
#1
Options
17 Reply
Re:TL-MR3420 3G/4G >>> Internet Access MODE CHANGE ISSUE
2013-04-27 16:22:36
what if you disconnect the 3G device, set wan only, can you get wan ip address automatically?
0
0
#2
Options
Re:TL-MR3420 3G/4G >>> Internet Access MODE CHANGE ISSUE
2013-05-07 02:03:08
Hello Michael,

Yes, I can get the IP when on LAN but internet does not work, but sometimes this fix the problem after restarting router.

Yesterday, I updated Firmware too to latest one.

Following is setting:

1. Internet access mode is set to "Wan preferred ".
2- 3G Modem is set to " Connect Automatically".

We face electricity issue here and I am using UPS for Router.

When electricity is down, WAN connection is lost and 3G is connected automatically.
BUT
When electricity is back, WAN is restored but no IP is assigned through WAN, it does not shift to WAN, it keeps connected 3G Modem.

I have written in detail about the setting. Should I set 3G Modem settings to " Connected on Demand". I am really sick of this problem. I do not know why it does not work and keeps connected to 3G Modem.

I have written to TP Link support, but they just returned automated email about HOLIDAYS " We are on holidays ... bla bla ". I would request TP Link Support Team to help me in this problem or tell me exact settings. OR if someone is experiencing this problem and solved it, Please let me know about it.

Thanks in advance .

Regards,
Saqib
0
0
#3
Options
Re:TL-MR3420 3G/4G >>> Internet Access MODE CHANGE ISSUE
2013-05-07 05:38:56

saqib wrote

Hello Michael,

Yes, I can get the IP when on LAN but internet does not work, but sometimes this fix the problem after restarting router.

Yesterday, I updated Firmware too to latest one.

Following is setting:

1. Internet access mode is set to "Wan preferred ".
2- 3G Modem is set to " Connect Automatically".

We face electricity issue here and I am using UPS for Router.

When electricity is down, WAN connection is lost and 3G is connected automatically.
BUT
When electricity is back, WAN is restored but no IP is assigned through WAN, it does not shift to WAN, it keeps connected 3G Modem.

I have written in detail about the setting. Should I set 3G Modem settings to " Connected on Demand". I am really sick of this problem. I do not know why it does not work and keeps connected to 3G Modem.

I have written to TP Link support, but they just returned automated email about HOLIDAYS " We are on holidays ... bla bla ". I would request TP Link Support Team to help me in this problem or tell me exact settings. OR if someone is experiencing this problem and solved it, Please let me know about it.

Thanks in advance .

Regards,
Saqib


I have the exact same problem with my TL-MR3420

Luca
0
0
#4
Options
exactly the same problem
2014-05-17 00:29:57
i have exactly the same problem ! " When ADSL (WAN) connectivity is back, no IP is assigned through WAN, it does not shift to WAN, it keeps connected 3G Modem."

it switches to WAN only if the ethernet cable is unplugged and plugged again.

my TL-MR3420 is loaded with new firmware : 3.14.9 Build 140319 Rel.38485n

i thought that i was using some other ADSL router, so i switched to TP-LINK's TD8816 on the ADSL end. still, it does not work.

WAN is on Dynamic IP address
0
0
#5
Options
Similar issue
2014-09-11 22:32:43
I do have a similar issue.

When "Internet Access" set to "WAN Preferred", connection is made on the modem, but it never reverts to WAN, unless the cable is physically re-plugged.

Is TP-LINK reading the forum or do I need to write to support? What's the address?

Thanks.
0
0
#6
Options
Same issue
2015-11-20 07:28:05
Hi Everyone,

I also have exactly the same issue with the latest firmware!

TP-LINK please respond ASAP with a fix to this issue!

Regards,
Zoltan
0
0
#7
Options
Replay
2015-11-20 12:10:56
I hope everyone can be patient and wait for a reply from the admin. Patient man more beloved by Allah
0
0
#8
Options
Same problem !
2015-12-07 20:08:55
Hi,
I have the same issue ! It is even more a frustration that the witch to 3G is very fast to occur but need a manual opearation to switch back to wan and not use all 3G data.
Only way to solve I have a to switch off the router every day using programmable plug...
This is not such a good solution !
Is TP Link going to solve this ?
Do you have any other solution ?
Thanks
0
0
#9
Options
Re:TL-MR3420 3G/4G >>> Internet Access MODE CHANGE ISSUE
2015-12-07 20:25:01
Do you have any configuration that works (DHCP, fix IP, etc ) ?
Thanks
0
0
#10
Options
Re:TL-MR3420 3G/4G >>> Internet Access MODE CHANGE ISSUE
2015-12-22 15:40:17
I asked tp-link and they said they will release a firmware to solve the problem later.
Maybe we can try the new firmware when it released.
0
0
#11
Options