ZTE MF637U Modem not working with EDGE

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
ZTE MF637U Modem not working with EDGE
ZTE MF637U Modem not working with EDGE
2013-04-22 16:17:45
Region : Others

Model : TL-MR3420

Hardware Version : V2

Firmware Version :

ISP : YU KENYA


Hi guys,most service providers in our country dont have 3G or 4G support,but all the same i bought an MR3420 router in the hopes that since my modem is listed,it would still connect even if on an EDGE/2G network like YU-Kenya.But this is not the case,the router does not recognize the modem i.e it says the modem is unplugged but when i look at the logs,it indicated it detected the modem but LTE was set to zero.Please assist by providing a modem bin file for compatibility under EDGE/2G connection otherwise my router will be of no use to me.
0
0
#1
Options
2 Reply
Re:ZTE MF637U Modem not working with EDGE
2013-04-27 15:52:23
have you checked the bin file center on tplink website?
http://www.tp-link.com/en/support/3g/
0
0
#2
Options
Re:ZTE MF637U Modem not working with EDGE
2013-04-29 02:45:44

Michael Grange wrote

have you checked the bin file center on tplink website?
http://www.tp-link.com/en/support/3g/


Yes i have checked the above link for any bin files related to my particular modem model,and i haven't
found any.From the router log it indicates that the modem is detected but 'lte=0' which might mean that
backward compatibility with 2G networks is disabled for this particular modem type.
I would appreciate if someone could provide a bin file for ZTE MF637U Modem to make it compatible
with the router under EDGE coz in my country it means more and more people will continue
buying the router without realising that it will never work with their modem.Thanks.
0
0
#3
Options