Archer C6 connection issues

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Archer C6 connection issues

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer C6 connection issues
Archer C6 connection issues
2022-08-25 19:04:39
Tags: #internet
Model: Archer C6  
Hardware Version: V3
Firmware Version: 1.0.14

Hello,

 

I have Archer C6 AC1200 MU-MIMO WiFi router. Ver 3.2 

I have a problem that while I can see the network itself, I cannot connect to it. 

 

I have tried several solutions and none of them worked:

- I tried to configure everything through the app, it seems that all is set, no problems configuring the router, but the internet is not there. All devices can connect to the network but it says 'No internet connection. 

- I have tried configuring on the browser. Then I encounter a different problem which might be the main source. While doing a quick set up, I cannot finnish it. I get stuck on the 'summary' step because I can't connect to the newly renamed network. It goes on and never connects. I therefore cannot finnish the set up. 

I tried to reset to factory settings, turn it on/off, add 8.8.8.8 to the optional fields, nothing seems to work.

  0      
  0      
#1
Options
6 Reply
Re:Archer C6 connection issues
2022-08-25 23:35:45

  @Setsuna 

 

Hi,

 

I seems to me there is a problem with the configuration of the Internet connection. Has the "Internet" LED (the rightmost one) ever lid up in green color or has it always been orange?

 

Anyway, what connection type are you required to use to connect to your ISP's Internet connection?

 

Is it "Dynamic IP" or "PPPoE" or something else?

 

Are you replacing another existing router that was working fine or is this a first-time setup of a new Internet connection? 

 

 

By the way, when setting up a router using a computer it is favorable to connect it via Ethernet cable, to avoid being disconnected from the router every time certain network settings are changed.

 

  3  
  3  
#2
Options
Re:Archer C6 connection issues
2022-08-26 21:14:23

  @woozle 

 

That light was always green. 

 

The connection type should be dynamic IP. 

 

Yes, I am replacing an existing (non-TP) router. 

 

Thanks for the suggestion of using the cable. I've never done it before and now my computer has no wlan port, so I can neither use the Internet without router nor set the router using the provided cable. I guess I'll just have to borrow an adapter from a friend. 

  0  
  0  
#3
Options
Re:Archer C6 connection issues
2022-08-26 23:47:23

  @Setsuna 

 

Hi,

 

Do you mean the "Internet" LED (globe with orbiter symbol) of the Archer C6 router is already green right after startup of the router, without modifying any settings?

 

Normally a green "Internet" LED is a quite reliable indicator for a working Internet connection.

 

Did you actually try to open any Internet website before you went through the "Quick Setup" thing for the first time?

 

Could you do the following test?

- While the router is powered on, reset the Archer C6 to Factory Default Settings by pressing and holding the physical "Reset" button for >5 seconds. (until you notice some distinct resonse from the router's LEDs)
- Wait for the router to boot up again and the "Internet" LED to turn green.
- Connect a computer, phone or tablet to the Wi-Fi of the Archer C6 (TP-Link_xxxx or TP-Link_xxxx_5G) using the wireless password that is printed on the label on the underside of the router.
- Open a web browser and try to open any website you can think of. (for example www.tp-link.com)

 

Does the website open or not?

 

  0  
  0  
#4
Options
Re:Archer C6 connection issues
2022-08-28 10:54:29

  @woozle 

 

Yes, the light is green a few moments after turning on the router.

 

I've tried resetting to factory settings plenty of times. Neither before the reset nor after none of the websites are loading.

 

I've also tried your suggestion of using the ethernet cable. This time I managed to complete the quick set up with no issues, however, the result is still the same, once connected to the network it displays a message 'no Internet connection'.  

  0  
  0  
#5
Options
Re:Archer C6 connection issues
2022-08-28 15:49:57

  @Setsuna 

 

Then it looks like setting up an Internet connection with your ISP is not just plug&play and instead requires a special configuration.

 

Do you remember how your previous router got connected to this Internet? Was that router handed to you by the ISP or configured by the ISP?

 

Could you tell us the name of your ISP and the type of broadband service?

 

What you could do is to log into the configuration webpage of your old working router, look up all settings related to the Internet connection and then try to replicate each setting on your new Archer C6 router.

 

You could also test if "cloning" the old router's MAC address to the Archer C6 makes any difference. 
To do that obtain the MAC address of the old router's WAN port and then on the Archer C6 enter it under "Advanced" > "Network" > "Internet" > "Use Custom MAC Address".

 

  0  
  0  
#6
Options
Re:Archer C6 connection issues
2022-08-30 07:33:24

  @woozle 

Thank you for your help, as you correctly guessed, the provider probably had some kind of block or something put on the new routers, as when I called them they just told me to try setting the new router a few minutes after the call and then it worked with no problems. I set it up exactly the same as all the other times and I didn't even need to use Ethernet connection.

 

As for your suggestion of cloning MAC address, did that too (before calling) and it didn't help. 

 

The internet provider is Penki (Lithuania). 

  0  
  0  
#7
Options

Information

Helpful: 0

Views: 494

Replies: 6

Tags

internet
Related Articles