2.4 Ghz ssid doesnt connect

2.4 Ghz ssid doesnt connect

2.4 Ghz ssid doesnt connect
2.4 Ghz ssid doesnt connect
2022-09-29 15:34:39
Model: Archer GX90  
Hardware Version: V1
Firmware Version: 1.1.0 Build 20220228 rel.60482(5553)

Hi All

 

i bought a new Archer GX90 triband router from amazon july this year. everything was working fine until 3 days ago. 2.4 Ghz SSID regular and guest cannot be connected on any devices it simply gives an error message connection failure.

 

working with support  i had done below already but, none helped resolve the issue.

 

1. changed SSId

2. changed ssid password

3. power recycled

4. changed channels

5. changed bandwidth from Auto to 20 Mhz

6. lastly did a factory reset and reestablished.

 

i have a very simply setup none of the advanced stuff. My wired n/w is still is good as it was day 1 and my 5G1 and 5G2 are working fine too.the issue is only with 2.4 i see the ssid's but unable to connect. i am update to date on all firmware and related stuff.

 

i am not using wpa3 i am still on wpa/wpa2-personal and version wpa-psk/wpa2-psk Encryption AES for all 3 bands.

 

TP link support had no other suggestions other than a RMA so that is in process but, i did see couple of posts the new equipment still had issues so i am looking for advice suggestions if you have been though this and how you resolved it.

 

really appreciate your help

  0      
  0      
#1
Options
1 Reply
Re:2.4 Ghz ssid doesnt connect
2022-09-30 06:54:49

@ragsgold 

 

Thank you for reaching out to us and welcome to the TP-Link community.

 

Regarding this particular model, GX90, I honestly haven't heard of a similar issue that the 2.4G network would stop working. I would suggest waiting for the replacement, then trying to observe if that would work properly.

 

Do let the community know if there is still an issue or anything new comes up.

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#2
Options

Information

Helpful: 0

Views: 63

Replies: 1

Related Articles