Low internet speed when connected to router, but high when connected to modem?

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Low internet speed when connected to router, but high when connected to modem?

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Low internet speed when connected to router, but high when connected to modem?
Low internet speed when connected to router, but high when connected to modem?
2022-11-02 13:31:58 - last edited 2022-11-08 11:40:21
Model: Archer AX50  
Hardware Version: V1
Firmware Version: 1.0.11 Build 20210730 rel.54485(5553)

I currently have a 300Mbps connection contract with my ISP (actually it is 500-600Mbps), but if I test the speed using Oklaa Speetest with my notebook connected to the router, I get about 170-200Mbps. If I connect the Ethernet cable to the modem, I get almost 600Mbps. 

 

The same happens for both wired and wireless connections sad

 

I tried changing the MTU (from 1500 to 1472): same results

Also, I set the bandwidth limit to 1000Mbps for both upload and download: same results

 

Can you help?

 

TIA

  0      
  0      
#1
Options
1 Accepted Solution
Re:Low internet speed when connected to router, but high when connected to modem?-Solution
2022-11-08 01:46:27 - last edited 2022-11-08 11:40:21

@vazquezjm 

 

Have you ever modified the QoS settings on the AX50? If yes, try turning it off and follow the guide below to be sure all of the settings are configured correctly:

How to turn off the QoS feature on TP-Link Router

 

Or you can reset the AX50 to factory defaults to exclude all the customized settings and reconfigure it from scratch to see if the speed will be normal. If yes, then try to modify and change settings as requested one at a time to find out which one affects the speed on the router.

If my reply helps with the issue, please click on the arrow pointing upward. If it solves your issue, please click the star to mark it as a "Recommended Solution".
Recommended Solution
  5  
  5  
#5
Options
6 Reply
Re:Low internet speed when connected to router, but high when connected to modem?
2022-11-04 06:00:16

@vazquezjm 

 

Are you using the built-in Oklaa Speetest on the web page or from the Tether app? I believe that may not be accurate since you cannot choose the best speetest server in your area.

 

Try using speedtest app or speedtest.com to monitor and test the actual speed.

If my reply helps with the issue, please click on the arrow pointing upward. If it solves your issue, please click the star to mark it as a "Recommended Solution".
  0  
  0  
#2
Options
Re:Low internet speed when connected to router, but high when connected to modem?
2022-11-04 12:04:29

 

Liverpool20 wrote

@vazquezjm 

 

Are you using the built-in Oklaa Speetest on the web page or from the Tether app? I believe that may not be accurate since you cannot choose the best speetest server in your area.

 

I'm using speedtest.com from a laptop connected to the router or modem.

 

  0  
  0  
#3
Options
Re:Low internet speed when connected to router, but high when connected to modem?
2022-11-07 12:40:32

I'm still experiencing this issue. Is anyone from TP-Link Suport around? 

  0  
  0  
#4
Options
Re:Low internet speed when connected to router, but high when connected to modem?-Solution
2022-11-08 01:46:27 - last edited 2022-11-08 11:40:21

@vazquezjm 

 

Have you ever modified the QoS settings on the AX50? If yes, try turning it off and follow the guide below to be sure all of the settings are configured correctly:

How to turn off the QoS feature on TP-Link Router

 

Or you can reset the AX50 to factory defaults to exclude all the customized settings and reconfigure it from scratch to see if the speed will be normal. If yes, then try to modify and change settings as requested one at a time to find out which one affects the speed on the router.

If my reply helps with the issue, please click on the arrow pointing upward. If it solves your issue, please click the star to mark it as a "Recommended Solution".
Recommended Solution
  5  
  5  
#5
Options
Re:Low internet speed when connected to router, but high when connected to modem?
2022-11-08 11:40:17

Liverpool20 wrote
 

Have you ever modified the QoS settings on the AX50? If yes, try turning it off and follow the guide below to be sure all of the settings are configured correctly:

How to turn off the QoS feature on TP-Link Router

 

You're the man!! That was it!  

 

I've been struggling with this for so long. I set the bandwidth to 999Mbps in the past but had some devices with priority set and never thought that was affecting the whole LAN speed.

 

Thanks @Liverpool20 !

  4  
  4  
#6
Options
Re:Low internet speed when connected to router, but high when connected to modem?
2022-11-08 11:59:55

@vazquezjm 

Happy to know that helps! Enjoy your router and internet, bro.laugh

If my reply helps with the issue, please click on the arrow pointing upward. If it solves your issue, please click the star to mark it as a "Recommended Solution".
  1  
  1  
#7
Options

Information

Helpful: 0

Views: 505

Replies: 6