Speed Issue on my TP-Link Deco M4R(4.0) 2pcs set

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Speed Issue on my TP-Link Deco M4R(4.0) 2pcs set

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Speed Issue on my TP-Link Deco M4R(4.0) 2pcs set
Speed Issue on my TP-Link Deco M4R(4.0) 2pcs set
2023-01-12 13:04:47
Tags: #Deco M4 Problem
Model: Deco M4  
Hardware Version: V4
Firmware Version: 1.0.2 Build 20220401 Rel. 35920

Hello,

I am new and just joined. If I make any mistakes please do let me know. Thank you.

 

I have a pair of Deco M4 routers . Recently I am facing a really weird problem with my decos. The main deco works perfectly fine with any kind of devices but the problem starts with the second deco. Any kind of PC or Laptop connected with my second deco works great with excellent speed but when any android Mobile devices gets connected to the second deco the net speed on those devices are slow as hell. The things i have tried to solve the problems are as follows:

 

1. Interchanged the two Decos.

2. Interchanged the chargers (Not like it matters though)

3. Made both wireless and wired connections between the two Decos.

4. Have fiddled around with the limited settings that Deco App enables us to change

5. Also changed my modem out of curiosity.

6. Contacted with Tp-link Bangladesh they didn't understand the problem

7. Can't update to any new Firmware as deco app shows its the latest   

8. Have tried with many other Mobile devices shows similar Issue 

 

Please any kind of help and suggestions will be great.

Thank you.

 

File:
speed test report.pdfDownload
  0      
  0      
#1
Options
2 Reply
Re:Speed Issue on my TP-Link Deco M4R(4.0) 2pcs set
2023-01-13 03:43:39

  @Rafid317 

Hi, welcome to the community.

Can I have the model number of the Android devices?

Have you checked the wireless link speed when they are connected to the second Deco M4:

How to check the associated/link speed on a wireless client

Please try to turn off "Mesh Technology" of the Android mobile devices on the Deco APP to see whether it helped.

By the way, were you having the same issue before updating to Deco?

Thank you very much.

Best regards.

  0  
  0  
#2
Options
Re:Speed Issue on my TP-Link Deco M4R(4.0) 2pcs set
2023-01-13 06:22:09 - last edited 2023-01-13 06:23:48

Thank you @David-Tp for your quick reply

 

1. I have tested with different phones like Oneplus (7 pro & 5T), Xiaomi, Samsung and Realme sets. All the phones experienced severe slow internet while connected to the 2nd deco

2. The wireless link speed shows 780Mbps

3.Yes I have turned off Mesh technology for the mobile devices but the problem still persists.

4. I didn't update any firmware though it came with this firmware.

 

I hope this are the inquiries you asked for. I am very puzzled with this issue. I have used about 5 Tp-link routers upto now, none have any problems accept this. I am guessing this is a firmware or software issue because clearly its not a hardware issue as device interchanging and wired connection didn't solve it and also laptops and computers works great with the 2nd deco.

  0  
  0  
#3
Options

Information

Helpful: 0

Views: 323

Replies: 2

Tags

Deco M4 Problem